Updated to NetHack 3.6.2

This commit is contained in:
Ron Olson 2019-05-13 20:15:52 -05:00
parent 70178873ce
commit ce6537be54
9 changed files with 92 additions and 1296 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
nethack-343-src.tgz
/nethack-360-src.tgz
/nethack-361-src.tgz
/nethack-362-src.tgz

View File

@ -1,11 +0,0 @@
--- sys/unix/Makefile.top.orig 2018-05-02 15:01:59.419155535 -0500
+++ sys/unix/Makefile.top 2018-05-02 15:02:52.288507817 -0500
@@ -49,7 +49,7 @@
# per discussion in Install.X11 and Install.Qt
#VARDATND =
# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm
-# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm rip.xpm
+VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm rip.xpm
# for Atari/Gem
# VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
# for BeOS

File diff suppressed because it is too large Load Diff

View File

@ -1,24 +1,17 @@
--- include/config.h.orig 2016-10-02 19:21:02.647428093 -0500
+++ include/config.h 2016-10-02 19:23:17.090421679 -0500
@@ -43,7 +43,7 @@
--- include/config.h.orig 2019-05-13 10:47:48.545839681 -0500
+++ include/config.h 2019-05-13 15:46:04.080338820 -0500
@@ -45,8 +45,8 @@
#if !defined(NOTTYGRAPHICS)
#define TTY_GRAPHICS /* good old tty based graphics */
#endif
-/* #define CURSES_GRAPHICS *//* Curses interface - Karl Garrison*/
-/* #define X11_GRAPHICS */ /* X11 interface */
+#define X11_GRAPHICS /* X11 interface */
+#define CURSES_GRAPHICS /* Curses interface - Karl Garrison*/
+#define X11_GRAPHICS /* X11 interface */
/* #define QT_GRAPHICS */ /* Qt interface */
/* #define GNOME_GRAPHICS */ /* Gnome interface */
/* #define MSWIN_GRAPHICS */ /* Windows NT, CE, Graphics */
@@ -125,7 +125,7 @@
* would allow:
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
*/
-/* # define USE_XPM */ /* Disable if you do not have the XPM library */
+# define USE_XPM /* Disable if you do not have the XPM library */
#ifdef USE_XPM
#define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
#endif
@@ -250,11 +250,11 @@
@@ -263,11 +263,11 @@
#if defined(UNIX) && !defined(ZLIB_COMP) && !defined(COMPRESS)
/* path and file name extension for compression program */
@ -29,14 +22,23 @@
/* An example of one alternative you might want to use: */
-/* #define COMPRESS "/usr/local/bin/gzip" */ /* FSF gzip compression */
-/* #define COMPRESS_EXTENSION ".gz" */ /* normal gzip extension */
+#define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
+#define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+#define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
+#define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
#endif
#ifndef COMPRESS
--- include/unixconf.h.orig 2015-11-17 04:54:25.000000000 -0600
+++ include/unixconf.h 2017-05-22 13:48:46.766291818 -0500
@@ -104,7 +104,7 @@
@@ -311,7 +311,7 @@
* a tar-like file, thus making a neater installation. See *conf.h
* for detailed configuration.
*/
-/* #define DLB */ /* not supported on all platforms */
+#define DLB /* not supported on all platforms */
/*
* Defining REPRODUCIBLE_BUILD causes 'util/makedefs -v' to construct
--- include/unixconf.h.orig 2019-05-13 10:48:00.595904458 -0500
+++ include/unixconf.h 2019-05-13 19:38:45.882219484 -0500
@@ -106,7 +106,7 @@
* If you want the static parts of your playground on a read-only file
* system, define VAR_PLAYGROUND to be where the variable parts are kept.
*/
@ -45,7 +47,7 @@
/*
* Define DEF_PAGER as your default pager, e.g. "/bin/cat" or "/usr/ucb/more"
@@ -131,7 +131,7 @@
@@ -133,7 +133,7 @@
* "extra output" method is used, but not all systems provide access to
* a fine-grained timer.
*/

View File

@ -1,5 +1,5 @@
--- sys/unix/Makefile.doc.orig 2018-05-02 15:30:26.382529453 -0500
+++ sys/unix/Makefile.doc 2018-05-02 15:32:45.159454158 -0500
--- sys/unix/Makefile.doc.orig 2019-05-13 11:17:47.677796575 -0500
+++ sys/unix/Makefile.doc 2019-05-13 11:22:38.045441807 -0500
@@ -28,12 +28,13 @@
# Use the "cat" GUIDECMD if nroff and/or tbl and/or col are not installed

View File

@ -1,6 +1,6 @@
--- sys/unix/Makefile.src.orig 2016-10-02 19:07:41.996506529 -0500
+++ sys/unix/Makefile.src 2016-10-02 19:12:05.083455291 -0500
@@ -64,7 +64,7 @@
--- sys/unix/Makefile.src.orig 2019-05-13 10:45:22.525054741 -0500
+++ sys/unix/Makefile.src 2019-05-13 15:54:05.290209398 -0500
@@ -66,7 +66,7 @@
# if you get setcgtty() warnings during execution, you are feeding gcc
# a non-ANSI <sys/ioctl.h> -- either run fixincludes on it or use
# -traditional in CFLAGS
@ -9,7 +9,7 @@
#
# For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
#
@@ -128,7 +128,7 @@
@@ -130,7 +130,7 @@
# flags for Linux
# compile normally
# CFLAGS = -O2 -fomit-frame-pointer -I../include
@ -18,18 +18,24 @@
# OR compile backwards compatible a.out format
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
# LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
@@ -222,8 +222,8 @@
@@ -267,12 +267,12 @@
#WINBEOBJ = winbe.o NHWindow.o NHMenuWindow.o NHMapWindow.o tile.o
#
#
-#WINSRC = $(WINTTYSRC)
-#WINOBJ = $(WINTTYOBJ)
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
+#WINSRC = $(WINTTYSRC) $(WINX11SRC)
+#WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
#
# Curses - Karl Garrison, Tangles
-#WINSRC = $(WINCURSESSRC)
-#WINOBJ = $(WINCURSESOBJ)
+WINSRC = $(WINTTYSRC) $(WINX11SRC) $(WINCURSESSRC)
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ) $(WINCURSESOBJ)
#
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
@@ -238,12 +238,12 @@
@@ -287,12 +287,12 @@
# WINTTYLIB = -ltermcap
# WINTTYLIB = -lcurses
# WINTTYLIB = -lcurses16
@ -39,23 +45,23 @@
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
-#WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11
# WINX11LIB = -lXaw -lXmu -lXt -lX11
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
@@ -263,7 +263,7 @@
# libraries for BeOS
WINBELIB = -lbe
@@ -327,7 +327,7 @@
# same as above, for XCurses
#WINCURSESLIB = -L/usr/local/lib/pdcurses -lXCurses -lXawM -lXmu -lXext -lXt -lX11
#
-#WINLIB = $(WINTTYLIB)
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)
--- sys/unix/Makefile.utl.orig 2016-10-02 20:22:37.262531451 -0500
+++ sys/unix/Makefile.utl 2016-10-02 19:13:15.878978496 -0500
@@ -18,7 +18,7 @@
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
#
# For Curses
#WINLIB = $(WINCURSESLIB)
--- sys/unix/Makefile.utl.orig 2019-05-13 11:05:33.255674384 -0500
+++ sys/unix/Makefile.utl 2019-05-13 11:07:09.572212625 -0500
@@ -20,7 +20,7 @@
# if you are using gcc as your compiler,
# uncomment the CC definition below if it's not in your environment
@ -64,7 +70,7 @@
#
# For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
#
@@ -76,7 +76,7 @@
@@ -78,7 +78,7 @@
# flags for Linux
# compile normally
# CFLAGS = -O2 -fomit-frame-pointer -I../include
@ -73,15 +79,15 @@
# OR compile backwards compatible a.out format
# CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
# LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
@@ -104,11 +104,11 @@
@@ -111,11 +111,11 @@
# yacc/lex programs to use to generate *_comp.h, *_lex.c, and *_yacc.c.
# if, instead of yacc/lex you have bison/flex, comment/uncomment the following.
-YACC = yacc
-LEX = lex
-# YACC = bison -y
+#YACC = yacc
+#LEX = lex
+# YACC = yacc
+# LEX = lex
+YACC = bison -y
# YACC = byacc
-# LEX = flex

20
nethack-3.6.2-top.patch Normal file
View File

@ -0,0 +1,20 @@
--- sys/unix/Makefile.top.orig 2019-05-13 11:07:15.731247038 -0500
+++ sys/unix/Makefile.top 2019-05-13 11:10:12.118232737 -0500
@@ -27,7 +27,7 @@
# Permissions - some places use setgid instead of setuid, for instance
# See also the option "SECURE" in include/config.h
-#GAMEPERM = 04755
+GAMEPERM = 02755
FILEPERM = 0644
# VARFILEPERM = 0644
EXEPERM = 0755
@@ -49,7 +49,7 @@
# per discussion in Install.X11 and Install.Qt
#VARDATND =
# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm
-# VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm rip.xpm
+VARDATND = x11tiles NetHack.ad pet_mark.xbm pilemark.xbm rip.xpm
# for Atari/Gem
# VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
# for BeOS

View File

@ -4,16 +4,17 @@
%global fontname nethack-bitmap
Name: nethack
Version: 3.6.1
Release: 4%{?dist}
Version: 3.6.2
Release: 1%{?dist}
Summary: A rogue-like single player dungeon exploration game
Group: Amusements/Games
License: NGPL
URL: http://nethack.org
Source0: https://sourceforge.net/projects/%{name}/files/%{name}/%{version}/%{name}-361-src.tgz
URL: https://nethack.org
Source0: https://www.nethack.org/download/3.6.2/nethack-362-src.tgz
Source1: %{name}.desktop
Patch0: %{name}-%{version}-makefile.patch
Patch1: Makefile.top.patch
Patch1: %{name}-%{version}-top.patch
Patch2: %{name}-%{version}-config.patch
Patch3: %{name}-%{version}-guidebook.patch
Requires: %{fontname}-fonts-core
@ -59,6 +60,7 @@ Requires(post): xorg-x11-font-utils
Requires(post): coreutils
Requires(preun): coreutils
%description -n %{fontname}-fonts-core
X11 core fonts configuration for %{fontname}.
@ -134,6 +136,10 @@ if [ $1 -eq 0 ] ; then
rm %{_fontdir}/fonts.dir
fi;
%clean
rm -rf $RPM_BUILD_ROOT
%files
%doc doc/*.txt README dat/license dat/history
%doc dat/opthelp dat/wizhelp
@ -166,6 +172,9 @@ fi;
%files -n %{fontname}-fonts-core
%changelog
* Mon May 13 2019 Ron Olson <tachoknight@gmail.com> - 3.6.2-1
- Update to NetHack 3.6.2
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.6.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (nethack-361-src.tgz) = bd6e36c163f0d85e1ab1fc659464696b5a02c3864a800ad47e047fdc4a35fff4ef7dd28a9b071fa46f7f67fa45c97fdc77bc1f2bdbad80cc02950d73731d9c30
SHA512 (nethack-362-src.tgz) = e865f21298ffdf67301b5b6ca91f2e762011cc35b55f80603fff014b48f9724d67671168a898abb2171879906a65564d8eb59d272bb5a9f8bf957f074e3c105e