- Enable x11 support (Bug #167523)

This commit is contained in:
Luke Macken 2005-09-08 05:14:29 +00:00
parent d93d0a817c
commit b646685ca4
2 changed files with 90 additions and 2 deletions

64
nethack-3.4.3-x11.patch Normal file
View File

@ -0,0 +1,64 @@
--- sys/unix/Makefile.top.orig 2005-06-24 21:11:44.000000000 -0400
+++ sys/unix/Makefile.top 2005-06-24 21:12:06.000000000 -0400
@@ -40,9 +40,8 @@
SHELLDIR = $(PREFIX)/games
# per discussion in Install.X11 and Install.Qt
-VARDATND =
# VARDATND = x11tiles NetHack.ad pet_mark.xbm
-# VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
+VARDATND = x11tiles NetHack.ad pet_mark.xbm rip.xpm
# for Atari/Gem
# VARDATND = nh16.img title.img GEM_RSC.RSC rip.img
# for BeOS
--- include/config.h.orig 2005-06-24 21:12:38.000000000 -0400
+++ include/config.h 2005-06-24 21:13:36.000000000 -0400
@@ -43,7 +43,7 @@
* Some combinations make no sense. See the installation document.
*/
#define TTY_GRAPHICS /* good old tty based graphics */
-/* #define X11_GRAPHICS */ /* X11 interface */
+#define X11_GRAPHICS /* X11 interface */
/* #define QT_GRAPHICS */ /* Qt interface */
/* #define GNOME_GRAPHICS */ /* Gnome interface */
/* #define MSWIN_GRAPHICS */ /* Windows NT, CE, Graphics */
@@ -126,7 +126,7 @@
* would allow:
* xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
*/
-/* # define USE_XPM */ /* Disable if you do not have the XPM library */
+# define USE_XPM /* Disable if you do not have the XPM library */
# ifdef USE_XPM
# define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
# endif
--- sys/unix/Makefile.src.orig 2005-06-24 21:14:49.000000000 -0400
+++ sys/unix/Makefile.src 2005-06-24 21:15:32.000000000 -0400
@@ -214,8 +214,8 @@
#
#
-WINSRC = $(WINTTYSRC)
-WINOBJ = $(WINTTYOBJ)
+WINSRC = $(WINTTYSRC) $(WINX11SRC)
+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
# on some systems the termcap library is in -ltermcap or -lcurses
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
@@ -235,7 +235,7 @@
#
# libraries for X11
# If USE_XPM is defined in config.h, you will also need -lXpm here.
-WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
+WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
# WINX11LIB = -lXaw -lXmu -lXt -lX11
# WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
# WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
@@ -255,7 +255,7 @@
# libraries for BeOS
WINBELIB = -lbe
-WINLIB = $(WINTTYLIB)
+WINLIB = $(WINTTYLIB) $(WINX11LIB)
# any other strange libraries your system needs (for Sysunix only -- the more
# specialized targets should already be right)

View File

@ -3,7 +3,7 @@
Name: nethack
Version: 3.4.3
Release: 1%{?dist}
Release: 2%{?dist}
Summary: A rogue-like single player dungeon exploration game
Group: Amusements/Games
@ -13,9 +13,13 @@ Source0: http://dl.sf.net/%{name}/%{name}-343-src.tgz
Source1: %{name}.desktop
Patch0: %{name}-%{version}-makefile.patch
Patch1: %{name}-%{version}-config.patch
Patch2: %{name}-%{version}-x11.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: ncurses-devel, bison, flex, desktop-file-utils
BuildRequires: ncurses-devel
BuildRequires: bison, flex, desktop-file-utils
BuildRequires: xorg-x11-devel, xorg-x11-font-utils
Obsoletes: nethack-falconseye <= 1.9.4-6.a
@ -39,6 +43,7 @@ characters: you can pick your race, your role, and your gender.
%setup -q
%patch0 -b .makefile
%patch1 -b .config
%patch2 -b .x11
(source sys/unix/setup.sh)
# Set our paths
@ -81,6 +86,17 @@ desktop-file-install \
--add-category Game \
%{SOURCE1}
# Install the fonts for the X11 interface
cd win/X11
bdftopcf -o nh10.pcf nh10.bdf
bdftopcf -o ibm.pcf ibm.bdf
install -D ibm.pcf $RPM_BUILD_ROOT%{nhgamedir}/fonts/ibm.pcf
install -D nh10.pcf $RPM_BUILD_ROOT%{nhgamedir}/fonts/nh10.pcf
mkfontdir $RPM_BUILD_ROOT%{nhgamedir}/fonts
%{__sed} -i -e 's:^!\(NetHack.tile_file.*\):\1:' \
$RPM_BUILD_ROOT%{nhgamedir}/NetHack.ad
%clean
rm -rf $RPM_BUILD_ROOT
@ -96,6 +112,11 @@ rm -rf $RPM_BUILD_ROOT
%{nhgamedir}/nhdat
%{_bindir}/nethack
%{_bindir}/nethack-recover
%{nhgamedir}/NetHack.ad
%{nhgamedir}/pet_mark.xbm
%{nhgamedir}/rip.xpm
%{nhgamedir}/x11tiles
%{nhgamedir}/fonts/*
%defattr(0664,root,games)
%config(noreplace) %{nhdatadir}/record
%config(noreplace) %{nhdatadir}/perm
@ -106,5 +127,8 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Sep 06 2005 Luke Macken <lmacken@redhat.com> 3.4.3-2
- Enable x11 support
* Sun Jul 10 2005 Luke Macken <lmacken@redhat.com> 3.4.3-1
- Initial package for Fedora Extras