netcdf4-python/netcdf4-python-norpath.patch

31 lines
1.2 KiB
Diff

diff -up netcdf4-python-1.5.3rel/setup.py.norpath netcdf4-python-1.5.3rel/setup.py
--- netcdf4-python-1.5.3rel/setup.py.norpath 2019-10-22 09:39:48.000000000 -0600
+++ netcdf4-python-1.5.3rel/setup.py 2019-10-24 17:10:13.963050895 -0600
@@ -359,7 +359,7 @@ def _populate_hdf5_info(dirstosearch, in
if HDF5_libdir is not None: lib_dirs.append(HDF5_libdir)
if HDF5_incdir is not None: inc_dirs.append(HDF5_incdir)
- libs.extend(['hdf5_hl', 'hdf5'])
+ #libs.extend(['hdf5_hl', 'hdf5'])
dirstosearch = [os.path.expanduser('~'), '/usr/local', '/sw', '/opt',
@@ -425,7 +425,7 @@ NETCDF4_DIR environment variable not set
if sys.platform == 'win32':
libs.extend(['netcdf', 'zlib'])
else:
- libs.extend(['netcdf', 'z'])
+ libs.extend(['netcdf'])
if netCDF4_libdir is not None: lib_dirs.append(netCDF4_libdir)
if netCDF4_incdir is not None: inc_dirs.append(netCDF4_incdir)
@@ -471,7 +471,7 @@ NETCDF4_DIR environment variable not set
if sys.platform == 'win32':
runtime_lib_dirs = []
else:
- runtime_lib_dirs = lib_dirs
+ runtime_lib_dirs = []
# Do not require numpy for just querying the package
# Taken from the h5py setup file.