Update to 1.0.7

This commit is contained in:
Orion Poplawski 2014-02-06 22:47:59 -07:00
parent 0fbf3666b9
commit dc1a9e3da1
4 changed files with 20 additions and 17 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/netCDF4-1.0fix1.tar.gz
/netCDF4-1.0.2.tar.gz
/netCDF4-1.0.7.tar.gz

View File

@ -1,12 +1,12 @@
diff -up netCDF4-1.0.2/setup.py.norpath netCDF4-1.0.2/setup.py
--- netCDF4-1.0.2/setup.py.norpath 2012-11-21 07:20:13.000000000 -0700
+++ netCDF4-1.0.2/setup.py 2013-02-21 08:57:47.255829122 -0700
@@ -163,7 +163,7 @@ NETCDF4_DIR environment variable not set
lib_dirs.append(szip_libdir)
inc_dirs.append(szip_incdir)
-extensions = [Extension("netCDF4",["netCDF4.c"],libraries=libs,library_dirs=lib_dirs,include_dirs=inc_dirs,runtime_library_dirs=lib_dirs)]
+extensions = [Extension("netCDF4",["netCDF4.c"],libraries=libs,library_dirs=lib_dirs,include_dirs=inc_dirs)]
setup(name = "netCDF4",
version = "1.0.2",
diff -up netCDF4-1.0.7/setup.py.norpath netCDF4-1.0.7/setup.py
--- netCDF4-1.0.7/setup.py.norpath 2014-02-06 22:42:40.689954718 -0700
+++ netCDF4-1.0.7/setup.py 2014-02-06 22:43:16.600723399 -0700
@@ -295,7 +295,7 @@ else:
if has_cython and 'sdist' not in sys.argv[1:]:
sys.stdout.write('using Cython to compile netCDF4.pyx...\n')
# recompile netCDF4.pyx
- extensions = [Extension("netCDF4",["netCDF4.pyx"],libraries=libs,library_dirs=lib_dirs,include_dirs=inc_dirs,runtime_library_dirs=lib_dirs)]
+ extensions = [Extension("netCDF4",["netCDF4.pyx"],libraries=libs,library_dirs=lib_dirs,include_dirs=inc_dirs)]
# remove netCDF4.c file if it exists, so cython will recompile netCDF4.pyx.
if len(sys.argv) >= 2 and 'build' in sys.argv[1:] and os.path.exists('netCDF4.c'):
os.remove('netCDF4.c')

View File

@ -7,8 +7,8 @@
%global srcname distribute
Name: netcdf4-python
Version: 1.0.2
Release: 2%{?dist}
Version: 1.0.7
Release: 1%{?dist}
Summary: Python/numpy interface to netCDF
Group: Development/Languages
@ -91,8 +91,6 @@ containing vlens, and vlens containing compound types) are not supported.
%setup -q -n netCDF4-%{version}
%patch0 -p1 -b .norpath
%patch1 -p1 -b .libs
# Remove bundled ordereddict
rm ordereddict.py
%if 0%{?with_python3}
rm -rf %{py3dir}
@ -141,6 +139,7 @@ PYTHONPATH=$(echo ../build/lib.*) python3 run_all.py
%doc Changelog COPYING docs examples README
%{_bindir}/nc3tonc4
%{_bindir}/nc4tonc3
%{_bindir}/ncinfo
%{python_sitearch}/*
%if 0%{?with_python3}
@ -151,6 +150,9 @@ PYTHONPATH=$(echo ../build/lib.*) python3 run_all.py
%changelog
* Thu Feb 6 2014 Orion Poplawski <orion@cora.nwra.com> - 1.0.7-1
- Update to 1.0.7
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

View File

@ -1 +1 @@
22bfe58aefa177f7ab34dd12e70c7679 netCDF4-1.0.2.tar.gz
a2ac3014f833a78b53cbf19a556be9a1 netCDF4-1.0.7.tar.gz