Update to 1.3.1

Drop Python 2 in Fedora (bugz #1634978)
This commit is contained in:
Orion Poplawski 2018-10-07 11:19:28 -06:00
parent dba91d13cb
commit cf4c2afffa
5 changed files with 57 additions and 25 deletions

2
.gitignore vendored
View File

@ -14,3 +14,5 @@
/netcdf4-python-1.2.6.tar.gz
/netcdf4-python-1.2.7.tar.gz
/netcdf4-python-1.2.9.tar.gz
/netcdf4-python-1.3.1.tar.gz
/netcdf4-python-1.4.1.tar.gz

View File

@ -1,12 +1,21 @@
diff -up netcdf4-python-1.2.9rel/setup.py.libs netcdf4-python-1.2.9rel/setup.py
--- netcdf4-python-1.2.9rel/setup.py.libs 2017-06-20 12:43:57.950231729 -0600
+++ netcdf4-python-1.2.9rel/setup.py 2017-06-20 12:48:52.764137258 -0600
@@ -308,7 +308,7 @@ NETCDF4_DIR environment variable not set
if sys.platform=='win32':
libs = ['netcdf', 'hdf5_hl', 'hdf5', 'zlib']
else:
- libs = ['netcdf', 'hdf5_hl', 'hdf5', 'z']
+ libs = ['netcdf']
diff -up netcdf4-python-1.4.1rel/setup.py.libs netcdf4-python-1.4.1rel/setup.py
--- netcdf4-python-1.4.1rel/setup.py.libs 2018-10-06 20:02:02.828950332 -0600
+++ netcdf4-python-1.4.1rel/setup.py 2018-10-06 20:04:05.198352238 -0600
@@ -333,7 +333,7 @@ def _populate_hdf5_info(dirstosearch, in
if HDF5_libdir is not None: lib_dirs.append(HDF5_libdir)
if HDF5_incdir is not None: inc_dirs.append(HDF5_incdir)
if netCDF4_libdir is not None: lib_dirs = [netCDF4_libdir]
if HDF5_libdir is not None: lib_dirs.append(HDF5_libdir)
- libs.extend(['hdf5_hl', 'hdf5'])
+ #libs.extend(['hdf5_hl', 'hdf5'])
dirstosearch = [os.path.expanduser('~'), '/usr/local', '/sw', '/opt',
@@ -399,7 +399,7 @@ NETCDF4_DIR environment variable not set
if sys.platform == 'win32':
libs.extend(['netcdf', 'zlib'])
else:
- libs.extend(['netcdf', 'z'])
+ libs.extend(['netcdf'])
if netCDF4_libdir is not None: lib_dirs.append(netCDF4_libdir)
if netCDF4_incdir is not None: inc_dirs.append(netCDF4_incdir)

View File

@ -1,15 +1,12 @@
diff -up netcdf4-python-1.2.9rel/setup.py.norpath netcdf4-python-1.2.9rel/setup.py
--- netcdf4-python-1.2.9rel/setup.py.norpath 2017-06-20 12:41:14.139838454 -0600
+++ netcdf4-python-1.2.9rel/setup.py 2017-06-20 12:42:50.727480710 -0600
@@ -353,10 +353,7 @@ NETCDF4_DIR environment variable not set
lib_dirs.append(curl_libdir)
inc_dirs.append(curl_incdir)
-if sys.platform=='win32':
- runtime_lib_dirs = []
-else:
diff -up netcdf4-python-1.4.1rel/setup.py.norpath netcdf4-python-1.4.1rel/setup.py
--- netcdf4-python-1.4.1rel/setup.py.norpath 2018-10-06 20:00:20.476745679 -0600
+++ netcdf4-python-1.4.1rel/setup.py 2018-10-06 20:01:16.939410227 -0600
@@ -445,7 +445,7 @@ NETCDF4_DIR environment variable not set
if sys.platform == 'win32':
runtime_lib_dirs = []
else:
- runtime_lib_dirs = lib_dirs
+runtime_lib_dirs = []
+ runtime_lib_dirs = []
# Do not require numpy for just querying the package
# Taken from the h5py setup file.

View File

@ -1,6 +1,6 @@
Name: netcdf4-python
Version: 1.2.9
Release: 7%{?dist}
Version: 1.3.1
Release: 1%{?dist}
Summary: Python/numpy interface to netCDF
Group: Development/Languages
@ -14,8 +14,11 @@ Patch0: netcdf4-python-norpath.patch
# http://code.google.com/p/netcdf4-python/issues/detail?id=139
Patch1: netcdf4-python-libs.patch
%if 0%{?fedora} < 30
BuildRequires: python2-devel
BuildRequires: python2-setuptools >= 18.0
# Added in 1.4.0
#BuildRequires: python2-cftime
BuildRequires: python2-Cython
BuildRequires: python2-dateutil
# EL6 has python 2.6 and needs ordereddict
@ -23,7 +26,11 @@ BuildRequires: python2-dateutil
BuildRequires: python-ordereddict
%endif
BuildRequires: python2-numpy
%endif
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools >= 18
# Added in 1.4.0
#BuildRequires: python%{python3_pkgversion}-cftime
BuildRequires: python%{python3_pkgversion}-Cython
BuildRequires: python%{python3_pkgversion}-dateutil
BuildRequires: python%{python3_pkgversion}-numpy
@ -57,6 +64,8 @@ Group: Development/Languages
%if 0%{?rhel} && 0%{?rhel} <= 6
Requires: python-ordereddict
%endif
# Added in 1.4.0
#Requires: python2-cftime
Requires: python2-Cython
Requires: python2-numpy
%{?python_provide:%python_provide python2-netcdf4}
@ -80,6 +89,8 @@ containing vlens, and vlens containing compound types) are not supported.
%package -n python%{python3_pkgversion}-netcdf4
Summary: Python/numpy interface to netCDF
Group: Development/Languages
# Added in 1.4.0
#Requires: python%{python3_pkgversion}-cftime
Requires: python%{python3_pkgversion}-Cython
Requires: python%{python3_pkgversion}-numpy
%{?python_provide:%python_provide python%{python3_pkgversion}-netcdf4}
@ -110,14 +121,19 @@ rm test/tst_dap.py
%build
%if 0%{?fedora} < 30
%py2_build
%endif
%py3_build
%install
# python3 is default in fedora, but not EPEL
%if 0%{?fedora}
%if 0%{?fedora} < 30
%py2_install
%endif
%py3_install
%else
%py3_install
@ -127,7 +143,9 @@ rm test/tst_dap.py
%check
cd test
%if 0%{?fedora} < 30
PYTHONPATH=$(echo ../build/lib.*%{python2_version}) %{__python2} run_all.py
%endif
PYTHONPATH=$(echo ../build/lib.*%{python3_version}) %{__python3} run_all.py
@ -137,10 +155,12 @@ PYTHONPATH=$(echo ../build/lib.*%{python3_version}) %{__python3} run_all.py
%{_bindir}/nc4tonc3
%{_bindir}/ncinfo
%if 0%{?fedora} < 30
%files -n python2-netcdf4
%license COPYING
%doc Changelog docs examples README.md
%{python2_sitearch}/*
%endif
%files -n python%{python3_pkgversion}-netcdf4
%license COPYING
@ -149,6 +169,10 @@ PYTHONPATH=$(echo ../build/lib.*%{python3_version}) %{__python3} run_all.py
%changelog
* Sun Oct 7 2018 Orion Poplawski <orion@nwra.com> - 1.3.1-1
- Update to 1.3.1
- Drop Python 2 in Fedora (bugz #1634978)
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.9-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (netcdf4-python-1.2.9.tar.gz) = 3479cc835761811bf15665e00f5391740b6f2988c3f0f822cfe7c42d98f5b38030eaaf989b8c30891e2acac0ed6df86e4dd06bb15fd8ef695ed66e74fb83d2c2
SHA512 (netcdf4-python-1.3.1.tar.gz) = d73e79d8e92aa4754910cd13784ed4bbcefa3290fcce0c3774ff3f2ff6f07a4fe0eb92cb254035cfa8761121863ef96cfb433f802282fe20682076665ebd1d0a