Update to 1.2.5

- Enable python 3 for EPEL
This commit is contained in:
Orion Poplawski 2016-11-29 11:00:36 -07:00
parent d0314ad67d
commit 19477ac90e
5 changed files with 27 additions and 27 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/netcdf4-python-1.2.2.tar.gz
/netcdf4-python-1.2.3.tar.gz
/netcdf4-python-1.2.4.tar.gz
/netcdf4-python-1.2.5.tar.gz

View File

@ -1,7 +1,7 @@
diff -up netcdf4-python-1.2.2rel/setup.py.libs netcdf4-python-1.2.2rel/setup.py
--- netcdf4-python-1.2.2rel/setup.py.libs 2016-02-05 08:33:54.977139095 -0700
+++ netcdf4-python-1.2.2rel/setup.py 2016-02-05 08:35:07.630694784 -0700
@@ -307,7 +307,7 @@ NETCDF4_DIR environment variable not set
diff -up netcdf4-python-1.2.5rel/setup.py.libs netcdf4-python-1.2.5rel/setup.py
--- netcdf4-python-1.2.5rel/setup.py.libs 2016-11-29 10:55:40.518989615 -0700
+++ netcdf4-python-1.2.5rel/setup.py 2016-11-29 10:55:40.520989604 -0700
@@ -324,7 +324,7 @@ NETCDF4_DIR environment variable not set
if sys.platform=='win32':
libs = ['netcdf','hdf5_hl','hdf5','zlib']
else:

View File

@ -1,23 +1,23 @@
diff -up netcdf4-python-1.2.2rel/setup.py.norpath netcdf4-python-1.2.2rel/setup.py
--- netcdf4-python-1.2.2rel/setup.py.norpath 2016-02-05 08:32:27.626630007 -0700
+++ netcdf4-python-1.2.2rel/setup.py 2016-02-05 08:33:33.808264087 -0700
@@ -382,8 +382,7 @@ if has_cython and 'sdist' not in sys.arg
diff -up netcdf4-python-1.2.5rel/setup.py.norpath netcdf4-python-1.2.5rel/setup.py
--- netcdf4-python-1.2.5rel/setup.py.norpath 2016-11-29 10:53:45.214631966 -0700
+++ netcdf4-python-1.2.5rel/setup.py 2016-11-29 10:55:20.014103847 -0700
@@ -399,8 +399,7 @@ if has_cython and 'sdist' not in sys.arg
[netcdf4_src_root + '.pyx'],
libraries=libs,
library_dirs=lib_dirs,
- include_dirs=inc_dirs,
- runtime_library_dirs=runtime_lib_dirs),
+ include_dirs=inc_dirs),
Extension('netcdftime._datetime', ['netcdftime/_datetime.pyx'])]
Extension('netcdftime._netcdftime', ['netcdftime/_netcdftime.pyx'])]
# remove netCDF4.c file if it exists, so cython will recompile netCDF4.pyx.
# run for build *and* install (issue #263). Otherwise 'pip install' will
@@ -425,8 +424,7 @@ else:
@@ -442,8 +441,7 @@ else:
[netcdf4_src_c],
libraries=libs,
library_dirs=lib_dirs,
- include_dirs=inc_dirs,
- runtime_library_dirs=runtime_lib_dirs),
+ include_dirs=inc_dirs),
Extension('netcdftime._datetime', ['netcdftime/_datetime.c'])]
Extension('netcdftime._netcdftime', ['netcdftime/_netcdftime.c'])]
ext_modules = extensions

View File

@ -1,25 +1,20 @@
%if 0%{?fedora}
%global with_python3 1
%else
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
%endif
Name: netcdf4-python
Version: 1.2.4
Release: 2%{?dist}
Version: 1.2.5
Release: 1%{?dist}
Summary: Python/numpy interface to netCDF
Group: Development/Languages
License: MIT
URL: https://github.com/Unidata/netcdf4-python
Source0: https://github.com/Unidata/netcdf4-python/archive/v%{version}rel.tar.gz#/%{name}-%{version}.tar.gz
Source0: https://github.com/Unidata/netcdf4-python/archive/v%{version}rel/%{name}-%{version}.tar.gz
# No rpath for library
# http://code.google.com/p/netcdf4-python/issues/detail?id=138
Patch0: netcdf4-python-norpath.patch
# Don't link against hdf5 and z libraries
# http://code.google.com/p/netcdf4-python/issues/detail?id=139
Patch1: netcdf4-python-libs.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: python2-devel
BuildRequires: Cython
@ -30,10 +25,10 @@ BuildRequires: python-ordereddict
%endif
BuildRequires: numpy
%if 0%{?with_python3}
BuildRequires: python3-devel
BuildRequires: python3-Cython
BuildRequires: python3-dateutil
BuildRequires: python3-numpy
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-Cython
BuildRequires: python%{python3_pkgversion}-dateutil
BuildRequires: python%{python3_pkgversion}-numpy
%endif # if with_python3
BuildRequires: netcdf-devel
@ -73,9 +68,9 @@ containing vlens, and vlens containing compound types) are not supported.
%package -n netcdf4-python3
Summary: Python/numpy interface to netCDF
Group: Development/Languages
Requires: python3-Cython
Requires: python3-numpy
Provides: python3-netcdf4 = %{version}-%{release}
Requires: python%{python3_pkgversion}-Cython
Requires: python%{python3_pkgversion}-numpy
Provides: python%{python3_pkgversion}-netcdf4 = %{version}-%{release}
%description -n netcdf4-python3
netCDF version 4 has many features not found in earlier versions of the
@ -146,6 +141,10 @@ PYTHONPATH=$(echo ../build/lib.*%{python3_version}) %{__python3} run_all.py
%changelog
* Tue Nov 29 2016 Orion Poplawski <orion@cora.nwra.com> - 1.2.5-1
- Update to 1.2.5
- Enable python 3 for EPEL
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-2
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages

View File

@ -1 +1 @@
b79eb6c7daa7d9c5ed28df130915eb0b netcdf4-python-1.2.4.tar.gz
c98924986ac9a2d5ce92542cf119a57b netcdf4-python-1.2.5.tar.gz