Update to 4.6.3
This commit is contained in:
parent
aaefcf4cbe
commit
1277d0f9ec
2
.gitignore
vendored
2
.gitignore
vendored
@ -15,3 +15,5 @@ netcdf-4.1.1.tar.gz
|
||||
/netcdf-4.4.0.tar.gz
|
||||
/netcdf-4.4.1.tar.gz
|
||||
/netcdf-4.4.1.1.tar.gz
|
||||
/netcdf-4.6.2.1.tar.gz
|
||||
/netcdf-4.6.3.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up netcdf-c-4.4.1.1/h5_test/tst_h_par.c.err netcdf-c-4.4.1.1/h5_test/tst_h_par.c
|
||||
--- netcdf-c-4.4.1.1/h5_test/tst_h_par.c.err 2016-11-21 11:27:08.000000000 -0700
|
||||
+++ netcdf-c-4.4.1.1/h5_test/tst_h_par.c 2016-11-29 11:34:59.433806850 -0700
|
||||
@@ -11,6 +11,7 @@
|
||||
$Id: tst_h_par.c,v 1.15 2010/05/25 13:53:04 ed Exp $
|
||||
*/
|
||||
#include <nc_tests.h>
|
||||
+#include "err_macros.h"
|
||||
#include <hdf5.h>
|
||||
|
||||
/* Defining USE_MPE causes the MPE trace library to be used (and you
|
67
netcdf.spec
67
netcdf.spec
@ -1,14 +1,11 @@
|
||||
Name: netcdf
|
||||
Version: 4.4.1.1
|
||||
Release: 12%{?dist}
|
||||
Version: 4.6.3
|
||||
Release: 1%{?dist}
|
||||
Summary: Libraries for the Unidata network Common Data Form
|
||||
|
||||
License: NetCDF
|
||||
URL: http://www.unidata.ucar.edu/software/netcdf/
|
||||
Source0: https://github.com/Unidata/netcdf-c/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||
# Add missing #include "err_macros.h"
|
||||
# https://github.com/Unidata/netcdf-c/pull/333
|
||||
Patch0: netcdf-err.patch
|
||||
|
||||
BuildRequires: libtool
|
||||
BuildRequires: chrpath
|
||||
@ -36,13 +33,6 @@ Requires: hdf5%{?_isa} = %{_hdf5_version}
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%if 0%{?fedora} < 26
|
||||
%ifarch s390 s390x
|
||||
# No openmpi on s390(x)
|
||||
%global with_openmpi 0
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%if %{with_mpich}
|
||||
%global mpi_list mpich
|
||||
%endif
|
||||
@ -172,36 +162,31 @@ NetCDF parallel openmpi static libraries
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-c-%{version}
|
||||
%patch0 -p1 -b .err
|
||||
m4 libsrc/ncx.m4 > libsrc/ncx.c
|
||||
%autosetup -p1 -n %{name}-c-%{version}
|
||||
|
||||
|
||||
%build
|
||||
#Do out of tree builds
|
||||
%global _configure ../configure
|
||||
#Common configure options
|
||||
export LDFLAGS="%{__global_ldflags} -L%{_libdir}/hdf"
|
||||
%global configure_opts \\\
|
||||
--enable-shared \\\
|
||||
--enable-netcdf-4 \\\
|
||||
--enable-dap \\\
|
||||
--enable-extra-example-tests \\\
|
||||
CPPFLAGS=-I%{_includedir}/hdf \\\
|
||||
LIBS="-ldf -ljpeg -ltirpc" \\\
|
||||
LIBS="-ltirpc" \\\
|
||||
--enable-hdf4 \\\
|
||||
--disable-dap-remote-tests \\\
|
||||
%{nil}
|
||||
export LDFLAGS="%{__global_ldflags} -L%{_libdir}/hdf"
|
||||
|
||||
# Upstream libtool is stripping -spec from link command
|
||||
libtoolize --force
|
||||
|
||||
# Serial build
|
||||
mkdir build
|
||||
pushd build
|
||||
ln -s ../configure .
|
||||
%configure %{configure_opts}
|
||||
make %{?_smp_mflags}
|
||||
%make_build
|
||||
popd
|
||||
|
||||
# MPI builds
|
||||
@ -220,12 +205,8 @@ do
|
||||
--includedir=%{_includedir}/$mpi-%{_arch} \
|
||||
--datarootdir=%{_libdir}/$mpi/share \
|
||||
--mandir=%{_libdir}/$mpi/share/man \
|
||||
%ifnarch s390 s390x
|
||||
--enable-parallel-tests
|
||||
%else
|
||||
%{nil}
|
||||
%endif
|
||||
make %{?_smp_mflags}
|
||||
%make_build
|
||||
module purge
|
||||
popd
|
||||
done
|
||||
@ -264,18 +245,21 @@ done
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYRIGHT README.md RELEASE_NOTES.md
|
||||
%license COPYRIGHT
|
||||
%doc README.md RELEASE_NOTES.md
|
||||
%{_bindir}/nccopy
|
||||
%{_bindir}/ncdump
|
||||
%{_bindir}/ncgen
|
||||
%{_bindir}/ncgen3
|
||||
%{_libdir}/*.so.11*
|
||||
%{_libdir}/*.so.15*
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%files devel
|
||||
%doc examples
|
||||
%{_bindir}/nc-config
|
||||
%{_includedir}/netcdf.h
|
||||
%{_includedir}/netcdf_aux.h
|
||||
%{_includedir}/netcdf_filter.h
|
||||
%{_includedir}/netcdf_meta.h
|
||||
%{_includedir}/netcdf_mem.h
|
||||
%{_libdir}/libnetcdf.settings
|
||||
@ -288,17 +272,23 @@ done
|
||||
|
||||
%if %{with_mpich}
|
||||
%files mpich
|
||||
%doc COPYRIGHT README.md RELEASE_NOTES.md
|
||||
%license COPYRIGHT
|
||||
%doc README.md RELEASE_NOTES.md
|
||||
%{_libdir}/mpich/bin/nccopy
|
||||
%{_libdir}/mpich/bin/ncdump
|
||||
%{_libdir}/mpich/bin/ncgen
|
||||
%{_libdir}/mpich/bin/ncgen3
|
||||
%{_libdir}/mpich/lib/*.so.11*
|
||||
%{_libdir}/mpich/lib/*.so.15*
|
||||
%doc %{_libdir}/mpich/share/man/man1/*.1*
|
||||
|
||||
%files mpich-devel
|
||||
%{_libdir}/mpich/bin/nc-config
|
||||
%{_includedir}/mpich-%{_arch}
|
||||
%{_includedir}/mpich-%{_arch}/netcdf.h
|
||||
%{_includedir}/mpich-%{_arch}/netcdf_aux.h
|
||||
%{_includedir}/mpich-%{_arch}/netcdf_filter.h
|
||||
%{_includedir}/mpich-%{_arch}/netcdf_meta.h
|
||||
%{_includedir}/mpich-%{_arch}/netcdf_mem.h
|
||||
%{_includedir}/mpich-%{_arch}/netcdf_par.h
|
||||
%{_libdir}/mpich/lib/libnetcdf.settings
|
||||
%{_libdir}/mpich/lib/*.so
|
||||
%{_libdir}/mpich/lib/pkgconfig/%{name}.pc
|
||||
@ -310,17 +300,23 @@ done
|
||||
|
||||
%if %{with_openmpi}
|
||||
%files openmpi
|
||||
%doc COPYRIGHT README.md RELEASE_NOTES.md
|
||||
%license COPYRIGHT
|
||||
%doc README.md RELEASE_NOTES.md
|
||||
%{_libdir}/openmpi/bin/nccopy
|
||||
%{_libdir}/openmpi/bin/ncdump
|
||||
%{_libdir}/openmpi/bin/ncgen
|
||||
%{_libdir}/openmpi/bin/ncgen3
|
||||
%{_libdir}/openmpi/lib/*.so.11*
|
||||
%{_libdir}/openmpi/lib/*.so.15*
|
||||
%doc %{_libdir}/openmpi/share/man/man1/*.1*
|
||||
|
||||
%files openmpi-devel
|
||||
%{_libdir}/openmpi/bin/nc-config
|
||||
%{_includedir}/openmpi-%{_arch}
|
||||
%{_includedir}/openmpi-%{_arch}/netcdf.h
|
||||
%{_includedir}/openmpi-%{_arch}/netcdf_aux.h
|
||||
%{_includedir}/openmpi-%{_arch}/netcdf_filter.h
|
||||
%{_includedir}/openmpi-%{_arch}/netcdf_meta.h
|
||||
%{_includedir}/openmpi-%{_arch}/netcdf_mem.h
|
||||
%{_includedir}/openmpi-%{_arch}/netcdf_par.h
|
||||
%{_libdir}/openmpi/lib/libnetcdf.settings
|
||||
%{_libdir}/openmpi/lib/*.so
|
||||
%{_libdir}/openmpi/lib/pkgconfig/%{name}.pc
|
||||
@ -332,6 +328,9 @@ done
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Mar 16 2019 Orion Poplawski <orion@nwra.com> - 4.6.3-1
|
||||
- Update to 4.6.3
|
||||
|
||||
* Thu Feb 14 2019 Orion Poplawski <orion@nwra.com> - 4.4.1.1-12
|
||||
- Rebuild for openmpi 3.1.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user