29 lines
1020 B
Diff
29 lines
1020 B
Diff
From 9432f629e66e4f9500f6335eab3ad427f84523b2 Mon Sep 17 00:00:00 2001
|
|
From: Adam Williamson <awilliam@redhat.com>
|
|
Date: Thu, 20 Jul 2017 10:31:47 -0700
|
|
Subject: [PATCH] Link libnetsnmptrapd against MYSQL_LIBS
|
|
|
|
When building with MySQL (MariaDB) support, this library must
|
|
be linked against the MySQL client library, or else it will
|
|
have unresolved symbols.
|
|
---
|
|
apps/Makefile.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/apps/Makefile.in b/apps/Makefile.in
|
|
index 77404dd89..7da434522 100644
|
|
--- a/apps/Makefile.in
|
|
+++ b/apps/Makefile.in
|
|
@@ -204,7 +204,7 @@ snmpdf$(EXEEXT): snmpdf.$(OSUFFIX) $(USELIBS)
|
|
$(LINK) ${CFLAGS} -o $@ snmpdf.$(OSUFFIX) ${LDFLAGS} ${LIBS}
|
|
|
|
libnetsnmptrapd.$(LIB_EXTENSION)$(LIB_VERSION): $(LLIBTRAPD_OBJS)
|
|
- $(LIB_LD_CMD) $@ ${LLIBTRAPD_OBJS} $(MIBLIB) $(USELIBS) $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS)
|
|
+ $(LIB_LD_CMD) $@ ${LLIBTRAPD_OBJS} $(MIBLIB) $(USELIBS) $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS) $(MYSQL_LIBS)
|
|
$(RANLIB) $@
|
|
|
|
snmpinforminstall:
|
|
--
|
|
2.13.0
|
|
|