Update mysqllib patch

This commit is contained in:
Josef Ridky 2017-07-26 12:45:36 +02:00
parent a299db445d
commit e8349ae7ac
2 changed files with 31 additions and 28 deletions

View File

@ -1,28 +1,28 @@
diff -urNp old/configure new/configure
--- old/configure 2017-07-11 15:24:33.579767286 +0200
+++ new/configure 2017-07-12 08:50:28.375913913 +0200
@@ -23743,8 +23743,8 @@ $as_echo "#define HAVE_BROKEN_LIBMYSQLCL
fi
rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
- CPPFLAGS="${_cppflags}"
- LIBS="${_libs}"
+# CPPFLAGS="${_cppflags}"
+# LIBS="${_libs}"
From 9432f629e66e4f9500f6335eab3ad427f84523b2 Mon Sep 17 00:00:00 2001
From: Adam Williamson <awilliam@redhat.com>
Date: Thu, 20 Jul 2017 10:31:47 -0700
Subject: [PATCH] Link libnetsnmptrapd against MYSQL_LIBS
When building with MySQL (MariaDB) support, this library must
be linked against the MySQL client library, or else it will
have unresolved symbols.
---
apps/Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/apps/Makefile.in b/apps/Makefile.in
index 77404dd89..7da434522 100644
--- a/apps/Makefile.in
+++ b/apps/Makefile.in
@@ -204,7 +204,7 @@ snmpdf$(EXEEXT): snmpdf.$(OSUFFIX) $(USELIBS)
$(LINK) ${CFLAGS} -o $@ snmpdf.$(OSUFFIX) ${LDFLAGS} ${LIBS}
cat >> configure-summary << EOF
MYSQL Trap Logging: enabled
diff -urNp old/configure.d/config_os_libs2 new/configure.d/config_os_libs2
--- old/configure.d/config_os_libs2 2017-07-11 15:24:14.268853962 +0200
+++ new/configure.d/config_os_libs2 2017-07-12 08:47:11.270052282 +0200
@@ -485,8 +485,8 @@ if test "x$with_mysql" = "xyes" ; then
[AC_MSG_RESULT(no)
AC_DEFINE([HAVE_BROKEN_LIBMYSQLCLIENT], 1,
[Define if using MY_INIT() causes a linker error])])
- CPPFLAGS="${_cppflags}"
- LIBS="${_libs}"
+# CPPFLAGS="${_cppflags}"
+# LIBS="${_libs}"
AC_MSG_CACHE_ADD(MYSQL Trap Logging: enabled)
else
AC_MSG_CACHE_ADD(MYSQL Trap Logging: unavailable)
libnetsnmptrapd.$(LIB_EXTENSION)$(LIB_VERSION): $(LLIBTRAPD_OBJS)
- $(LIB_LD_CMD) $@ ${LLIBTRAPD_OBJS} $(MIBLIB) $(USELIBS) $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS)
+ $(LIB_LD_CMD) $@ ${LLIBTRAPD_OBJS} $(MIBLIB) $(USELIBS) $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS) $(MYSQL_LIBS)
$(RANLIB) $@
snmpinforminstall:
--
2.13.0

View File

@ -11,7 +11,7 @@
Summary: A collection of SNMP protocol tools and libraries
Name: net-snmp
Version: 5.7.3
Release: 14%{?dist}
Release: 15%{?dist}
Epoch: 1
License: BSD
@ -534,6 +534,9 @@ rm -rf ${RPM_BUILD_ROOT}
%endif
%changelog
* Wed Jul 26 2017 Josef Ridky <jridky@redhat.com> - 1:5.7.3-15
- Update mysqllib patch with upstream reported version (#1470004)
* Thu Jul 13 2017 Josef Ridky <jridky@redhat.com> - 1:5.7.3-14
- Fix perl issue with use NetSNMP::TrapReceiver (add link to libmysqlclient.so) (#1470004)