fix net-snmp-config strange values for --libs (#228588)

This commit is contained in:
vcrhonek 2007-02-26 11:52:56 +00:00
parent d877272e7c
commit beb5a2a35c
2 changed files with 151 additions and 1 deletions

View File

@ -0,0 +1,145 @@
--- net-snmp-5.4/configure.libdir.fix 2007-02-26 12:25:08.000000000 +0100
+++ net-snmp-5.4/configure.libdir 2007-02-26 12:28:03.000000000 +0100
@@ -27039,7 +27039,7 @@
if test "$with_libwrap" != "no"; then
if test "$with_libwrap" != "yes"; then
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
fi
_libs=${LIBS}
@@ -27242,7 +27242,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap"
else
echo "$as_me: failed program was:" >&5
@@ -27470,7 +27470,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
else
echo "$as_me: failed program was:" >&5
--- net-snmp-5.4/configure.mnttab.fix 2006-11-24 18:56:15.000000000 +0100
+++ net-snmp-5.4/configure.mnttab 2007-02-26 12:28:14.000000000 +0100
@@ -27047,7 +27047,7 @@
if test "$with_libwrap" != "no"; then
if test "$with_libwrap" != "yes"; then
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
fi
_libs=${LIBS}
@@ -27250,7 +27250,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap"
else
echo "$as_me: failed program was:" >&5
@@ -27478,7 +27478,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
else
echo "$as_me: failed program was:" >&5
--- net-snmp-5.4/configure.fix 2007-02-26 12:25:08.000000000 +0100
+++ net-snmp-5.4/configure 2007-02-26 12:27:24.000000000 +0100
@@ -27039,7 +27039,7 @@
if test "$with_libwrap" != "no"; then
if test "$with_libwrap" != "yes"; then
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
fi
_libs=${LIBS}
@@ -27242,7 +27242,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap"
else
echo "$as_me: failed program was:" >&5
@@ -27470,7 +27470,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
else
echo "$as_me: failed program was:" >&5
--- net-snmp-5.4/configure.in.fix 2006-11-24 18:53:18.000000000 +0100
+++ net-snmp-5.4/configure.in 2007-02-26 12:27:50.000000000 +0100
@@ -2683,7 +2683,7 @@
if test "$with_libwrap" != "no"; then
if test "$with_libwrap" != "yes"; then
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
fi
_libs=${LIBS}
@@ -2700,7 +2700,7 @@
AC_MSG_RESULT([yes])
AC_DEFINE(NETSNMP_USE_LIBWRAP)
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap"],
[
AC_MSG_RESULT([no])
@@ -2716,7 +2716,7 @@
AC_MSG_RESULT(yes)
AC_DEFINE(NETSNMP_USE_LIBWRAP)
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap -lnsl",
AC_MSG_RESULT(no)
--- net-snmp-5.4/configure.ethtool-config.fix 2007-02-26 12:25:08.000000000 +0100
+++ net-snmp-5.4/configure.ethtool-config 2007-02-26 12:27:38.000000000 +0100
@@ -27039,7 +27039,7 @@
if test "$with_libwrap" != "no"; then
if test "$with_libwrap" != "yes"; then
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
fi
_libs=${LIBS}
@@ -27242,7 +27242,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap"
else
echo "$as_me: failed program was:" >&5
@@ -27470,7 +27470,7 @@
#define NETSNMP_USE_LIBWRAP 1
_ACEOF
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
else
echo "$as_me: failed program was:" >&5

View File

@ -7,7 +7,7 @@
Summary: A collection of SNMP protocol tools and libraries
Name: net-snmp
Version: %{major_ver}
Release: 9%{?dist}
Release: 10%{?dist}
Epoch: 1
License: BSDish
@ -36,6 +36,7 @@ Patch11: net-snmp-5.4-ip-addr-route-leaks.patch
Patch12: net-snmp-5.4-tcpConn-tcp6-fopen.patch
Patch13: net-snmp-5.4-ethtool-config.patch
Patch14: net-snmp-5.4-free.patch
Patch15: net-snmp-5.4-strange_libpath.patch
Requires(pre): /sbin/chkconfig
Requires(post): /sbin/chkconfig
@ -148,6 +149,7 @@ and applications.
%patch13 -p1 -b .ethtool-config
%patch14 -p1 -b .free
%patch15 -p1 -b .strange_libpath
# Do this patch with a perl hack...
perl -pi -e "s|'\\\$install_libdir'|'%{_libdir}'|" ltmain.sh
@ -352,6 +354,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_libdir}/lib*.so.*
%changelog
* Mon Feb 26 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 5.4-10
- fix net-snmp-config strange values for --libs (#228588)
* Fri Feb 23 2007 Radek Vokál <rvokal@redhat.com> - 5.4-9
- fix dependency on lm_sensors-devel (#229109)
- spec file cleanups