Updated to 5.7.2

This commit is contained in:
Jan Safranek 2012-10-18 10:02:05 +02:00
parent eecc6a24ff
commit 95059c27e3
10 changed files with 39 additions and 1755 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@ net-snmp-5.5.tar.gz
/net-snmp-5.6.1.tar.gz
/net-snmp-5.7.tar.gz
/net-snmp-5.7.1.tar.gz
/net-snmp-5.7.2.tar.gz

View File

@ -1,15 +0,0 @@
603243: include struct.h in installed -devel files
diff -up net-snmp-5.5/agent/Makefile.in.orig net-snmp-5.5/agent/Makefile.in
--- net-snmp-5.5/agent/Makefile.in.orig 2010-06-16 13:48:48.000000000 +0200
+++ net-snmp-5.5/agent/Makefile.in 2010-06-16 14:02:36.000000000 +0200
@@ -44,7 +44,7 @@ INSTALLBUILTSUBDIRHEADERS=../include/net
INSTALLBUILTSUBDIR=agent
INCLUDEMIBGROUPDIR=agent/mibgroup
-INCLUDEMIBGROUPDIRHEADERS=util_funcs.h
+INCLUDEMIBGROUPDIRHEADERS=util_funcs.h struct.h
OTHERINSTALL=installmibgroupheaders @EMBEDPERLINSTALL@
OTHERUNINSTALL=@EMBEDPERLUNINSTALL@

View File

@ -1,24 +0,0 @@
diff -up net-snmp-5.6/agent/Makefile.in.pie net-snmp-5.6/agent/Makefile.in
--- net-snmp-5.6/agent/Makefile.in.pie 2010-06-08 23:05:11.000000000 +0200
+++ net-snmp-5.6/agent/Makefile.in 2010-10-25 17:34:55.802975874 +0200
@@ -245,7 +245,7 @@ getmibstat.o: mibgroup/kernel_sunos5.c
$(CC) $(CFLAGS) -o $@ -D_GETMIBSTAT_TEST -DDODEBUG -c $?
snmpd$(EXEEXT): ${LAGENTOBJS} $(USELIBS) $(AGENTLIB) $(MIBLIB) $(LIBTARG)
- $(LINK) $(CFLAGS) -o $@ ${LAGENTOBJS} $(LOCAL_LIBS) ${LDFLAGS} ${OUR_AGENT_LIBS}
+ $(LINK) $(CFLAGS) -pie -o $@ ${LAGENTOBJS} $(LOCAL_LIBS) ${LDFLAGS} ${OUR_AGENT_LIBS}
libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION): ${LLIBAGENTOBJS} $(USELIBS)
diff -up net-snmp-5.6/apps/Makefile.in.pie net-snmp-5.6/apps/Makefile.in
--- net-snmp-5.6/apps/Makefile.in.pie 2010-07-02 18:27:52.000000000 +0200
+++ net-snmp-5.6/apps/Makefile.in 2010-10-25 17:03:57.414725652 +0200
@@ -127,7 +127,7 @@ snmptest$(EXEEXT): snmptest.$(OSUFFIX
$(LINK) ${CFLAGS} -o $@ snmptest.$(OSUFFIX) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
snmptrapd$(EXEEXT): $(TRAPD_OBJECTS) $(USETRAPLIBS) $(INSTALLLIBS)
- $(LINK) ${CFLAGS} -o $@ $(TRAPD_OBJECTS) $(INSTALLLIBS) $(LOCAL_LIBS) ${LDFLAGS} ${TRAPLIBS}
+ $(LINK) ${CFLAGS} -o $@ -pie $(TRAPD_OBJECTS) $(INSTALLLIBS) $(LOCAL_LIBS) ${LDFLAGS} ${TRAPLIBS}
snmptrap$(EXEEXT): snmptrap.$(OSUFFIX) $(USELIBS)
$(LINK) ${CFLAGS} -o $@ snmptrap.$(OSUFFIX) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}

View File

@ -1,14 +0,0 @@
MySQL 5.5 does not export 'const char *my_progname', so MY_INIT cannot be used.
diff -up net-snmp-5.6.1/apps/snmptrapd_sql.c.orig net-snmp-5.6.1/apps/snmptrapd_sql.c
--- net-snmp-5.6.1/apps/snmptrapd_sql.c.orig 2010-11-30 22:08:59.000000000 +0100
+++ net-snmp-5.6.1/apps/snmptrapd_sql.c 2011-02-15 13:01:31.631486477 +0100
@@ -434,7 +434,7 @@ netsnmp_mysql_init(void)
return -1;
}
- MY_INIT("snmptrapd");
+ my_init();
/** load .my.cnf values */
load_defaults ("my", _sql.groups, &not_argc, &not_argv);

View File

@ -1,14 +0,0 @@
Fix a typo in libtool, seems to be related to bug #742678
diff -up net-snmp-5.7.1/ltmain.sh.orig net-snmp-5.7.1/ltmain.sh
--- net-snmp-5.7.1/ltmain.sh.orig 2011-09-28 06:53:47.000000000 +0200
+++ net-snmp-5.7.1/ltmain.sh 2011-10-04 09:48:11.022131513 +0200
@@ -8051,7 +8051,7 @@ EOF
elif test -n "$runpath_var"; then
case "$perm_rpath " in
*" $libdir "*) ;;
- *) func_apped perm_rpath " $libdir" ;;
+ *) func_append perm_rpath " $libdir" ;;
esac
fi
done

View File

@ -1,16 +0,0 @@
742678: libnetsnmpmibs.so.30 is linked against libperl.so
add perl rpath to libnetsnmpmibs.so
diff -up net-snmp-5.7.1/agent/Makefile.in.orig net-snmp-5.7.1/agent/Makefile.in
--- net-snmp-5.7.1/agent/Makefile.in.orig 2011-10-04 09:49:26.762027506 +0200
+++ net-snmp-5.7.1/agent/Makefile.in 2011-10-04 10:31:48.092899541 +0200
@@ -302,7 +302,7 @@ libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VE
$(RANLIB) $(AGENTLIB)
libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION): ${LMIBOBJS} $(AGENTLIB) $(USELIBS)
- $(LIB_LD_CMD) $(MIBLIB) ${LMIBOBJS} $(AGENTLIB) $(USELIBS) @LD_NO_UNDEFINED@ $(LDFLAGS) ${LMIBLIBS} $(LIB_LD_LIBS) @AGENTLIBS@
+ $(LIB_LD_CMD) $(MIBLIB) ${LMIBOBJS} $(AGENTLIB) $(USELIBS) @LD_NO_UNDEFINED@ $(LDFLAGS) ${LMIBLIBS} $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS) @AGENTLIBS@
$(RANLIB) $(MIBLIB)
agentlib: $(AGENTLIB)

File diff suppressed because it is too large Load Diff

24
net-snmp-5.7.2-pie.patch Normal file
View File

@ -0,0 +1,24 @@
diff -up net-snmp-5.7.2/agent/Makefile.in.pie net-snmp-5.7.2/agent/Makefile.in
--- net-snmp-5.7.2/agent/Makefile.in.pie 2012-10-10 00:28:58.000000000 +0200
+++ net-snmp-5.7.2/agent/Makefile.in 2012-10-18 09:45:13.298613099 +0200
@@ -294,7 +294,7 @@ getmibstat.o: mibgroup/kernel_sunos5.c
$(CC) $(CFLAGS) -o $@ -D_GETMIBSTAT_TEST -DDODEBUG -c $?
snmpd$(EXEEXT): ${LAGENTOBJS} $(USELIBS) $(AGENTLIB) $(HELPERLIB) $(MIBLIB) $(LIBTARG)
- $(LINK) $(CFLAGS) -o $@ ${LAGENTOBJS} ${LDFLAGS} ${OUR_AGENT_LIBS}
+ $(LINK) $(CFLAGS) -o $@ -pie ${LAGENTOBJS} ${LDFLAGS} ${OUR_AGENT_LIBS}
libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION): ${LLIBAGENTOBJS} $(USELIBS)
$(LIB_LD_CMD) $(AGENTLIB) ${LLIBAGENTOBJS} $(USELIBS) ${LAGENTLIBS} @LD_NO_UNDEFINED@ $(LDFLAGS) $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS) @AGENTLIBS@
diff -up net-snmp-5.7.2/apps/Makefile.in.pie net-snmp-5.7.2/apps/Makefile.in
--- net-snmp-5.7.2/apps/Makefile.in.pie 2012-10-10 00:28:58.000000000 +0200
+++ net-snmp-5.7.2/apps/Makefile.in 2012-10-18 09:44:27.827774580 +0200
@@ -170,7 +170,7 @@ snmptest$(EXEEXT): snmptest.$(OSUFFIX
$(LINK) ${CFLAGS} -o $@ snmptest.$(OSUFFIX) ${LDFLAGS} ${LIBS}
snmptrapd$(EXEEXT): $(TRAPD_OBJECTS) $(USETRAPLIBS) $(INSTALLLIBS)
- $(LINK) ${CFLAGS} -o $@ $(TRAPD_OBJECTS) $(INSTALLLIBS) ${LDFLAGS} ${TRAPLIBS}
+ $(LINK) ${CFLAGS} -o $@ -pie $(TRAPD_OBJECTS) $(INSTALLLIBS) ${LDFLAGS} ${TRAPLIBS}
snmptrap$(EXEEXT): snmptrap.$(OSUFFIX) $(USELIBS)
$(LINK) ${CFLAGS} -o $@ snmptrap.$(OSUFFIX) ${LDFLAGS} ${LIBS}

View File

@ -10,8 +10,8 @@
Summary: A collection of SNMP protocol tools and libraries
Name: net-snmp
Version: 5.7.1
Release: 10%{?dist}
Version: 5.7.2
Release: 1%{?dist}
Epoch: 1
License: BSD
@ -29,17 +29,12 @@ Source8: net-snmptrapd.sysconfig
Source9: net-snmp-tmpfs.conf
Source10: snmpd.service
Source11: snmptrapd.service
Patch1: net-snmp-5.6-pie.patch
Patch1: net-snmp-5.7.2-pie.patch
Patch2: net-snmp-5.5-dir-fix.patch
Patch3: net-snmp-5.6-multilib.patch
Patch4: net-snmp-5.5-include-struct.patch
Patch5: net-snmp-5.5-apsl-copying.patch
Patch6: net-snmp-5.5-perl-linking.patch
Patch7: net-snmp-5.6-test-debug.patch
Patch8: net-snmp-5.6.1-mysql.patch
Patch9: net-snmp-5.7.1-systemd.patch
Patch10: net-snmp-5.7-libtool.patch
Patch11: net-snmp-5.7-mibs-perl-linking.patch
Patch4: net-snmp-5.5-apsl-copying.patch
Patch5: net-snmp-5.5-perl-linking.patch
Patch6: net-snmp-5.6-test-debug.patch
Requires(post): chkconfig
Requires(preun): chkconfig
@ -190,18 +185,13 @@ The net-snmp-sysvinit package provides SysV init scripts for Net-SNMP daemons.
%patch2 -p1 -b .dir-fix
%patch3 -p1 -b .multilib
%patch4 -p1 -b .include-struct
%patch5 -p1 -b .apsl
%patch4 -p1 -b .apsl
# Following patch removes -Wl,-rpath,/usr/lib64/perl5/CORE from
# net-snmp-config --agent-libs output. As for Fedora 15, this
# rpath is needed to link subagents, because libperl.so is in
# non-default directory - so leave the rpath there.
#%patch6 -p1 -b .perl-linking
%patch7 -p1
%patch8 -p1 -b .mysql
%patch9 -p1 -b .systemd
%patch10 -p1 -b .libtool
%patch11 -p1 -b .mibs-perl
#%patch5 -p1 -b .perl-linking
%patch6 -p1
%ifarch sparc64 s390 s390x
# disable failing test - see https://bugzilla.redhat.com/show_bug.cgi?id=680697
@ -410,7 +400,7 @@ rm -rf ${RPM_BUILD_ROOT}
%doc COPYING ChangeLog.trimmed EXAMPLE.conf FAQ NEWS TODO
%doc README README.agent-mibs README.agentx README.krb5 README.snmpv3
%doc local/passtest local/ipf-mod.pl
%doc README.thread AGENT.txt PORTING local/README.mib2c README.systemd
%doc README.thread AGENT.txt PORTING local/README.mib2c
%dir %{_sysconfdir}/snmp
%config(noreplace) %{_sysconfdir}/snmp/snmpd.conf
%config(noreplace) %{_sysconfdir}/snmp/snmptrapd.conf
@ -491,6 +481,9 @@ rm -rf ${RPM_BUILD_ROOT}
%{_initrddir}/snmptrapd
%changelog
* Thu Oct 18 2012 Jan Safranek <jsafrane@redhat.com> - 1:5.7.2-1
- Updated to 5.7.2
* Mon Aug 27 2012 Jan Safranek <jsafrane@redhat.com> - 1:5.7.1-10
- Updated RPM scriplets with latest systemd-rpm macros (#850403).
- Fixed fedora-review tool complaints.

View File

@ -1 +1 @@
c95d08fd5d93df0c11a2e1bdf0e01e0b net-snmp-5.7.1.tar.gz
5bddd02e2f82b62daa79f82717737a14 net-snmp-5.7.2.tar.gz