Use standard Fedora build flags

- Resolves #1543853

Signed-off-by: Rafael Santos <rdossant@redhat.com>
This commit is contained in:
Rafael Santos 2018-04-11 21:56:22 +02:00
parent 3d45358cc7
commit 87dfbe6ca4
2 changed files with 28 additions and 2 deletions

View File

@ -0,0 +1,19 @@
--- net-snmp-5.7.3/python/setup.py 2018-04-11 21:49:37.380726184 +0200
+++ net-snmp-5.7.3/python/setup.py 2018-04-11 21:51:50.155979432 +0200
@@ -18,14 +18,14 @@
netsnmp_libs = os.popen(basedir+'/net-snmp-config --libs').read()
libdir = os.popen(basedir+'/net-snmp-config --build-lib-dirs '+basedir).read()
incdir = os.popen(basedir+'/net-snmp-config --build-includes '+basedir).read()
- libs = re.findall(r"-l(\S+)", netsnmp_libs)
+ libs = re.findall(r"\s-l(\S+)", netsnmp_libs)
libdirs = re.findall(r"-L(\S+)", libdir)
incdirs = re.findall(r"-I(\S+)", incdir)
else:
netsnmp_libs = os.popen('net-snmp-config --libs').read()
libdirs = re.findall(r"-L(\S+)", netsnmp_libs)
incdirs = []
- libs = re.findall(r"-l(\S+)", netsnmp_libs)
+ libs = re.findall(r"\s-l(\S+)", netsnmp_libs)
setup(
name="netsnmp-python", version="1.0a1",

View File

@ -7,7 +7,7 @@
Summary: A collection of SNMP protocol tools and libraries
Name: net-snmp
Version: 5.7.3
Release: 37%{?dist}
Release: 38%{?dist}
Epoch: 1
License: BSD
@ -62,6 +62,9 @@ Patch21: net-snmp-5.7.3-iterator-fix.patch
Patch22: net-snmp-5.7.3-autofs.patch
Patch23: net-snmp-5.7.3-CVE-2018-1000116.patch
# Do not match -specs=/usr/lib/rpm/redhat/redhat-hardened-ld in regex
Patch24: net-snmp-5.7.3-python-ldflags.patch
# This patch fix issue with new OpenSLL library in rawhide (f26+)
# !!!WARNING!!! DO NOT USE IT FOR OLDER FEDORA RELEASES (>f26)
Patch100: net-snmp-5.7.3-openssl.patch
@ -227,6 +230,7 @@ cp %{SOURCE10} .
%patch21 -p1 -b .iterator-fix
%patch22 -p1 -b .autofs-skip
%patch23 -p1 -b .CVE-2018-1000116
%patch24 -p1 -b .python-ldflags
%patch100 -p1 -b .openssl
%patch101 -p1 -b .modern-rpm-api
%patch102 -p1
@ -264,7 +268,7 @@ MIBS="$MIBS ucd-snmp/lmsensorsMib"
--enable-ucd-snmp-compatibility \
--sysconfdir=%{_sysconfdir} \
--with-cflags="$RPM_OPT_FLAGS -D_RPM_4_4_COMPAT" \
--with-ldflags="-Wl,-z,relro -Wl,-z,now" \
--with-ldflags="$RPM_LD_FLAGS" \
--with-logfile="/var/log/snmpd.log" \
--with-mib-modules="$MIBS" \
--with-mysql \
@ -494,6 +498,9 @@ LD_LIBRARY_PATH=%{buildroot}/%{_libdir} make test
%{_libdir}/libnetsnmptrapd*.so.*
%changelog
* Wed Apr 11 2018 Rafael Santos <rdossant@redhat.com> - 1:5.7.3-38
- Use standard Fedora build flags (bug #1543853)
* Tue Mar 27 2018 Josef Ridky <jridky@redhat.com> - 1:5.7.3-37
- backport upstream patch for structure iterator