added btrfs support to hrFSTable
Resolves: #965348 Removed direct dependency on mysql-libs Resolves: #962739 Conflicts: net-snmp.spec
This commit is contained in:
parent
42e763ddb8
commit
3781561b22
32
net-snmp-5.7.2-btrfs.patch
Normal file
32
net-snmp-5.7.2-btrfs.patch
Normal file
@ -0,0 +1,32 @@
|
||||
Bug 965348 - HOST-RESOURCES-MIB::hrFS* not includes btrfs
|
||||
|
||||
commit da1fef382591ff45dc92eb3b95a6bfeff9ecfa4f
|
||||
Author: Jan Safranek <jsafranek@users.sourceforge.net>
|
||||
Date: Tue May 21 09:13:41 2013 +0200
|
||||
|
||||
CHANGES: snmpd: Added btrfs support to hrFSTable
|
||||
|
||||
diff -up net-snmp-5.7.2/agent/mibgroup/hardware/fsys/fsys_mntent.c.btrfs net-snmp-5.7.2/agent/mibgroup/hardware/fsys/fsys_mntent.c
|
||||
--- net-snmp-5.7.2/agent/mibgroup/hardware/fsys/fsys_mntent.c.btrfs 2012-10-10 00:28:58.000000000 +0200
|
||||
+++ net-snmp-5.7.2/agent/mibgroup/hardware/fsys/fsys_mntent.c 2013-05-21 09:22:11.457405066 +0200
|
||||
@@ -139,6 +139,7 @@ _fsys_type( char *typename )
|
||||
!strcmp(typename, MNTTYPE_REISERFS) ||
|
||||
!strcmp(typename, MNTTYPE_OCFS2) ||
|
||||
!strcmp(typename, MNTTYPE_CVFS) ||
|
||||
+ !strcmp(typename, MNTTYPE_BTRFS) ||
|
||||
!strcmp(typename, MNTTYPE_LOFS))
|
||||
return NETSNMP_FS_TYPE_OTHER;
|
||||
|
||||
diff -up net-snmp-5.7.2/agent/mibgroup/hardware/fsys/mnttypes.h.btrfs net-snmp-5.7.2/agent/mibgroup/hardware/fsys/mnttypes.h
|
||||
--- net-snmp-5.7.2/agent/mibgroup/hardware/fsys/mnttypes.h.btrfs 2012-10-10 00:28:58.000000000 +0200
|
||||
+++ net-snmp-5.7.2/agent/mibgroup/hardware/fsys/mnttypes.h 2013-05-21 09:22:33.758303373 +0200
|
||||
@@ -142,6 +142,9 @@
|
||||
#ifndef MNTTYPE_CVFS
|
||||
#define MNTTYPE_CVFS "cvfs"
|
||||
#endif
|
||||
+#ifndef MNTTYPE_BTRFS
|
||||
+#define MNTTYPE_BTRFS "btrfs"
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* File systems to skip
|
@ -11,7 +11,7 @@
|
||||
Summary: A collection of SNMP protocol tools and libraries
|
||||
Name: net-snmp
|
||||
Version: 5.7.2
|
||||
Release: 5%{?dist}.1
|
||||
Release: 6%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
License: BSD
|
||||
@ -38,6 +38,7 @@ Patch5: net-snmp-5.5-perl-linking.patch
|
||||
Patch6: net-snmp-5.6-test-debug.patch
|
||||
Patch7: net-snmp-5.7.2-systemd.patch
|
||||
Patch8: net-snmp-5.7.2-python-ipaddress-size.patch
|
||||
Patch9: net-snmp-5.7.2-btrfs.patch
|
||||
|
||||
Requires(post): chkconfig
|
||||
Requires(preun): chkconfig
|
||||
@ -48,8 +49,8 @@ Requires(preun): coreutils
|
||||
Requires: %{name}-libs = %{epoch}:%{version}-%{release}
|
||||
Requires: %{name}-agent-libs = %{epoch}:%{version}-%{release}
|
||||
Requires: mysql-libs
|
||||
# This is actually needed for the %triggerun script but Requires(triggerun)
|
||||
# is not valid. We can use %post because this particular %triggerun script
|
||||
# This is actually needed for the %%triggerun script but Requires(triggerun)
|
||||
# is not valid. We can use %%post because this particular %triggerun script
|
||||
# should fire just after this package is installed.
|
||||
Requires(post): systemd-sysv
|
||||
|
||||
@ -201,6 +202,7 @@ cp %{SOURCE12} .
|
||||
%patch6 -p1
|
||||
%patch7 -p1 -b .systemd
|
||||
%patch8 -p1 -b .ipaddress-size
|
||||
%patch9 -p1 -b .btrfs
|
||||
|
||||
%ifarch sparc64 s390 s390x
|
||||
# disable failing test - see https://bugzilla.redhat.com/show_bug.cgi?id=680697
|
||||
@ -495,6 +497,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_initrddir}/snmptrapd
|
||||
|
||||
%changelog
|
||||
* Fri Nov 8 2013 Jan Safranek <jsafrane@redhat.com> 1:5.7.2-6
|
||||
- Added btrfs support to hrFSTable
|
||||
|
||||
* Thu Feb 14 2013 Tom Callaway <spot@fedoraproject.org> 1:5.7.2-5.1
|
||||
- add missing IETF MIB license text (BSD)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user