Remove old patches
This commit is contained in:
parent
965a4c0441
commit
f28168bbd4
@ -1,23 +0,0 @@
|
||||
--- ncarg-4.4.2/config/ymake.ppc64 2006-05-02 08:16:20.000000000 -0600
|
||||
+++ ncarg-4.4.2/config/ymake 2007-06-27 10:28:13.000000000 -0600
|
||||
@@ -364,19 +364,13 @@
|
||||
case x*86:
|
||||
case i*64:
|
||||
case x*64:
|
||||
- case p*64:
|
||||
+ case ppc*:
|
||||
case alpha:
|
||||
set model = $mach
|
||||
set arch = $mach
|
||||
set sysincs = LINUX
|
||||
set vendor = IBM
|
||||
breaksw
|
||||
- case ppc:
|
||||
- set model = $mach
|
||||
- set arch = $mach
|
||||
- set sysincs = YDLINUX
|
||||
- set vendor = APPLE
|
||||
- breaksw
|
||||
default:
|
||||
echo "$0 : Unknown machine type" > /dev/tty
|
||||
exit 1
|
@ -1,11 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/ni/src/ncl/Symbol.h.flex 2007-07-13 11:12:28.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ni/src/ncl/Symbol.h 2007-12-13 12:32:10.000000000 -0700
|
||||
@@ -523,7 +523,7 @@
|
||||
|
||||
#ifndef YY_INPUT
|
||||
#define YY_INPUT(buf,result,max_size) \
|
||||
- if ( yy_current_buffer->yy_is_interactive ) \
|
||||
+ if ( YY_CURRENT_BUFFER_LVALUE->yy_is_interactive ) \
|
||||
{ \
|
||||
int c = '*', n; \
|
||||
for ( n = 0; n < max_size && \
|
@ -1,101 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/ni/src/ncl/NclHDF.c.hdf 2007-06-20 19:35:32.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ni/src/ncl/NclHDF.c 2008-03-21 13:18:13.000000000 -0600
|
||||
@@ -24,7 +24,6 @@
|
||||
#include "defs.h"
|
||||
#define HAVE_NETCDF
|
||||
#include <hdf/mfhdf.h>
|
||||
-#include <hdf/netcdf.h>
|
||||
#include "NclData.h"
|
||||
#include "NclFileInterfaces.h"
|
||||
#include <math.h>
|
||||
@@ -63,7 +62,7 @@
|
||||
NclQuark var_path;
|
||||
nc_type data_type;
|
||||
int n_dims;
|
||||
- int dim[MAX_VAR_DIMS];
|
||||
+ int dim[H4_MAX_VAR_DIMS];
|
||||
int natts;
|
||||
HDFAttInqRecList *att_list;
|
||||
};
|
||||
@@ -308,9 +307,9 @@
|
||||
|
||||
#endif
|
||||
{
|
||||
- char buffer[MAX_NC_NAME];
|
||||
+ char buffer[H4_MAX_NC_NAME];
|
||||
char *tp, *cp;
|
||||
- char len = MIN(MAX_NC_NAME - 2,strlen(hdf_name));
|
||||
+ char len = MIN(H4_MAX_NC_NAME - 2,strlen(hdf_name));
|
||||
|
||||
strncpy(buffer,hdf_name,len);
|
||||
cp = tp = buffer;
|
||||
@@ -342,7 +341,7 @@
|
||||
|
||||
*cp = '\0';
|
||||
if (ncl_class) {
|
||||
- len = MIN(MAX_NC_NAME - 1,len + 2 + strlen(ncl_class));
|
||||
+ len = MIN(H4_MAX_NC_NAME - 1,len + 2 + strlen(ncl_class));
|
||||
strncat(cp,"__",len);
|
||||
cp += 2;
|
||||
*cp = '\0';
|
||||
@@ -460,9 +459,9 @@
|
||||
int32 sd_id, sds_id, sds_ref;
|
||||
intn status;
|
||||
int32 n_datasets, n_file_attrs, index;
|
||||
- int32 dim_sizes[MAX_VAR_DIMS];
|
||||
+ int32 dim_sizes[H4_MAX_VAR_DIMS];
|
||||
int32 rank, data_type, n_attrs;
|
||||
- char name[MAX_NC_NAME]; int i;
|
||||
+ char name[H4_MAX_NC_NAME]; int i;
|
||||
/********************* End of variable declaration ***********************/
|
||||
/* * Open the file and initialize the SD interface. */
|
||||
sd_id = SDstart (path, DFACC_READ);
|
||||
@@ -647,8 +646,8 @@
|
||||
HDFFileRecord *tmp = (HDFFileRecord*) rec;
|
||||
int cdfid;
|
||||
int dummy;
|
||||
- char buffer[MAX_NC_NAME];
|
||||
- char buffer2[MAX_NC_NAME];
|
||||
+ char buffer[H4_MAX_NC_NAME];
|
||||
+ char buffer2[H4_MAX_NC_NAME];
|
||||
int i,j,has_scalar_dim = 0,nvars = 0;
|
||||
long tmp_size;
|
||||
HDFAttInqRecList **stepalptr;
|
||||
@@ -1247,7 +1246,7 @@
|
||||
int cdfid = -1;
|
||||
int ret = -1,i;
|
||||
int no_stride = 1;
|
||||
- long count[MAX_NC_DIMS];
|
||||
+ long count[H4_MAX_NC_DIMS];
|
||||
|
||||
stepvl = rec->vars;
|
||||
while(stepvl != NULL) {
|
||||
@@ -1467,7 +1466,7 @@
|
||||
HDFFileRecord *rec = (HDFFileRecord*)therec;
|
||||
int cdfid;
|
||||
HDFVarInqRecList *stepvl;
|
||||
- long count[MAX_NC_DIMS];
|
||||
+ long count[H4_MAX_NC_DIMS];
|
||||
int i,n_elem = 1,no_stride = 1;
|
||||
int ret;
|
||||
|
||||
@@ -1950,7 +1949,7 @@
|
||||
HDFVarInqRecList *stepvl = NULL;
|
||||
int cdfid,i,ret;
|
||||
nc_type *the_data_type;
|
||||
- int dim_ids[MAX_NC_DIMS];
|
||||
+ int dim_ids[H4_MAX_NC_DIMS];
|
||||
HDFDimInqRecList* stepdl = NULL;
|
||||
int add_scalar_dim = 0;
|
||||
|
||||
--- ncl_ncarg-5.0.0/ni/src/ncl/NclHDFEOS.c.hdf 2007-06-20 19:35:32.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ni/src/ncl/NclHDFEOS.c 2007-12-13 12:42:42.000000000 -0700
|
||||
@@ -67,7 +67,7 @@
|
||||
NclQuark var_class_name;
|
||||
int32 typenumber;
|
||||
int32 n_dims;
|
||||
- int32 dim[MAX_VAR_DIMS];
|
||||
+ int32 dim[H4_MAX_VAR_DIMS];
|
||||
int32 n_int_atts;
|
||||
HDFEOSAttInqRecList *att_int_list;
|
||||
};
|
@ -1,523 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/common/src/libncarg_c/bcopyswap.c.includes 2000-08-21 22:03:31.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/common/src/libncarg_c/bcopyswap.c 2008-03-21 11:01:12.000000000 -0600
|
||||
@@ -33,6 +33,7 @@
|
||||
* of 4.
|
||||
*/
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
bcopyswap(b1, b2, size)
|
||||
char *b1;
|
||||
--- ncl_ncarg-5.0.0/common/src/bin/ncargpath/ncargpath.c.includes 2000-08-21 22:04:15.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/common/src/bin/ncargpath/ncargpath.c 2008-03-21 11:02:16.000000000 -0600
|
||||
@@ -41,6 +41,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <ncarg/c.h>
|
||||
|
||||
--- ncl_ncarg-5.0.0/ncarg2d/src/libncarg/plotchar/bofred.c.includes 2000-08-22 09:05:20.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg/plotchar/bofred.c 2008-03-21 11:04:17.000000000 -0600
|
||||
@@ -25,6 +25,10 @@
|
||||
************************************************************************/
|
||||
|
||||
|
||||
+#include <sys/types.h>
|
||||
+#include <sys/stat.h>
|
||||
+#include <fcntl.h>
|
||||
+#include <stdlib.h>
|
||||
#include <stdio.h>
|
||||
#include <ncarg/c.h>
|
||||
|
||||
--- ncl_ncarg-5.0.0/ncarg2d/src/libncarg/areasC/c_argeti.c.includes 2000-08-22 09:02:06.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg/areasC/c_argeti.c 2008-03-21 11:05:46.000000000 -0600
|
||||
@@ -24,6 +24,7 @@
|
||||
* *
|
||||
************************************************************************/
|
||||
|
||||
+#include <string.h>
|
||||
#include <ncarg/ncargC.h>
|
||||
|
||||
extern void NGCALLF(argeti,ARGETI)(NGstring,int*,int);
|
||||
--- ncl_ncarg-5.0.0/ncarg2d/src/libncarg/ncargC.h.includes 2008-03-21 11:10:43.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg/ncargC.h 2008-03-21 11:10:25.000000000 -0600
|
||||
@@ -176,6 +176,12 @@
|
||||
#endif
|
||||
);
|
||||
|
||||
+extern void NGCALLF(agback,AGBACK)(
|
||||
+#ifdef NeedFuncProto
|
||||
+ void
|
||||
+#endif
|
||||
+);
|
||||
+
|
||||
extern char *c_agbnch(
|
||||
#ifdef NeedFuncProto
|
||||
int idsh
|
||||
--- ncl_ncarg-5.0.0/ncarg2d/src/libncarg_gks/zlib/gzio.c.includes 2005-12-04 13:52:16.000000000 -0700
|
||||
+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg_gks/zlib/gzio.c 2008-03-21 11:15:20.000000000 -0600
|
||||
@@ -8,6 +8,7 @@
|
||||
/* @(#) $Id: gzio.c,v 1.2 2005/12/04 20:52:16 haley Exp $ */
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <stdarg.h>
|
||||
|
||||
#include "zutil.h"
|
||||
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/raster.c.includes 2000-08-22 09:12:16.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/raster.c 2008-04-10 14:53:26.000000000 -0600
|
||||
@@ -48,6 +48,7 @@
|
||||
*
|
||||
*/
|
||||
#include <stdio.h>
|
||||
+#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <fcntl.h>
|
||||
#include <errno.h>
|
||||
@@ -518,6 +519,7 @@
|
||||
* RAS_ERROR or RAS_EOF if something went wrong.
|
||||
*
|
||||
*********************************************************************/
|
||||
+int
|
||||
RasterLoadPalette(ras, colors)
|
||||
Raster *ras;
|
||||
unsigned char colors[768];
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.c.includes 2000-08-22 09:12:12.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.c 2008-04-10 14:57:14.000000000 -0600
|
||||
@@ -71,6 +71,7 @@
|
||||
|
||||
/* Swiped from John Clyne */
|
||||
|
||||
+void
|
||||
_swapshort (bp, n)
|
||||
register char *bp;
|
||||
register unsigned n;
|
||||
@@ -86,6 +87,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
+void
|
||||
_swaplong (bp, n)
|
||||
register char *bp;
|
||||
register unsigned n;
|
||||
@@ -112,6 +114,7 @@
|
||||
*
|
||||
* Return the number of images in a file. Return -1 on error
|
||||
*/
|
||||
+int
|
||||
ImageCount_(name, format)
|
||||
char *name;
|
||||
char *format;
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.h.includes 2008-04-10 14:57:41.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.h 2008-04-10 15:00:16.000000000 -0600
|
||||
@@ -0,0 +1,41 @@
|
||||
+/*
|
||||
+ * $Id$
|
||||
+ */
|
||||
+/************************************************************************
|
||||
+* *
|
||||
+* Copyright (C) 2000 *
|
||||
+* University Corporation for Atmospheric Research *
|
||||
+* All Rights Reserved *
|
||||
+* *
|
||||
+* This file is free software; you can redistribute it and/or modify *
|
||||
+* it under the terms of the GNU General Public License as published *
|
||||
+* by the Free Software Foundation; either version 2 of the License, or *
|
||||
+* (at your option) any later version. *
|
||||
+* *
|
||||
+* This software is distributed in the hope that it will be useful, but *
|
||||
+* WITHOUT ANY WARRANTY; without even the implied warranty of *
|
||||
+* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
|
||||
+* General Public License for more details. *
|
||||
+* *
|
||||
+* You should have received a copy of the GNU General Public License *
|
||||
+* along with this software; if not, write to the Free Software *
|
||||
+* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 *
|
||||
+* USA. *
|
||||
+* *
|
||||
+************************************************************************/
|
||||
+
|
||||
+/***********************************************************************
|
||||
+* *
|
||||
+* Copyright (C) 1991 *
|
||||
+* University Corporation for Atmospheric Research *
|
||||
+* All Rights Reserved *
|
||||
+* *
|
||||
+* *
|
||||
+***********************************************************************/
|
||||
+/* File: misc.h
|
||||
+ */
|
||||
+
|
||||
+int read_swap(FILE *fp, int nb, char *buf, int swapflag);
|
||||
+void _swapshort (register char *bp, register unsigned n);
|
||||
+void _swaplong (register char *bp, register unsigned n);
|
||||
+int ImageCount_(char *name, char *format);
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.c.includes 2008-04-10 15:29:16.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.c 2008-04-10 15:28:57.000000000 -0600
|
||||
@@ -76,7 +76,7 @@
|
||||
/*
|
||||
* Flushes out the output buffer. Called at the end of a picture.
|
||||
*/
|
||||
-flush()
|
||||
+void flush()
|
||||
{
|
||||
(void)write(outFD,outbuf,outbufnum);
|
||||
outbufnum = 0;
|
||||
@@ -86,7 +86,7 @@
|
||||
* Copies the "count" number of chars from "str" into the output buffer,
|
||||
* flushing the buffer if need be.
|
||||
*/
|
||||
-buffer(str,count)
|
||||
+void buffer(str,count)
|
||||
SignedChar *str;
|
||||
int count;
|
||||
{
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.h.includes 2008-04-10 15:29:29.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.h 2008-04-10 15:31:08.000000000 -0600
|
||||
@@ -0,0 +1,37 @@
|
||||
+/*
|
||||
+ * $Id$
|
||||
+ */
|
||||
+/************************************************************************
|
||||
+* *
|
||||
+* This file is free software; you can redistribute it and/or modify *
|
||||
+* it under the terms of the GNU General Public License as published *
|
||||
+* by the Free Software Foundation; either version 2 of the License, or *
|
||||
+* (at your option) any later version. *
|
||||
+* *
|
||||
+* This software is distributed in the hope that it will be useful, but *
|
||||
+* WITHOUT ANY WARRANTY; without even the implied warranty of *
|
||||
+* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
|
||||
+* General Public License for more details. *
|
||||
+* *
|
||||
+* You should have received a copy of the GNU General Public License *
|
||||
+* along with this software; if not, write to the Free Software *
|
||||
+* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 *
|
||||
+* USA. *
|
||||
+* *
|
||||
+************************************************************************/
|
||||
+
|
||||
+/***********************************************************************
|
||||
+* *
|
||||
+* Copyright (C) 1990 *
|
||||
+* University Corporation for Atmospheric Research *
|
||||
+* All Rights Reserved *
|
||||
+* *
|
||||
+* NCAR View V3.01 - UNIX Release *
|
||||
+* *
|
||||
+***********************************************************************/
|
||||
+
|
||||
+#include "ctrandef.h"
|
||||
+
|
||||
+int GcapOpenBuffer(char *file);
|
||||
+void flush(void);
|
||||
+void buffer(SignedChar *str, int count);
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.c.includes 2000-08-22 09:11:45.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.c 2008-04-10 15:15:45.000000000 -0600
|
||||
@@ -99,7 +99,7 @@
|
||||
|
||||
|
||||
|
||||
-InitDefault()
|
||||
+void InitDefault()
|
||||
{
|
||||
static boolean isInit = FALSE;
|
||||
int max_intensity = (1 << DCP) - 1;
|
||||
@@ -173,7 +173,7 @@
|
||||
colorLUTable.damage = FALSE;
|
||||
}
|
||||
|
||||
-SetInPic(value)
|
||||
+void SetInPic(value)
|
||||
boolean value;
|
||||
{
|
||||
int i;
|
||||
@@ -1290,7 +1290,7 @@
|
||||
/*
|
||||
* set mininum line width
|
||||
*/
|
||||
-SetMinLineWidthDefault(line_width)
|
||||
+void SetMinLineWidthDefault(line_width)
|
||||
float line_width;
|
||||
{
|
||||
|
||||
@@ -1315,7 +1315,7 @@
|
||||
/*
|
||||
* Set Maximum line width.
|
||||
*/
|
||||
-SetMaxLineWidthDefault(line_width)
|
||||
+void SetMaxLineWidthDefault(line_width)
|
||||
float line_width;
|
||||
{
|
||||
defaulttable.line_width = MIN(line_width, defaulttable.line_width);
|
||||
@@ -1330,7 +1330,7 @@
|
||||
/*
|
||||
* set additional line scaling
|
||||
*/
|
||||
-SetAdditionalLineScale(line_scale)
|
||||
+void SetAdditionalLineScale(line_scale)
|
||||
float line_scale;
|
||||
{
|
||||
LINE_WIDTH_DAMAGE = TRUE;
|
||||
@@ -1344,7 +1344,7 @@
|
||||
/*
|
||||
* set rgb intensity scaling
|
||||
*/
|
||||
-SetRGBIntensityScale(rgb_scale)
|
||||
+void SetRGBIntensityScale(rgb_scale)
|
||||
float rgb_scale;
|
||||
{
|
||||
COLOUR_TABLE_DAMAGE = TRUE;
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.h.includes 2000-08-21 21:30:26.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.h 2008-04-10 15:26:23.000000000 -0600
|
||||
@@ -454,3 +454,73 @@
|
||||
#define COLOUR_INDEX_RED(I) (clut->ce[(I)].rgb.red)
|
||||
#define COLOUR_INDEX_GREEN(I) (clut->ce[(I)].rgb.green)
|
||||
#define COLOUR_INDEX_BLUE(I) (clut->ce[(I)].rgb.blue)
|
||||
+
|
||||
+void InitDefault(void);
|
||||
+void _CtDefNoColorDefault(void);
|
||||
+void SetInPic(boolean value);
|
||||
+int MFVersion(CGMC *c);
|
||||
+int MFDesc(CGMC *c);
|
||||
+int VDCType(CGMC *c);
|
||||
+int IntergerPrec(CGMC *c);
|
||||
+int RealPrec(CGMC *c);
|
||||
+int IndexPrec(CGMC *c);
|
||||
+int ColrPrec(CGMC *c);
|
||||
+int ColrIndexPrec(CGMC *c);
|
||||
+int MaxColrIndex(CGMC *c);
|
||||
+int ColrValueExt(CGMC *c);
|
||||
+int MFElemList(CGMC *c);
|
||||
+int MFDefaults(CGMC *c);
|
||||
+int CharSetList(CGMC *c);
|
||||
+int CharCoding(CGMC *c);
|
||||
+int ScaleMode(CGMC *c);
|
||||
+int ColrMode(CGMC *c);
|
||||
+int LineWidthMode(CGMC *c);
|
||||
+int MarkerSizeMode(CGMC *c);
|
||||
+int EdgeWidthMode(CGMC *c);
|
||||
+int VDCExt(CGMC *c);
|
||||
+int BackColr(CGMC *c);
|
||||
+int VDCIntergerPrec(CGMC *c);
|
||||
+int VDCRealPrec(CGMC *c);
|
||||
+int AuxColr(CGMC *c);
|
||||
+int Transparency(CGMC *c);
|
||||
+int ClipRect(CGMC *c);
|
||||
+int Clip(CGMC *c);
|
||||
+int LineIndex(CGMC *c);
|
||||
+int LineType(CGMC *c);
|
||||
+int LineWidth(CGMC *c);
|
||||
+int LineColr(CGMC *c);
|
||||
+int MarkerIndex(CGMC *c);
|
||||
+int MarkerType(CGMC *c);
|
||||
+int MarkerSize(CGMC *c);
|
||||
+int MarkerColr(CGMC *c);
|
||||
+int TextIndex(CGMC *c);
|
||||
+int TextFontIndex(CGMC *c);
|
||||
+int TextPrec(CGMC *c);
|
||||
+int CharExpan(CGMC *c);
|
||||
+int CharSpace(CGMC *c);
|
||||
+int TextColr(CGMC *c);
|
||||
+int CharHeight(CGMC *c);
|
||||
+int CharOri(CGMC *c);
|
||||
+int TextPath(CGMC *c);
|
||||
+int TextAlign(CGMC *c);
|
||||
+int CharSetIndex(CGMC *c);
|
||||
+int AltCharSetIndex(CGMC *c);
|
||||
+int FillIndex(CGMC *c);
|
||||
+int IntStyle(CGMC *c);
|
||||
+int FillColr(CGMC *c);
|
||||
+int HatchIndex(CGMC *c);
|
||||
+int PatIndex(CGMC *c);
|
||||
+int EdgeIndex(CGMC *c);
|
||||
+int EdgeType(CGMC *c);
|
||||
+int EdgeWidth(CGMC *c);
|
||||
+int EdgeColr(CGMC *c);
|
||||
+int EdgeVis(CGMC *c);
|
||||
+int FillRefPt(CGMC *c);
|
||||
+int PatTable(CGMC *c);
|
||||
+int PatSize(CGMC *c);
|
||||
+int ColrTable(CGMC *c);
|
||||
+int ASF(CGMC *c);
|
||||
+void SetMinLineWidthDefault(float line_width);
|
||||
+void SetMaxLineWidthDefault(float line_width);
|
||||
+void SetAdditionalLineScale(float line_scale);
|
||||
+void SetRGBIntensityScale(float rgb_scale);
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/gcaprast.c.includes 2000-08-22 09:11:48.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/gcaprast.c 2008-04-10 15:32:49.000000000 -0600
|
||||
@@ -44,6 +44,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <ncarg/c.h>
|
||||
#include "cgmc.h"
|
||||
@@ -52,9 +53,8 @@
|
||||
#include "ctrandef.h"
|
||||
#include "translate.h"
|
||||
#include "bitops.h"
|
||||
-
|
||||
-
|
||||
-
|
||||
+#include "buffer.h"
|
||||
+#include "format.h"
|
||||
|
||||
static boolean Runlength; /* true if device wants run length encoded
|
||||
* pixel map
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/in.h.includes 2008-04-10 15:08:11.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/in.h 2008-04-10 15:08:42.000000000 -0600
|
||||
@@ -29,6 +29,9 @@
|
||||
* NCAR View V3.00 - UNIX Release *
|
||||
* *
|
||||
***********************************************************************/
|
||||
+
|
||||
+#include "cgmc.h"
|
||||
+
|
||||
#define BUFSIZE 1440 /*size of CGM buffer in bytes */
|
||||
#define N -1 /*flag indicating any integer value */
|
||||
#define STDIN 0
|
||||
@@ -72,4 +75,5 @@
|
||||
*/
|
||||
};
|
||||
|
||||
+int Instr_Dec(CGMC *cgmc);
|
||||
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.c.includes 2000-08-22 09:11:50.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.c 2008-04-10 15:09:55.000000000 -0600
|
||||
@@ -36,7 +36,7 @@
|
||||
* Description: miscellaneous ctrans funcions
|
||||
*/
|
||||
|
||||
-CoordStringToInt(s, llx, lly, urx, ury)
|
||||
+int CoordStringToInt(s, llx, lly, urx, ury)
|
||||
char *s;
|
||||
int *llx, *lly, *urx, *ury;
|
||||
{
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.h.includes 2008-04-10 15:10:15.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.h 2008-04-10 15:11:11.000000000 -0600
|
||||
@@ -0,0 +1,31 @@
|
||||
+/*
|
||||
+ * $Id$
|
||||
+ */
|
||||
+/************************************************************************
|
||||
+* *
|
||||
+* Copyright (C) 1992 *
|
||||
+* University Corporation for Atmospheric Research *
|
||||
+* All Rights Reserved *
|
||||
+* *
|
||||
+* This file is free software; you can redistribute it and/or modify *
|
||||
+* it under the terms of the GNU General Public License as published *
|
||||
+* by the Free Software Foundation; either version 2 of the License, or *
|
||||
+* (at your option) any later version. *
|
||||
+* *
|
||||
+* This software is distributed in the hope that it will be useful, but *
|
||||
+* WITHOUT ANY WARRANTY; without even the implied warranty of *
|
||||
+* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
|
||||
+* General Public License for more details. *
|
||||
+* *
|
||||
+* You should have received a copy of the GNU General Public License *
|
||||
+* along with this software; if not, write to the Free Software *
|
||||
+* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 *
|
||||
+* USA. *
|
||||
+* *
|
||||
+************************************************************************/
|
||||
+
|
||||
+/*
|
||||
+ * File: misc.h
|
||||
+ */
|
||||
+
|
||||
+int CoordStringToInt(char *s, int *llx, int *lly, int *urx, int *ury);
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/rast.c.includes 2005-08-03 15:14:16.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/rast.c 2008-04-10 16:02:40.000000000 -0600
|
||||
@@ -30,6 +30,7 @@
|
||||
* *
|
||||
***********************************************************************/
|
||||
|
||||
+#include "in.h"
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
@@ -44,6 +45,7 @@
|
||||
#include "ctrandef.h"
|
||||
#include "default.h"
|
||||
#include "devices.h"
|
||||
+#include "misc.h"
|
||||
|
||||
extern boolean *softFill;
|
||||
extern boolean deviceIsInit;
|
||||
@@ -104,7 +106,7 @@
|
||||
Raster *rastGrid; /* struct for creating output file */
|
||||
boolean rasIsDirect; /* direct encoded image? */
|
||||
|
||||
-static build_ras_arg(ras_argc, ras_argv, rast_opts)
|
||||
+static int build_ras_arg(ras_argc, ras_argv, rast_opts)
|
||||
int *ras_argc;
|
||||
char **ras_argv;
|
||||
struct Opts rast_opts;
|
||||
@@ -166,7 +168,7 @@
|
||||
}
|
||||
|
||||
|
||||
-static clear_grid(grid)
|
||||
+static void clear_grid(grid)
|
||||
Raster *grid;
|
||||
{
|
||||
if (rasIsDirect) {
|
||||
@@ -184,7 +186,7 @@
|
||||
}
|
||||
}
|
||||
|
||||
-static init_color_tab()
|
||||
+static void init_color_tab()
|
||||
{
|
||||
|
||||
/*
|
||||
@@ -198,7 +200,7 @@
|
||||
|
||||
#define DEFAULT_WIDTH 512 /* default raster width */
|
||||
#define DEFAULT_HEIGHT 512 /* default raster height */
|
||||
-get_resolution(dev_extent, opts, name)
|
||||
+void get_resolution(dev_extent, opts, name)
|
||||
CoordRect *dev_extent;
|
||||
struct Opts opts;
|
||||
char *name;
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sunraster.c.includes 2000-08-22 09:12:19.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sunraster.c 2008-04-10 17:02:27.000000000 -0600
|
||||
@@ -59,8 +59,10 @@
|
||||
#include <fcntl.h>
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
#include "ncarg_ras.h"
|
||||
#include "sunraster.h"
|
||||
+#include "misc.h"
|
||||
|
||||
static char *FormatName = "sun";
|
||||
|
||||
@@ -235,18 +237,18 @@
|
||||
dep = (SunInfo *) ras->dep;
|
||||
}
|
||||
|
||||
- nb = write(ras->fd, (char *) dep, sizeof(SunInfo));
|
||||
+ nb = write(ras->fd, dep, sizeof(SunInfo));
|
||||
if (nb != sizeof(SunInfo)) return(RAS_EOF);
|
||||
|
||||
/* Write the color table. */
|
||||
|
||||
- nb = write(ras->fd, (char *) ras->red, ras->ncolor);
|
||||
+ nb = write(ras->fd, ras->red, ras->ncolor);
|
||||
if (nb != ras->ncolor) return(RAS_EOF);
|
||||
|
||||
- nb = write(ras->fd, (char *) ras->green, ras->ncolor);
|
||||
+ nb = write(ras->fd, ras->green, ras->ncolor);
|
||||
if (nb != ras->ncolor) return(RAS_EOF);
|
||||
|
||||
- nb = write(ras->fd, (char *) ras->blue, ras->ncolor);
|
||||
+ nb = write(ras->fd, ras->blue, ras->ncolor);
|
||||
if (nb != ras->ncolor) return(RAS_EOF);
|
||||
|
||||
/*
|
@ -1,13 +0,0 @@
|
||||
diff -up ncl_ncarg-5.0.0/ni/src/scripts/nhlf77.csh.netcdff ncl_ncarg-5.0.0/ni/src/scripts/nhlf77.csh
|
||||
--- ncl_ncarg-5.0.0/ni/src/scripts/nhlf77.csh.netcdff 2008-02-01 23:55:21.000000000 +0100
|
||||
+++ ncl_ncarg-5.0.0/ni/src/scripts/nhlf77.csh 2008-02-01 23:57:23.000000000 +0100
|
||||
@@ -64,7 +64,7 @@ foreach arg ($argv)
|
||||
|
||||
case "-netcdf":
|
||||
case "-cdf":
|
||||
- set extra_libs = "$extra_libs SED_NCDFLIBS"
|
||||
+ set extra_libs = "$extra_libs SED_NCDFLIBS -lnetcdff"
|
||||
breaksw
|
||||
|
||||
case "-hdf":
|
||||
diff -up ncl_ncarg-5.0.0/ni/src/scripts/ng4ex.csh.netcdff ncl_ncarg-5.0.0/ni/src/scripts/ng4ex.csh
|
@ -1,11 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/config/Project.png 2007-12-14 08:03:39.000000000 -0700
|
||||
+++ ncl_ncarg-5.0.0/config/Project 2007-12-14 08:04:02.000000000 -0700
|
||||
@@ -170,7 +170,7 @@
|
||||
#endif /* HDFEOSlib */
|
||||
|
||||
#ifndef GRIB2lib
|
||||
-#define GRIB2lib -lgrib2c -ljasper
|
||||
+#define GRIB2lib -lgrib2c -ljasper -lpng
|
||||
#endif /* GRIB2lib */
|
||||
|
||||
#ifndef NetCDFlib
|
@ -1,13 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/ni/src/lib/hlu/CnTriMeshRenderer.c.orig 2007-11-13 15:00:42.000000000 -0700
|
||||
+++ ncl_ncarg-5.0.0/ni/src/lib/hlu/CnTriMeshRenderer.c 2007-11-13 15:01:05.000000000 -0700
|
||||
@@ -30,8 +30,10 @@
|
||||
#include <ncarg/hlu/CurvilinearTransObj.h>
|
||||
#include <ncarg/hlu/SphericalTransObj.h>
|
||||
#include <ncarg/hlu/TriMeshTransObj.h>
|
||||
+#ifdef BuildTRIANGLE
|
||||
#define REAL double
|
||||
#include <ncarg/hlu/triangle.h>
|
||||
+#endif
|
||||
|
||||
#define Oset(field) \
|
||||
NhlOffset(NhlCnTriMeshRendererLayerRec,cntrimeshrenderer.field)
|
@ -1,106 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sgiraster.c.uint32 2000-08-22 09:12:18.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sgiraster.c 2008-04-11 09:29:45.000000000 -0600
|
||||
@@ -315,8 +315,8 @@
|
||||
just to be safe.
|
||||
*/
|
||||
|
||||
- sgiinfo->tmpbuf = (UInt16_T *) ras_calloc(3*header->xsize, 1);
|
||||
- if (sgiinfo->tmpbuf == (UInt16_T *) NULL) {
|
||||
+ sgiinfo->tmpbuf = (uint16_t *) ras_calloc(3*header->xsize, 1);
|
||||
+ if (sgiinfo->tmpbuf == (uint16_t *) NULL) {
|
||||
(void) ESprintf(errno, "malloc(%d)", (3*header->xsize));
|
||||
return(RAS_ERROR);
|
||||
}
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sgiraster.h.uint32 2000-08-21 21:30:25.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sgiraster.h 2008-04-11 10:02:33.000000000 -0600
|
||||
@@ -27,6 +27,7 @@
|
||||
#ifndef __SGIRASTER_H__
|
||||
#define __SGIRASTER_H__
|
||||
|
||||
+#include <stdint.h>
|
||||
|
||||
#define SGI_FORMAT_NAME "sgi"
|
||||
#define SGI_MAGIC 0732
|
||||
@@ -65,18 +66,6 @@
|
||||
is not (yet) that large.
|
||||
*/
|
||||
|
||||
-#ifdef alpha
|
||||
-typedef unsigned int UInt32_T;
|
||||
-typedef unsigned short UInt16_T;
|
||||
-typedef int Int32_T;
|
||||
-typedef short Int16_T;
|
||||
-#else
|
||||
-typedef unsigned long UInt32_T;
|
||||
-typedef unsigned short UInt16_T;
|
||||
-typedef long Int32_T;
|
||||
-typedef short Int16_T;
|
||||
-#endif
|
||||
-
|
||||
#define RAS_SGI_RESERVED 512
|
||||
|
||||
/*
|
||||
@@ -84,15 +73,15 @@
|
||||
**
|
||||
*/
|
||||
typedef struct {
|
||||
- UInt16_T imagic B16;
|
||||
- UInt16_T type B16;
|
||||
- UInt16_T dim B16;
|
||||
- UInt16_T xsize B16;
|
||||
- UInt16_T ysize B16;
|
||||
- UInt16_T zsize B16;
|
||||
- UInt32_T min B32;
|
||||
- UInt32_T max B32;
|
||||
- UInt32_T wastebytes B32;
|
||||
+ uint16_t imagic B16;
|
||||
+ uint16_t type B16;
|
||||
+ uint16_t dim B16;
|
||||
+ uint16_t xsize B16;
|
||||
+ uint16_t ysize B16;
|
||||
+ uint16_t zsize B16;
|
||||
+ uint32_t min B32;
|
||||
+ uint32_t max B32;
|
||||
+ uint32_t wastebytes B32;
|
||||
char name[80];
|
||||
SgiColormapType colormap B32;
|
||||
} SGIFileHeader_T;
|
||||
--- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sunraster.h.uint32 2000-08-21 21:30:25.000000000 -0600
|
||||
+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sunraster.h 2008-04-11 10:02:46.000000000 -0600
|
||||
@@ -27,13 +27,9 @@
|
||||
#ifndef _RASTER_SUN_
|
||||
#define _RASTER_SUN_
|
||||
|
||||
-#define RAS_SUN_ESC 128
|
||||
+#include <stdint.h>
|
||||
|
||||
-#ifdef alpha
|
||||
-typedef unsigned int UInt32_T;
|
||||
-#else
|
||||
-typedef unsigned long UInt32_T;
|
||||
-#endif
|
||||
+#define RAS_SUN_ESC 128
|
||||
|
||||
/* Sun image encoding types. */
|
||||
|
||||
@@ -55,14 +51,14 @@
|
||||
#define SUN_HEADER_SIZE 32
|
||||
|
||||
typedef struct SunInfoStruct {
|
||||
- UInt32_T ras_magic B32; /* magic number */
|
||||
- UInt32_T ras_width B32; /* width (pixels) of image */
|
||||
- UInt32_T ras_height B32; /* height (pixels) of image */
|
||||
- UInt32_T ras_depth B32; /* depth - 1,8,24 bits */
|
||||
- UInt32_T ras_length B32; /* length (bytes) of image */
|
||||
+ uint32_t ras_magic B32; /* magic number */
|
||||
+ uint32_t ras_width B32; /* width (pixels) of image */
|
||||
+ uint32_t ras_height B32; /* height (pixels) of image */
|
||||
+ uint32_t ras_depth B32; /* depth - 1,8,24 bits */
|
||||
+ uint32_t ras_length B32; /* length (bytes) of image */
|
||||
SunEncodingType ras_type B32;
|
||||
SunColormapType ras_maptype B32;
|
||||
- UInt32_T ras_maplength B32;/* length (bytes) of following map */
|
||||
+ uint32_t ras_maplength B32;/* length (bytes) of following map */
|
||||
} SunInfo;
|
||||
|
||||
#define RAS_MAGIC 0x59a66a95
|
@ -1,16 +0,0 @@
|
||||
--- ncl_ncarg-5.0.0/ni/src/mkwrap/yMakefile.wrapit 2007-12-14 15:00:17.000000000 -0700
|
||||
+++ ncl_ncarg-5.0.0/ni/src/mkwrap/yMakefile 2007-12-14 15:00:41.000000000 -0700
|
||||
@@ -55,11 +55,11 @@
|
||||
|
||||
GEN_SRCS = y.tab.c lex.yy.c
|
||||
|
||||
-STATIC_SRCS = Symbol.c wrapit.c
|
||||
+STATIC_SRCS = Symbol.c wrapit77.c
|
||||
|
||||
GEN_OBJS = y.tab.o lex.yy.o
|
||||
|
||||
-STATIC_OBJS = Symbol.o wrapit.o
|
||||
+STATIC_OBJS = Symbol.o wrapit77.o
|
||||
|
||||
OBJS = $(GEN_OBJS) $(STATIC_OBJS)
|
||||
|
2
ncl.spec
2
ncl.spec
@ -30,7 +30,6 @@ Patch0: ncl-5.0.0-paths.patch
|
||||
Patch1: ncarg-4.4.1-deps.patch
|
||||
Patch2: ncl-5.1.0-ppc64.patch
|
||||
Patch7: ncl-5.0.0-atlas.patch
|
||||
Patch9: ncl-5.0.0-wrapit.patch
|
||||
# don't have the installation target depends on the build target since
|
||||
# for library it implies running ranlib and modifying the library timestamp
|
||||
Patch10: ncl-5.0.0-no_install_dep.patch
|
||||
@ -109,7 +108,6 @@ Example programs and data using NCL.
|
||||
|
||||
%prep
|
||||
%setup -q -n ncl_ncarg-%{version}
|
||||
#%patch0 -p1 -b .rpmroot
|
||||
%patch0 -p1 -b .paths
|
||||
%patch1 -p1 -b .deps
|
||||
%patch2 -p1 -b .ppc64
|
||||
|
Loading…
Reference in New Issue
Block a user