Update to 6.1.0
Drop xwd patch applied upstream
This commit is contained in:
parent
b7ae783de1
commit
72596a0f1d
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ ncl_ncarg_src-5.2.0.tar.gz
|
||||
ncl_ncarg_src-5.2.1.tar.gz
|
||||
/ncl_ncarg-6.0.0-beta.tar.gz
|
||||
/ncl_ncarg-6.0.0.tar.gz
|
||||
/ncl_ncarg-6.1.0.tar.gz
|
||||
|
@ -1,50 +0,0 @@
|
||||
diff -up ncl_ncarg-6.1.0-beta/ncarview/src/lib/libncarg_ras/xwd.c.64bit ncl_ncarg-6.1.0-beta/ncarview/src/lib/libncarg_ras/xwd.c
|
||||
--- ncl_ncarg-6.1.0-beta/ncarview/src/lib/libncarg_ras/xwd.c.64bit 2012-05-28 13:36:41.000000000 -0600
|
||||
+++ ncl_ncarg-6.1.0-beta/ncarview/src/lib/libncarg_ras/xwd.c 2012-07-12 17:03:53.730179494 -0600
|
||||
@@ -186,7 +186,7 @@ XWDRead(ras)
|
||||
static unsigned buffer_size; /* size of image */
|
||||
unsigned char *cptr1, *cptr2;
|
||||
int status, i;
|
||||
- XColor xcolors[256]; /* color palette in X dump */
|
||||
+ XWDColor xcolors[256]; /* color palette in X dump */
|
||||
int win_name_size; /* not used */
|
||||
unsigned image_size();
|
||||
static unsigned long swaptest = 1;
|
||||
@@ -303,8 +303,8 @@ XWDRead(ras)
|
||||
/* Read in the color palette */
|
||||
|
||||
status = fread((char *) xcolors, 1,
|
||||
- (int) (ras->ncolor * sizeof(XColor)), ras->fp);
|
||||
- if (status != ras->ncolor * sizeof(XColor)) {
|
||||
+ (int) (ras->ncolor * sizeof(XWDColor)), ras->fp);
|
||||
+ if (status != ras->ncolor * sizeof(XWDColor)) {
|
||||
(void) ESprintf(RAS_E_NOT_IN_CORRECT_FORMAT,
|
||||
"XWDRead(\"%s\")", ras->name);
|
||||
}
|
||||
@@ -313,7 +313,7 @@ XWDRead(ras)
|
||||
|
||||
if (*(char *) &swaptest) {
|
||||
for (i = 0; i < ras->ncolor; i++) {
|
||||
- _swaplong((char *) &xcolors[i].pixel, sizeof(long));
|
||||
+ _swaplong((char *) &xcolors[i].pixel, sizeof(xcolors[i].pixel));
|
||||
_swapshort((char *) &xcolors[i].red, 3 * sizeof(short));
|
||||
}
|
||||
}
|
||||
@@ -469,7 +469,7 @@ int
|
||||
XWDWrite(ras)
|
||||
Raster *ras;
|
||||
{
|
||||
- XColor xcolors[256]; /* color palette in X dump */
|
||||
+ XWDColor xcolors[256]; /* color palette in X dump */
|
||||
int nb;
|
||||
int i;
|
||||
unsigned long swaptest = 1;
|
||||
@@ -519,7 +519,7 @@ XWDWrite(ras)
|
||||
|
||||
if (*(char *) &swaptest) {
|
||||
for (i = 0; i < ras->ncolor; i++) {
|
||||
- _swaplong((char *) &xcolors[i].pixel, sizeof(long));
|
||||
+ _swaplong((char *) &xcolors[i].pixel, sizeof(xcolors[i].pixel));
|
||||
_swapshort((char *) &xcolors[i].red, 3 * sizeof(short));
|
||||
}
|
||||
}
|
11
ncl.spec
11
ncl.spec
@ -1,6 +1,6 @@
|
||||
Name: ncl
|
||||
Version: 6.0.0
|
||||
Release: 7%{?dist}
|
||||
Version: 6.1.0
|
||||
Release: 1%{?dist}
|
||||
Summary: NCAR Command Language and NCAR Graphics
|
||||
|
||||
Group: Applications/Engineering
|
||||
@ -31,8 +31,6 @@ Patch1: ncarg-4.4.1-deps.patch
|
||||
Patch2: ncl-5.1.0-ppc64.patch
|
||||
# Add needed -lm to ictrans build, remove unneeded -lrx -lidn -ldl from ncl
|
||||
Patch3: ncl-libs.patch
|
||||
# Patch to fix xwd driver on 64-bit (bug 839707)
|
||||
Patch4: ncl-xwd.patch
|
||||
Patch7: ncl-5.0.0-atlas.patch
|
||||
# don't have the installation target depends on the build target since
|
||||
# for library it implies running ranlib and modifying the library timestamp
|
||||
@ -126,7 +124,6 @@ Example programs and data using NCL.
|
||||
%patch1 -p1 -b .deps
|
||||
%patch2 -p1 -b .ppc64
|
||||
%patch3 -p1 -b .libs
|
||||
%patch4 -p1 -b .xwd
|
||||
%patch7 -p1 -b .atlas
|
||||
%patch10 -p1 -b .no_install_dep
|
||||
%patch11 -p1 -b .build_n_scripts
|
||||
@ -342,6 +339,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 31 2012 Orion Poplawski <orion@cora.nwra.com> - 6.1.0-1
|
||||
- Update to 6.1.0
|
||||
- Drop xwd patch applied upstream
|
||||
|
||||
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user