- Fixup more paths in shipped ncl scripts (bug #505240)
This commit is contained in:
parent
46c6c87aba
commit
5a0606c9fa
@ -1,17 +1,3 @@
|
|||||||
diff -up ncl_ncarg-5.0.0/ni/src/examples/gsun/gsn_code.ncl.paths ncl_ncarg-5.0.0/ni/src/examples/gsun/gsn_code.ncl
|
|
||||||
--- ncl_ncarg-5.0.0/ni/src/examples/gsun/gsn_code.ncl.paths 2008-02-01 17:20:00.000000000 +0100
|
|
||||||
+++ ncl_ncarg-5.0.0/ni/src/examples/gsun/gsn_code.ncl 2008-02-01 17:20:58.000000000 +0100
|
|
||||||
@@ -1937,8 +1937,8 @@ begin
|
|
||||||
lines = new(30+natt,string) ; Roughly how many lines we need
|
|
||||||
nlines = 0
|
|
||||||
|
|
||||||
- write_lines("load " + q + "$NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_code.ncl" + q, lines, nlines)
|
|
||||||
- write_lines("load " + q + "$NCARG_ROOT/lib/ncarg/nclscripts/csm/gsn_csm.ncl" + q, lines, nlines)
|
|
||||||
+ write_lines("load " + q + "$NCARG_ROOT/share/ncarg/nclscripts/csm/gsn_code.ncl" + q, lines, nlines)
|
|
||||||
+ write_lines("load " + q + "$NCARG_ROOT/share/ncarg/nclscripts/csm/gsn_csm.ncl" + q, lines, nlines)
|
|
||||||
write_lines("", lines, nlines)
|
|
||||||
write_lines("begin", lines, nlines)
|
|
||||||
write_lines(";", lines, nlines)
|
|
||||||
diff -up ncl_ncarg-5.0.0/config/ymake.paths ncl_ncarg-5.0.0/config/ymake
|
diff -up ncl_ncarg-5.0.0/config/ymake.paths ncl_ncarg-5.0.0/config/ymake
|
||||||
--- ncl_ncarg-5.0.0/config/ymake.paths 2006-05-02 16:16:20.000000000 +0200
|
--- ncl_ncarg-5.0.0/config/ymake.paths 2006-05-02 16:16:20.000000000 +0200
|
||||||
+++ ncl_ncarg-5.0.0/config/ymake 2008-02-01 15:19:00.000000000 +0100
|
+++ ncl_ncarg-5.0.0/config/ymake 2008-02-01 15:19:00.000000000 +0100
|
16
ncl.spec
16
ncl.spec
@ -1,6 +1,6 @@
|
|||||||
Name: ncl
|
Name: ncl
|
||||||
Version: 5.1.0
|
Version: 5.1.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: NCAR Command Language and NCAR Graphics
|
Summary: NCAR Command Language and NCAR Graphics
|
||||||
|
|
||||||
Group: Applications/Engineering
|
Group: Applications/Engineering
|
||||||
@ -26,7 +26,7 @@ Source3: ncarg.sh
|
|||||||
#
|
#
|
||||||
# install paths are set up in Project. Paths used in code are also in
|
# install paths are set up in Project. Paths used in code are also in
|
||||||
# Project, in NGENV_DESCRIPT.
|
# Project, in NGENV_DESCRIPT.
|
||||||
Patch0: ncl-5.0.0-paths.patch
|
Patch0: ncl-5.1.0-paths.patch
|
||||||
Patch1: ncarg-4.4.1-deps.patch
|
Patch1: ncarg-4.4.1-deps.patch
|
||||||
Patch2: ncl-5.1.0-ppc64.patch
|
Patch2: ncl-5.1.0-ppc64.patch
|
||||||
Patch7: ncl-5.0.0-atlas.patch
|
Patch7: ncl-5.0.0-atlas.patch
|
||||||
@ -142,13 +142,10 @@ sed -e 's;@prefix@;%{_prefix};' \
|
|||||||
cp %{SOURCE2} %{SOURCE3} .
|
cp %{SOURCE2} %{SOURCE3} .
|
||||||
sed -i -e s,@LIB@,%{_lib},g ncarg.csh ncarg.sh
|
sed -i -e s,@LIB@,%{_lib},g ncarg.csh ncarg.sh
|
||||||
|
|
||||||
pushd ni/src/examples
|
sed -i -e 's;load "\$NCARG_ROOT/lib/ncarg/nclex\([^ ;]*\);loadscript(ncargpath("nclex") + "\1);' \
|
||||||
for file in */*.ncl; do
|
|
||||||
sed -i -e 's;load "\$NCARG_ROOT/lib/ncarg/nclex\([^ ;]*\);loadscript(ncargpath("nclex") + "\1);' \
|
|
||||||
-e 's;"\$NCARG_ROOT/lib/ncarg/\(data\|database\);ncargpath("\1") + ";' \
|
-e 's;"\$NCARG_ROOT/lib/ncarg/\(data\|database\);ncargpath("\1") + ";' \
|
||||||
$file
|
-e 's;\$NCARG_ROOT/lib/ncarg/nclscripts;$NCARG_ROOT/share/ncarg/nclscripts;' \
|
||||||
done
|
`find ni/src -name \*.ncl`
|
||||||
popd
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -301,6 +298,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 7 2009 - Orion Poplawski <orion@cora.nwra.com> - 5.1.0-4
|
||||||
|
- Fixup more paths in shipped ncl scripts (bug #505240)
|
||||||
|
|
||||||
* Tue May 26 2009 - Orion Poplawski <orion@cora.nwra.com> - 5.1.0-3
|
* Tue May 26 2009 - Orion Poplawski <orion@cora.nwra.com> - 5.1.0-3
|
||||||
- Move database back to main arch dependent package
|
- Move database back to main arch dependent package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user