nbdkit/0004-perl-Make-example4-and...

58 lines
1.5 KiB
Diff

From e25e1bf830cc0252ef3374a3a1d391142726cf75 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 11 Jun 2018 11:48:08 +0100
Subject: [PATCH 4/7] perl: Make example4 and tar plugins conditional on
--enable-perl.
If you configured with --disable-perl then these plugins are still
built and installed. However they cannot work without the Perl
plugin, thus it is right to disable them.
(cherry picked from commit a6aa7d50afa7a6a41865e9814428d3c1b8295167)
---
plugins/example4/Makefile.am | 4 ++++
plugins/tar/Makefile.am | 4 ++++
2 files changed, 8 insertions(+)
diff --git a/plugins/example4/Makefile.am b/plugins/example4/Makefile.am
index abbda92..374b483 100644
--- a/plugins/example4/Makefile.am
+++ b/plugins/example4/Makefile.am
@@ -39,6 +39,8 @@ CLEANFILES = *~
plugindir = $(libdir)/nbdkit/plugins
+if HAVE_PERL
+
plugin_SCRIPTS = nbdkit-example4-plugin
# We have to do the rewriting here to avoid stupid exec_prefix.
@@ -59,3 +61,5 @@ nbdkit-example4-plugin.1: $(source)
mv $@.t $@
endif
+
+endif
diff --git a/plugins/tar/Makefile.am b/plugins/tar/Makefile.am
index 57d1026..016ffef 100644
--- a/plugins/tar/Makefile.am
+++ b/plugins/tar/Makefile.am
@@ -39,6 +39,8 @@ CLEANFILES = *~
plugindir = $(libdir)/nbdkit/plugins
+if HAVE_PERL
+
plugin_SCRIPTS = nbdkit-tar-plugin
# We have to do the rewriting here to avoid stupid exec_prefix.
@@ -59,3 +61,5 @@ nbdkit-tar-plugin.1: $(source)
mv $@.t $@
endif
+
+endif
--
2.17.1