nbdkit/0001-tests-Use-a-more-robus...

32 lines
791 B
Diff

From 183d81fa792fd024f62d068ead9cad0cc53d3c8e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Tue, 12 Mar 2019 22:13:24 +0000
Subject: [PATCH] tests: Use a more robust method to create the test disk
atomically.
---
tests/Makefile.am | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1712565..f50a35e 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -334,9 +334,10 @@ check_DATA += disk
CLEANFILES += disk
disk:
- rm -f $@ test1.img
- guestfish -N fs:ext4:100M -m /dev/sda1 write /hello.txt "hello,world"
- mv test1.img disk
+ rm -f $@ $@-t
+ guestfish -N $@-t=fs:ext4:100M -m /dev/sda1 \
+ write /hello.txt "hello,world"
+ mv $@-t $@
endif HAVE_GUESTFISH
--
2.20.1