New upstream version 1.15.7.

This commit is contained in:
Richard W.M. Jones 2019-11-06 14:44:03 +00:00
parent 26e120b9d6
commit ecd14a1e8d
6 changed files with 5 additions and 215 deletions

View File

@ -1,39 +0,0 @@
From 740f6dee658ee6adb356d9600e2b51bb22dbce1e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 19 Oct 2019 18:31:24 +0100
Subject: [PATCH 1/4] tests/test-captive.sh: Increase sleep times.
Short sleeps in this test make the test very prone to failure on slow
or heavily loaded machines.
Fixes commit 38165d0f8f5a4eb898d756a561811c2fe042fe4d.
See also
https://www.redhat.com/archives/libguestfs/2019-October/msg00115.html
---
tests/test-captive.sh | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/test-captive.sh b/tests/test-captive.sh
index 88c0d81..8890073 100755
--- a/tests/test-captive.sh
+++ b/tests/test-captive.sh
@@ -72,13 +72,13 @@ fi
# Check that nbdkit death from unhandled signal affects exit status
status=0
nbdkit -U - -P captive.pid example1 --run '
-test ! -s captive.pid || sleep 1
+test ! -s captive.pid || sleep 5
if test ! -s captive.pid; then
echo "no pidfile yet"
exit 10
fi
kill -s ABRT $(cat captive.pid) || exit 10
-sleep 1
+sleep 5
' > captive.out || status=$?
if test $status != $(( 128 + $(kill -l ABRT) )); then
echo "$0: unexpected exit status $status"
--
2.23.0

View File

@ -1,48 +0,0 @@
From c472b47a55a331dcb5cc75def71cc665abbc06db Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 24 Oct 2019 14:36:54 +0100
Subject: [PATCH] vddk: Disable tests on non-x86 platforms.
Fixes commit a0184ba081164218ddd1928ed48a75fca93406bc.
---
tests/Makefile.am | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 558ea86..2db5e7b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -162,12 +162,14 @@ check-valgrind:
check-root:
$(MAKE) check TESTS="test-file-block"
+if HAVE_VDDK
# Run a basic check against a real copy of VDDK. You must set
# vddkdir to point to the library location, eg:
#
# make check-vddk vddkdir=vmware-vix-disklib-distrib
check-vddk:
$(MAKE) check TESTS=test-vddk-real.sh
+endif HAVE_VDDK
#----------------------------------------------------------------------
# Basic server command line and start-up tests.
@@ -713,6 +715,7 @@ test_streaming_SOURCES = test-streaming.c test.h
test_streaming_CFLAGS = $(WARNINGS_CFLAGS) $(LIBGUESTFS_CFLAGS)
test_streaming_LDADD = libtest.la $(LIBGUESTFS_LIBS)
+if HAVE_VDDK
# VDDK plugin test.
# This only tests that the plugin can be loaded against a
# dummy VDDK library, it is not a detailed test.
@@ -737,6 +740,7 @@ libvixDiskLib_la_CXXFLAGS = $(WARNINGS_CFLAGS)
libvixDiskLib_la_LDFLAGS = \
-shared -version-number 6:0:0 -rpath /nowhere \
$(NULL)
+endif HAVE_VDDK
# zero plugin test.
TESTS += test-zero.sh
--
2.23.0

View File

@ -1,25 +0,0 @@
From f4e7db5062dc59662ce05796f95f93017187f1d6 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 19 Oct 2019 18:52:47 +0100
Subject: [PATCH 2/4] tests/test-captive.sh: Remove useless sleep.
---
tests/test-captive.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/test-captive.sh b/tests/test-captive.sh
index 8890073..22a90ca 100755
--- a/tests/test-captive.sh
+++ b/tests/test-captive.sh
@@ -44,7 +44,7 @@ rm -f $files
cleanup_fn rm -f $files
nbdkit -U $sock example1 --run '
- sleep 1; echo nbd=$nbd; echo port=$port; echo socket=$unixsocket
+ echo nbd=$nbd; echo port=$port; echo socket=$unixsocket
' > captive.out
# Check the output.
--
2.23.0

View File

@ -1,59 +0,0 @@
From b6cbb0edc94772ce063bc4a64d1940519fd87fa2 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 19 Oct 2019 19:11:22 +0100
Subject: [PATCH 3/4] tests/test-socket-activation.c: Don't check nbdkit exit
status.
In this test we run nbdkit as a subprocess of the test. The test
checked the exit status of nbdkit. However nbdkit can segfault on
shutdown because we are setting MALLOC_PERTURB_.
We need to fix nbdkit's shutdown path eventually, but for this test it
is not relevant so ignore the exit status.
This makes the test more stable.
---
tests/test-socket-activation.c | 25 +------------------------
1 file changed, 1 insertion(+), 24 deletions(-)
diff --git a/tests/test-socket-activation.c b/tests/test-socket-activation.c
index 2141d6d..ec91114 100644
--- a/tests/test-socket-activation.c
+++ b/tests/test-socket-activation.c
@@ -86,32 +86,9 @@ static pid_t pid = 0;
static void
cleanup (void)
{
- int status;
-
- if (pid > 0) {
+ if (pid > 0)
kill (pid, SIGTERM);
- /* Check the status of nbdkit is normal on exit. */
- if (waitpid (pid, &status, 0) == -1) {
- perror ("waitpid");
- _exit (EXIT_FAILURE);
- }
- if (WIFEXITED (status) && WEXITSTATUS (status) != 0) {
- _exit (WEXITSTATUS (status));
- }
- if (WIFSIGNALED (status)) {
- /* Note that nbdkit is supposed to catch the signal we send and
- * exit cleanly, so the following shouldn't happen.
- */
- fprintf (stderr, "nbdkit terminated by signal %d\n", WTERMSIG (status));
- _exit (EXIT_FAILURE);
- }
- if (WIFSTOPPED (status)) {
- fprintf (stderr, "nbdkit stopped by signal %d\n", WSTOPSIG (status));
- _exit (EXIT_FAILURE);
- }
- }
-
unlink (pidpath);
unlink (sockpath);
rmdir (tmpdir);
--
2.23.0

View File

@ -1,39 +0,0 @@
From 57ae3c6098c35256ab1e3679f77ed28b5aad982a Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 19 Oct 2019 19:42:40 +0100
Subject: [PATCH 4/4] tests/test-captive.sh: Better test for pidfile.
This test was still unstable on slower machines. Improve the test for
the pidfile to make it more stable.
Fixes commit 740f6dee658ee6adb356d9600e2b51bb22dbce1e
and commit 38165d0f8f5a4eb898d756a561811c2fe042fe4d.
---
tests/test-captive.sh | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)
diff --git a/tests/test-captive.sh b/tests/test-captive.sh
index 22a90ca..82697a5 100755
--- a/tests/test-captive.sh
+++ b/tests/test-captive.sh
@@ -72,10 +72,13 @@ fi
# Check that nbdkit death from unhandled signal affects exit status
status=0
nbdkit -U - -P captive.pid example1 --run '
-test ! -s captive.pid || sleep 5
-if test ! -s captive.pid; then
- echo "no pidfile yet"
- exit 10
+for i in {1..60}; do
+ if test -s captive.pid; then break; fi
+ sleep 1
+done
+if ! test -s captive.pid; then
+ echo "$0: no pidfile yet"
+ exit 10
fi
kill -s ABRT $(cat captive.pid) || exit 10
sleep 5
--
2.23.0

View File

@ -21,13 +21,13 @@
%global verify_tarball_signature 1
# If there are patches which touch autotools files, set this to 1.
%global patches_touch_autotools 1
%global patches_touch_autotools %{nil}
# The source directory.
%global source_directory 1.15-development
Name: nbdkit
Version: 1.15.6
Version: 1.15.7
Release: 1%{?dist}
Summary: NBD server
@ -41,9 +41,6 @@ Source1: http://libguestfs.org/download/nbdkit/%{source_directory}/%{name
Source2: libguestfs.keyring
%endif
# Upstream in > 1.15.6.
Patch1: 0001-vddk-Disable-tests-on-non-x86-platforms.patch
%if 0%{patches_touch_autotools}
BuildRequires: autoconf, automake, libtool
%endif
@ -905,6 +902,9 @@ make %{?_smp_mflags} check || {
%changelog
* Wed Nov 06 2019 Richard W.M. Jones <rjones@redhat.com> - 1.15.7-1
- New upstream version 1.15.7.
* Fri Oct 24 2019 Richard W.M. Jones <rjones@redhat.com> - 1.15.6-1
- New upstream version 1.15.6.