New stable version 1.2.4.
Remove upstream patches.
This commit is contained in:
parent
ee3fd0e5ef
commit
cd71d8d33a
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
/clog
|
||||
/nbdkit-*.tar.gz
|
||||
/nbdkit-1.2.4.tar.gz.sig
|
||||
|
@ -1,57 +0,0 @@
|
||||
From 974f6aba15d71984b5f05dc8b5f10bb7a5cec082 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 6 Jun 2018 19:29:35 +0100
|
||||
Subject: [PATCH 1/2] tests: Provide full path to Unix domain sockets.
|
||||
|
||||
See also this thread:
|
||||
https://www.redhat.com/archives/libvir-list/2018-June/msg00490.html
|
||||
---
|
||||
tests/test-cache.sh | 3 ++-
|
||||
tests/test-cow.sh | 3 ++-
|
||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/tests/test-cache.sh b/tests/test-cache.sh
|
||||
index e5e9e82..c46e7be 100755
|
||||
--- a/tests/test-cache.sh
|
||||
+++ b/tests/test-cache.sh
|
||||
@@ -32,6 +32,7 @@
|
||||
# SUCH DAMAGE.
|
||||
|
||||
set -e
|
||||
+set -x
|
||||
|
||||
files="cache.img cache.sock cache.pid"
|
||||
rm -f $files
|
||||
@@ -69,7 +70,7 @@ cleanup ()
|
||||
trap cleanup INT QUIT TERM EXIT ERR
|
||||
|
||||
# Open the overlay and perform some operations.
|
||||
-guestfish --format=raw -a 'nbd://?socket=cache.sock' <<'EOF'
|
||||
+guestfish --format=raw -a "nbd://?socket=$PWD/cache.sock" <<'EOF'
|
||||
run
|
||||
part-disk /dev/sda gpt
|
||||
mkfs ext4 /dev/sda1
|
||||
diff --git a/tests/test-cow.sh b/tests/test-cow.sh
|
||||
index 443ba38..01d2d04 100755
|
||||
--- a/tests/test-cow.sh
|
||||
+++ b/tests/test-cow.sh
|
||||
@@ -32,6 +32,7 @@
|
||||
# SUCH DAMAGE.
|
||||
|
||||
set -e
|
||||
+set -x
|
||||
|
||||
files="cow-base.img cow-diff.qcow2 cow.sock cow.pid"
|
||||
rm -f $files
|
||||
@@ -70,7 +71,7 @@ cleanup ()
|
||||
trap cleanup INT QUIT TERM EXIT ERR
|
||||
|
||||
# Write some data into the overlay.
|
||||
-guestfish --format=raw -a 'nbd://?socket=cow.sock' -m /dev/sda1 <<EOF
|
||||
+guestfish --format=raw -a "nbd://?socket=$PWD/cow.sock" -m /dev/sda1 <<EOF
|
||||
fill-dir / 10000
|
||||
fill-pattern "abcde" 5M /large
|
||||
write /hello "hello, world"
|
||||
--
|
||||
2.16.2
|
||||
|
@ -1,52 +0,0 @@
|
||||
From 013a3a96a102d1b1481a08b6d37bdf958d123985 Mon Sep 17 00:00:00 2001
|
||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||
Date: Wed, 6 Jun 2018 20:06:39 +0100
|
||||
Subject: [PATCH 2/2] tests: xz: Use 16M block size when preparing disk for xz
|
||||
plugin test.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
In a recent commit guestfish changed the default size for disk images
|
||||
prepared using the -N parameter from 100M to 1G:
|
||||
|
||||
https://github.com/libguestfs/libguestfs/commit/adc23829e4b128562c2c29d984654528bd259644
|
||||
|
||||
For the xz plugin test we prepared a disk image using guestfish and
|
||||
then xz-compressing the output, but we did not take our own advice and
|
||||
use the --block-size parameter to limit the xz block size. Because of
|
||||
the increased size of the disk as a whole, this pushed the block size
|
||||
beyond the limit that the xz plugin can handle, and the test would
|
||||
fail with:
|
||||
|
||||
nbdkit: error: /var/tmp/nbdkit-1.3.1/tests/disk.xz: xz file largest block is bigger than maxblock
|
||||
Either recompress the xz file with smaller blocks (see nbdkit-xz-plugin(1))
|
||||
or make maxblock parameter bigger.
|
||||
maxblock = 536870912 (bytes)
|
||||
largest block in xz file = 1073741824 (bytes)
|
||||
|
||||
Simple fix by adding the --block-size parameter.
|
||||
|
||||
Note that to see the effect of this change you will need to ‘make
|
||||
maintainer-clean’ or remove the files ‘tests/disk’ and ‘tests/disk.xz’
|
||||
by hand.
|
||||
---
|
||||
tests/Makefile.am | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
||||
index 4582120..0cc2618 100644
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -328,7 +328,7 @@ test_xz_LDADD = libtest.la $(LIBGUESTFS_LIBS)
|
||||
|
||||
disk.xz: disk
|
||||
rm -f $@
|
||||
- xz --best -c disk > $@
|
||||
+ xz --best --block-size=16777216 -c disk > $@
|
||||
|
||||
endif HAVE_GUESTFISH
|
||||
endif HAVE_LIBLZMA
|
||||
--
|
||||
2.16.2
|
||||
|
14
nbdkit.spec
14
nbdkit.spec
@ -17,7 +17,7 @@
|
||||
%endif
|
||||
|
||||
Name: nbdkit
|
||||
Version: 1.2.3
|
||||
Version: 1.2.4
|
||||
Release: 1%{?dist}
|
||||
Summary: NBD server
|
||||
|
||||
@ -26,12 +26,6 @@ URL: https://github.com/libguestfs/nbdkit
|
||||
|
||||
Source0: http://libguestfs.org/download/nbdkit/%{name}-%{version}.tar.gz
|
||||
|
||||
# Upstream patches to fix the tests.
|
||||
Patch1: 0001-tests-Provide-full-path-to-Unix-domain-sockets.patch
|
||||
Patch2: 0002-tests-xz-Use-16M-block-size-when-preparing-disk-for-.patch
|
||||
# Temporarily because patch2 touches Makefile.am.
|
||||
BuildRequires: autoconf, automake, libtool
|
||||
|
||||
%if 0%{?rhel} == 7
|
||||
# On RHEL 7, nothing in the virt stack is shipped on aarch64 and
|
||||
# libguestfs was not shipped on POWER (fixed in 7.5). We could in
|
||||
@ -372,8 +366,6 @@ plugins for %{name}.
|
||||
%prep
|
||||
%setup -q
|
||||
%autopatch -p1
|
||||
# Temporarily because patch2 touches Makefile.am.
|
||||
autoreconf -i
|
||||
|
||||
%ifnarch %{complete_test_arches}
|
||||
# Simplify the test suite so it doesn't require qemu.
|
||||
@ -626,6 +618,10 @@ popd
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jun 9 2018 Richard W.M. Jones <rjones@redhat.com> - 1.2.4-1
|
||||
- New stable version 1.2.4.
|
||||
- Remove upstream patches.
|
||||
|
||||
* Wed Jun 6 2018 Richard W.M. Jones <rjones@redhat.com> - 1.2.3-1
|
||||
- New stable version 1.2.3.
|
||||
- Add patch to work around libvirt problem with relative socket paths.
|
||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
SHA512 (nbdkit-1.2.3.tar.gz) = e11c04b02e971d06f82cbbb13381b5b917acb5d55117508bf9d1945189190bbf875599cfc98f08eae767ced127a883bba84f8a1bebb6d79699ca486e02cb93ce
|
||||
SHA512 (nbdkit-1.2.4.tar.gz) = 5f5f74e9223ed05cb0e9f36f7adea6980192bd23e3b900aaf1d045f135855e8fbbb7ff33df88a87a5b857d26635a4924b13c263cfac28b6206e26802731cab81
|
||||
SHA512 (nbdkit-1.2.4.tar.gz.sig) = bfe4d8fb913a08228ebaa44ca5966ef37f4919dff9b6049a5eeada78984745d80eafeac9751f5f0784d75c62e4d8a03eeddf803fcac3406542fea50c4d59048f
|
||||
|
Loading…
Reference in New Issue
Block a user