New upstream version 1.13.6.

This commit is contained in:
Richard W.M. Jones 2019-07-26 10:18:03 +01:00
parent 952b7ceb57
commit 87fad0e071
3 changed files with 8 additions and 56 deletions

View File

@ -1,49 +0,0 @@
From 4840b5e8293287af45f1e6062e5272a9b2ee0535 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 10 Jun 2019 09:34:59 +0100
Subject: [PATCH] python: Further fix for Python 3.8 embedding.
Further attempt to fix Python 3.8; see also
commit fb1a74b3d84571bc4c6bb57b26128c92b3368c52
and https://bugzilla.redhat.com/show_bug.cgi?id=1718294
---
configure.ac | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/configure.ac b/configure.ac
index 3489ae1..24d986f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -474,18 +474,12 @@ AS_IF([test "x$PYTHON" != "xno" && test "x$enable_python" != "xno"],[
])
dnl Check for Python CFLAGS, libraries.
- dnl For Python >= 3.8 we have to use python-embed.pc, see:
+ dnl For Python >= 3.8 we have to use python-<VERSION>-embed.pc, see:
dnl https://docs.python.org/3.8/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
dnl The python.pc is called python-<VERSION>.pc on Debian and
dnl later versions of Fedora, and python.pc on older versions
dnl of Fedora.
- PKG_CHECK_MODULES([PYTHON], [python-embed-"$PYTHON_VERSION"], [
- AC_SUBST([PYTHON_CFLAGS])
- AC_SUBST([PYTHON_LIBS])
- AC_SUBST([PYTHON_VERSION])
- AC_DEFINE([HAVE_PYTHON],[1],[Python library found at compile time])
- ],[
- PKG_CHECK_MODULES([PYTHON], [python-embed], [
+ PKG_CHECK_MODULES([PYTHON], [python-"$PYTHON_VERSION"-embed], [
AC_SUBST([PYTHON_CFLAGS])
AC_SUBST([PYTHON_LIBS])
AC_SUBST([PYTHON_VERSION])
@@ -505,7 +499,7 @@ AS_IF([test "x$PYTHON" != "xno" && test "x$enable_python" != "xno"],[
],[
AC_MSG_WARN([python $PYTHON_VERSION not found])
enable_python=no
- ])])])])
+ ])])])
dnl Check for various functions needed by the bindings.
old_LIBS="$LIBS"
--
2.22.0

View File

@ -21,14 +21,14 @@
%global verify_tarball_signature 1
# If there are patches which touch autotools files, set this to 1.
%global patches_touch_autotools 1
%global patches_touch_autotools %{nil}
# The source directory.
%global source_directory 1.13-development
Name: nbdkit
Version: 1.13.5
Release: 3%{?dist}
Version: 1.13.6
Release: 1%{?dist}
Summary: NBD server
License: BSD
@ -41,8 +41,6 @@ Source1: http://libguestfs.org/download/nbdkit/%{source_directory}/%{name
Source2: libguestfs.keyring
%endif
Patch1: 0001-python-Further-fix-for-Python-3.8-embedding.patch
%if 0%{patches_touch_autotools}
BuildRequires: autoconf, automake, libtool
%endif
@ -836,6 +834,9 @@ make %{?_smp_mflags} check || {
%changelog
* Fri Jul 26 2019 Richard W.M. Jones <rjones@redhat.com> - 1.13.6-1
- New upstream version 1.13.6.
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.13.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

View File

@ -1,2 +1,2 @@
SHA512 (nbdkit-1.13.5.tar.gz) = 0fd5b492f1a14de32fde091e9ce53cd733ae862ffc3bfd9abf50132a12f89422f244839d9e6d41e296cbf3f06dcd354d92f18cc043caea7337bca877787955ff
SHA512 (nbdkit-1.13.5.tar.gz.sig) = 70ffa7c620a4866ae03f7cf51ab92f66f7bd26b04e83217a3392bfe319d26f153aa919189c58aee3c19f2c016a09c50233cb5322248461ce7016a2139f41d39c
SHA512 (nbdkit-1.13.6.tar.gz) = 1b3d420e96aaf25584b12b0bdc33fb5b46685e9a9dba66e5aea70d1efa1a0fb6de21799c903114091308bb15f406170b50b93f54616c0a6604e035f15433de70
SHA512 (nbdkit-1.13.6.tar.gz.sig) = 892fe22a69dfd38730c4fa65d0ee353ec06bac30713db2c76c023e97b60a7d70dc7857c2e065407cccd810cd67ffe84f283323db2c56f108e7249f29631f95ff