Remove patches which are now upstream.

Fixes commit 442c62b8e5.
This commit is contained in:
Richard W.M. Jones 2018-07-06 12:49:40 +01:00
parent 7c4f31f5c3
commit 31886771ce
7 changed files with 0 additions and 285 deletions

View File

@ -1,56 +0,0 @@
From 9dc5dba35b3af9eaa98f97d8eb83a39435574230 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 9 Jun 2018 14:56:13 +0100
Subject: [PATCH 1/7] =?UTF-8?q?tests:=20If=20guestfish=20isn't=20available?=
=?UTF-8?q?,=20=E2=80=98disk=E2=80=99=20is=20not=20created=20so=20disable?=
=?UTF-8?q?=20tests=20which=20need=20it.?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Fixes commit 02f27adc50ed5b83021df4edc84f4dbf8b03a0e3.
(cherry picked from commit 07ecff1613b73f32b5954bd3a3d46bef6a39e396)
---
tests/Makefile.am | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ff51120..53b2d8a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -251,6 +251,7 @@ test_file_LDADD = libtest.la $(LIBGUESTFS_LIBS)
# gzip plugin test.
if HAVE_ZLIB
+if HAVE_GUESTFISH
LIBGUESTFS_TESTS += test-gzip
check_DATA += disk.gz
@@ -264,6 +265,7 @@ disk.gz: disk
rm -f $@
gzip -9 -c disk > $@
+endif HAVE_GUESTFISH
endif HAVE_ZLIB
# memory plugin test.
@@ -319,6 +321,7 @@ test_streaming_LDADD = libtest.la $(LIBGUESTFS_LIBS)
# xz plugin test.
if HAVE_LIBLZMA
+if HAVE_GUESTFISH
LIBGUESTFS_TESTS += test-xz
check_DATA += disk.xz
@@ -332,6 +335,7 @@ disk.xz: disk
rm -f $@
xz --best --block-size=16777216 -c disk > $@
+endif HAVE_GUESTFISH
endif HAVE_LIBLZMA
#----------------------------------------------------------------------
--
2.17.1

View File

@ -1,32 +0,0 @@
From 69b77654bd1244c187c5cbdecc362be1d4f587a5 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 9 Jun 2018 18:29:43 +0100
Subject: [PATCH 2/7] docs: Fix separators in list of plugins (. -> ,)
(cherry picked from commit 4c4ebb955e9504503f2b950344529fa1a4222715)
---
docs/nbdkit.pod | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/docs/nbdkit.pod b/docs/nbdkit.pod
index 1a0c005..2802b73 100644
--- a/docs/nbdkit.pod
+++ b/docs/nbdkit.pod
@@ -925,10 +925,10 @@ L<nbdkit-libvirt-plugin(1)>,
L<nbdkit-memory-plugin(1)>,
L<nbdkit-nbd-plugin(1)>,
L<nbdkit-null-plugin(1)>,
-L<nbdkit-split-plugin(1)>.
-L<nbdkit-streaming-plugin(1)>.
-L<nbdkit-tar-plugin(1)>.
-L<nbdkit-vddk-plugin(1)>.
+L<nbdkit-split-plugin(1)>,
+L<nbdkit-streaming-plugin(1)>,
+L<nbdkit-tar-plugin(1)>,
+L<nbdkit-vddk-plugin(1)>,
L<nbdkit-xz-plugin(1)>.
Filters:
--
2.17.1

View File

@ -1,49 +0,0 @@
From 5558eb0633a48325970baa647b9e8f4ac9eb4520 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 10 Jun 2018 20:33:12 +0100
Subject: [PATCH 3/7] docs: Suggest using PKG_CHECK_VAR to substitute plugindir
and filterdir.
(cherry picked from commit fcd05424c819e433543030373a7f4136b511ddc6)
---
docs/nbdkit-filter.pod | 6 ++++++
docs/nbdkit-plugin.pod | 6 ++++++
2 files changed, 12 insertions(+)
diff --git a/docs/nbdkit-filter.pod b/docs/nbdkit-filter.pod
index 7105a1d..2e23a8e 100644
--- a/docs/nbdkit-filter.pod
+++ b/docs/nbdkit-filter.pod
@@ -463,6 +463,12 @@ You can also run pkg-config/pkgconf directly, for example:
exit 1
fi
+You can also substitute the filterdir variable by doing:
+
+ PKG_CHECK_VAR([NBDKIT_FILTERDIR], [nbdkit], [filterdir])
+
+which defines C<$(NBDKIT_FILTERDIR)> in automake-generated Makefiles.
+
=head1 SEE ALSO
L<nbdkit(1)>,
diff --git a/docs/nbdkit-plugin.pod b/docs/nbdkit-plugin.pod
index 695e588..a393be9 100644
--- a/docs/nbdkit-plugin.pod
+++ b/docs/nbdkit-plugin.pod
@@ -668,6 +668,12 @@ You can also run pkg-config/pkgconf directly, for example:
exit 1
fi
+You can also substitute the plugindir variable by doing:
+
+ PKG_CHECK_VAR([NBDKIT_PLUGINDIR], [nbdkit], [plugindir])
+
+which defines C<$(NBDKIT_PLUGINDIR)> in automake-generated Makefiles.
+
=head1 WRITING PLUGINS IN OTHER PROGRAMMING LANGUAGES
You can also write nbdkit plugins in OCaml, Perl, Python or Ruby.
--
2.17.1

View File

@ -1,57 +0,0 @@
From e25e1bf830cc0252ef3374a3a1d391142726cf75 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Mon, 11 Jun 2018 11:48:08 +0100
Subject: [PATCH 4/7] perl: Make example4 and tar plugins conditional on
--enable-perl.
If you configured with --disable-perl then these plugins are still
built and installed. However they cannot work without the Perl
plugin, thus it is right to disable them.
(cherry picked from commit a6aa7d50afa7a6a41865e9814428d3c1b8295167)
---
plugins/example4/Makefile.am | 4 ++++
plugins/tar/Makefile.am | 4 ++++
2 files changed, 8 insertions(+)
diff --git a/plugins/example4/Makefile.am b/plugins/example4/Makefile.am
index abbda92..374b483 100644
--- a/plugins/example4/Makefile.am
+++ b/plugins/example4/Makefile.am
@@ -39,6 +39,8 @@ CLEANFILES = *~
plugindir = $(libdir)/nbdkit/plugins
+if HAVE_PERL
+
plugin_SCRIPTS = nbdkit-example4-plugin
# We have to do the rewriting here to avoid stupid exec_prefix.
@@ -59,3 +61,5 @@ nbdkit-example4-plugin.1: $(source)
mv $@.t $@
endif
+
+endif
diff --git a/plugins/tar/Makefile.am b/plugins/tar/Makefile.am
index 57d1026..016ffef 100644
--- a/plugins/tar/Makefile.am
+++ b/plugins/tar/Makefile.am
@@ -39,6 +39,8 @@ CLEANFILES = *~
plugindir = $(libdir)/nbdkit/plugins
+if HAVE_PERL
+
plugin_SCRIPTS = nbdkit-tar-plugin
# We have to do the rewriting here to avoid stupid exec_prefix.
@@ -59,3 +61,5 @@ nbdkit-tar-plugin.1: $(source)
mv $@.t $@
endif
+
+endif
--
2.17.1

View File

@ -1,35 +0,0 @@
From 8f56ed3f954de2377536bc79fb751db19537b0af Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 14 Jun 2018 14:18:34 +0100
Subject: [PATCH 5/7] plugins: nbd: Free h (handle) along error paths.
Found by Coverity.
(cherry picked from commit aa61206225e9594e348c3cfd9e1210ae614e87db)
---
plugins/nbd/nbd.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/plugins/nbd/nbd.c b/plugins/nbd/nbd.c
index 1695d9a..d50671a 100644
--- a/plugins/nbd/nbd.c
+++ b/plugins/nbd/nbd.c
@@ -463,6 +463,7 @@ nbd_open (int readonly)
h->fd = socket (AF_UNIX, SOCK_STREAM, 0);
if (h->fd < 0) {
nbdkit_error ("socket: %m");
+ free (h);
return NULL;
}
/* We already validated length during nbd_config_complete */
@@ -557,6 +558,7 @@ nbd_open (int readonly)
err:
close (h->fd);
+ free (h);
return NULL;
}
--
2.17.1

View File

@ -1,28 +0,0 @@
From 5ae135e6e98f55140ae078c3dee43376fe0673d1 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Thu, 14 Jun 2018 14:25:35 +0100
Subject: [PATCH 6/7] crypto: Fix error path when sending to gnutls socket.
Found by Coverity.
(cherry picked from commit 92f637817a7838337ba99e72e6d8e5543694e360)
---
src/crypto.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/crypto.c b/src/crypto.c
index 17a667b..23c5c8f 100644
--- a/src/crypto.c
+++ b/src/crypto.c
@@ -294,7 +294,7 @@ crypto_send (struct connection *conn, const void *vbuf, size_t len)
while (len > 0) {
r = gnutls_record_send (*session, buf, len);
- if (r == -1) {
+ if (r < 0) {
if (r == GNUTLS_E_INTERRUPTED || r == GNUTLS_E_AGAIN)
continue;
return -1;
--
2.17.1

View File

@ -1,28 +0,0 @@
From 9a628abe3df087f7fa68dfb89bc9a325d27c3f5e Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sun, 1 Jul 2018 15:47:56 +0100
Subject: [PATCH 7/7] src/main: Add missing break affecting '-t/--threads'
parameter.
Fixes commit e9516a147ace4e302d7eec0a2a81ddad1c5bfb00.
(cherry picked from commit d530742708086854cc18dc7bf2b58a1a10af17f7)
---
src/main.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/main.c b/src/main.c
index e5d9093..a878bd5 100644
--- a/src/main.c
+++ b/src/main.c
@@ -380,6 +380,7 @@ main (int argc, char *argv[])
}
/* XXX Worth a maximimum limit on threads? */
}
+ break;
case 'U':
if (socket_activation) {
--
2.17.1