Version 2.7.3.

This commit is contained in:
Jerry James 2021-09-06 07:30:20 -06:00
parent 3d854bd1f0
commit 95cc18a895
7 changed files with 53 additions and 33 deletions

View File

@ -6,13 +6,13 @@ Last-Update: 2017-11-24
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,22 @@
@@ -1,6 +1,22 @@
# Process this file with autoconf to produce a configure script.
-AC_INIT(nauty-h.in)
-AC_INIT
+AC_INIT([nauty],[@INJECTVER@],[bdm@cs.anu.edu.au],[nauty],[http://pallini.di.uniroma1.it/])
AC_CONFIG_SRCDIR([nauty-h.in])
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_AUX_DIR([autotool])
+AC_CONFIG_SRCDIR([dreadnaut.c])
+AC_CONFIG_HEADER([nauty/nauty_config.h])
+AM_INIT_AUTOMAKE([foreign])
+AM_MAINTAINER_MODE
@ -30,7 +30,7 @@ Last-Update: 2017-11-24
# ======================================================================
# First we define some functions
@@ -119,30 +136,37 @@
@@ -120,30 +136,37 @@
is_cygwin=0 ;;
esac
@ -85,12 +85,13 @@ Last-Update: 2017-11-24
case "$CC" in
gcc*)
@@ -461,5 +485,26 @@
@@ -451,7 +474,26 @@
AC_PROG_MKDIR_P
AC_PROG_INSTALL
-AC_OUTPUT(makefile:makefile.in nauty.h:nauty-h.in
- naututil.h:naututil-h.in gtools.h:gtools-h.in)
-AC_CONFIG_FILES([makefile:makefile.in nauty.h:nauty-h.in
- naututil.h:naututil-h.in gtools.h:gtools-h.in
- nauty.pc:nauty.pc.in])
+dnl Checks for linker script support
+gl_LD_VERSION_SCRIPT
+
@ -113,10 +114,10 @@ Last-Update: 2017-11-24
+ gtools.h:gtools-h.in
+ ])
+
+AC_OUTPUT
AC_OUTPUT
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,519 @@
@@ -0,0 +1,525 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
@ -173,6 +174,7 @@ Last-Update: 2017-11-24
+ linegraphg \
+ listg \
+ multig \
+ nbrhoodg \
+ newedgeg \
+ NRswitchg \
+ pickg \
@ -222,6 +224,7 @@ Last-Update: 2017-11-24
+ linegraphg.1 \
+ listg.1 \
+ multig.1 \
+ nbrhoodg.1 \
+ newedgeg.1 \
+ NRswitchg.1 \
+ pickg.1 \
@ -335,6 +338,7 @@ Last-Update: 2017-11-24
+labelg_DESCRIPTION = "canonically label graphs"
+linegraphg_DESCRIPTION = "compute the linegraphs of a file of graphs"
+listg_DESCRIPTION = "display graphs in a variety of forms"
+nbrhoodg_DESCRIPTION = "extract neighbourhoods of vertices"
+multig_DESCRIPTION = "generate small multigraphs with given underlying graph"
+newedgeg_DESCRIPTION = "create new edges from pairs of non-adjacent edges in each possible way"
+NRswitchg_DESCRIPTION = "complement vertex edges"
@ -382,6 +386,7 @@ Last-Update: 2017-11-24
+linegraphg_CPPFLAGS =
+listg_CPPFLAGS =
+multig_CPPFLAGS =
+nbrhoodg_CPPFLAGS =
+newedgeg_CPPFLAGS =
+NRswitchg_CPPFLAGS =
+pickg_CPPFLAGS =
@ -428,6 +433,7 @@ Last-Update: 2017-11-24
+linegraphg_SOURCES = linegraphg.c
+listg_SOURCES = listg.c
+multig_SOURCES = multig.c
+nbrhoodg_SOURCES = nbrhoodg.c
+newedgeg_SOURCES = newedgeg.c
+NRswitchg_SOURCES = NRswitchg.c
+pickg_SOURCES = testg.c
@ -474,6 +480,7 @@ Last-Update: 2017-11-24
+linegraphg_LDADD = $(NAUTY_LDADD)
+listg_LDADD = $(NAUTY_LDADD)
+multig_LDADD = $(NAUTY_LDADD)
+nbrhoodg_LDADD = $(NAUTY_LDADD)
+newedgeg_LDADD = $(NAUTY_LDADD)
+NRswitchg_LDADD = $(NAUTY_LDADD)
+pickg_LDADD = $(NAUTY_LDADD)
@ -1199,7 +1206,7 @@ Last-Update: 2017-11-24
+])
--- a/gtools-h.in
+++ b/gtools-h.in
@@ -60,8 +60,8 @@
@@ -58,8 +58,8 @@
This twisted expression works up to n=160529 in 32-bit arithmetic
and for larger n if size_t has 64 bits. */
@ -1338,20 +1345,18 @@ Last-Update: 2017-11-24
+distclean-local: remove-links
+ -rm -f Makefile
+
--- /dev/null
--- a/nauty.pc.in
+++ b/nauty.pc.in
@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+Name: nauty
+Description: nauty graph automorphism library
+Version: @PACKAGE_VERSION@
@@ -6,6 +6,7 @@
Name: nauty
Description: Programs and library for graph isomorphism
Version: 27r3
-Libs: -L${libdir} LIBS
-Libs.private:
-Cflags: -I${includedir} CFLGS
+URL: @PACKAGE_URL@
+Libs: -L${libdir} -l@PACKAGE@
+Libs.private: @threadlib@
+Libs.private: -lpthread
+Cflags: -I${includedir}
--- /dev/null
+++ b/m4/zlib.m4

View File

@ -15,7 +15,7 @@ Last-Update: 2017-11-24
--- a/gtools-h.in
+++ b/gtools-h.in
@@ -296,6 +296,7 @@
@@ -294,6 +294,7 @@
extern TLS_ATTR char *readg_line;
extern TLS_ATTR size_t ogf_linelen;
extern TLS_ATTR boolean is_pipe;

View File

@ -101,7 +101,7 @@ Last-Update: 2021-09-02
dnl --disable-clz disallows clz instructions, otherwise they are tested for
AC_ARG_ENABLE([clz],
@@ -319,7 +322,7 @@ have_popcntll=0
@@ -318,7 +321,7 @@ have_popcntll=0
have_mmpop32=0
have_mmpop64=0
@ -110,7 +110,7 @@ Last-Update: 2021-09-02
[AS_IF([test "$CC" = "icc"],
[AC_MSG_CHECKING(if _mm_popcnt_u32() is supported)
AC_LINK_IFELSE([AC_LANG_SOURCE([#include <nmmintrin.h>
@@ -353,6 +356,7 @@ AC_SUBST(have_popcntl)
@@ -352,6 +355,7 @@ AC_SUBST(have_popcntl)
AC_SUBST(have_popcntll)
AC_SUBST(have_mmpop32)
AC_SUBST(have_mmpop64)

View File

@ -5,7 +5,7 @@ Last-Update: 2017-11-24
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,100 +25,100 @@
@@ -25,102 +25,102 @@
bin_PROGRAMS = \
dreadnaut \
\
@ -38,6 +38,7 @@ Last-Update: 2017-11-24
- linegraphg \
- listg \
- multig \
- nbrhoodg \
- newedgeg \
- NRswitchg \
- pickg \
@ -79,6 +80,7 @@ Last-Update: 2017-11-24
+ nauty-linegraphg \
+ nauty-listg \
+ nauty-multig \
+ nauty-nbrhoodg \
+ nauty-newedgeg \
+ nauty-NRswitchg \
+ nauty-pickg \
@ -131,6 +133,7 @@ Last-Update: 2017-11-24
- linegraphg.1 \
- listg.1 \
- multig.1 \
- nbrhoodg.1 \
- newedgeg.1 \
- NRswitchg.1 \
- pickg.1 \
@ -172,6 +175,7 @@ Last-Update: 2017-11-24
+ nauty-linegraphg.1 \
+ nauty-listg.1 \
+ nauty-multig.1 \
+ nauty-nbrhoodg.1 \
+ nauty-newedgeg.1 \
+ nauty-NRswitchg.1 \
+ nauty-pickg.1 \
@ -194,7 +198,7 @@ Last-Update: 2017-11-24
lib_LTLIBRARIES = \
libnauty.la \
@@ -166,8 +166,8 @@
@@ -168,8 +168,8 @@
LD_LIBRARY_PATH=$(top_builddir)/.libs $(HELP2MAN) \
-s 1 \
$(AM_H2MFLAGS) \
@ -205,7 +209,7 @@ Last-Update: 2017-11-24
-o $@ \
$(top_builddir)/$<
@@ -187,189 +187,189 @@
@@ -189,193 +189,193 @@
## short descriptions inspired from the basic functions of the programs as described
## in section `Utilities' (15) of the `Nauty and Traces User's Guide' (version 2.6)
@ -238,6 +242,7 @@ Last-Update: 2017-11-24
-labelg_DESCRIPTION = "canonically label graphs"
-linegraphg_DESCRIPTION = "compute the linegraphs of a file of graphs"
-listg_DESCRIPTION = "display graphs in a variety of forms"
-nbrhoodg_DESCRIPTION = "extract neighbourhoods of vertices"
-multig_DESCRIPTION = "generate small multigraphs with given underlying graph"
-newedgeg_DESCRIPTION = "create new edges from pairs of non-adjacent edges in each possible way"
-NRswitchg_DESCRIPTION = "complement vertex edges"
@ -283,6 +288,7 @@ Last-Update: 2017-11-24
+nauty_labelg_DESCRIPTION = "canonically label graphs"
+nauty_linegraphg_DESCRIPTION = "compute the linegraphs of a file of graphs"
+nauty_listg_DESCRIPTION = "display graphs in a variety of forms"
+nauty_nbrhoodg_DESCRIPTION = "extract neighbourhoods of vertices"
+nauty_multig_DESCRIPTION = "generate small multigraphs with given underlying graph"
+nauty_newedgeg_DESCRIPTION = "create new edges from pairs of non-adjacent edges in each possible way"
+nauty_NRswitchg_DESCRIPTION = "complement vertex edges"
@ -330,6 +336,7 @@ Last-Update: 2017-11-24
-linegraphg_CPPFLAGS =
-listg_CPPFLAGS =
-multig_CPPFLAGS =
-nbrhoodg_CPPFLAGS =
-newedgeg_CPPFLAGS =
-NRswitchg_CPPFLAGS =
-pickg_CPPFLAGS =
@ -374,6 +381,7 @@ Last-Update: 2017-11-24
+nauty_linegraphg_CPPFLAGS =
+nauty_listg_CPPFLAGS =
+nauty_multig_CPPFLAGS =
+nauty_nbrhoodg_CPPFLAGS =
+nauty_newedgeg_CPPFLAGS =
+nauty_NRswitchg_CPPFLAGS =
+nauty_pickg_CPPFLAGS =
@ -420,6 +428,7 @@ Last-Update: 2017-11-24
-linegraphg_SOURCES = linegraphg.c
-listg_SOURCES = listg.c
-multig_SOURCES = multig.c
-nbrhoodg_SOURCES = nbrhoodg.c
-newedgeg_SOURCES = newedgeg.c
-NRswitchg_SOURCES = NRswitchg.c
-pickg_SOURCES = testg.c
@ -464,6 +473,7 @@ Last-Update: 2017-11-24
+nauty_linegraphg_SOURCES = linegraphg.c
+nauty_listg_SOURCES = listg.c
+nauty_multig_SOURCES = multig.c
+nauty_nbrhoodg_SOURCES = nbrhoodg.c
+nauty_newedgeg_SOURCES = newedgeg.c
+nauty_NRswitchg_SOURCES = NRswitchg.c
+nauty_pickg_SOURCES = testg.c
@ -510,6 +520,7 @@ Last-Update: 2017-11-24
-linegraphg_LDADD = $(NAUTY_LDADD)
-listg_LDADD = $(NAUTY_LDADD)
-multig_LDADD = $(NAUTY_LDADD)
-nbrhoodg_LDADD = $(NAUTY_LDADD)
-newedgeg_LDADD = $(NAUTY_LDADD)
-NRswitchg_LDADD = $(NAUTY_LDADD)
-pickg_LDADD = $(NAUTY_LDADD)
@ -555,6 +566,7 @@ Last-Update: 2017-11-24
+nauty_linegraphg_LDADD = $(NAUTY_LDADD)
+nauty_listg_LDADD = $(NAUTY_LDADD)
+nauty_multig_LDADD = $(NAUTY_LDADD)
+nauty_nbrhoodg_LDADD = $(NAUTY_LDADD)
+nauty_newedgeg_LDADD = $(NAUTY_LDADD)
+nauty_NRswitchg_LDADD = $(NAUTY_LDADD)
+nauty_pickg_LDADD = $(NAUTY_LDADD)

View File

@ -1,6 +1,6 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,9 +152,9 @@
@@ -154,9 +154,9 @@
AM_LDFLAGS =
LDADD =
@ -13,7 +13,7 @@
AM_H2MFLAGS = \
--manual="Nauty Manual" \
@@ -404,7 +404,7 @@
@@ -410,7 +410,7 @@
libnautyL1_la_LD_VERSION_SCRIPT += -Wl,--version-script=$(top_builddir)/$(libnautyL1_la_MAP)
endif
@ -22,7 +22,7 @@
libnauty_la_LDFLAGS = -version-info $(LIBNAUTY_LT_VERSION) $(libnauty_la_LD_VERSION_SCRIPT)
libnauty_la_SOURCES = \
@@ -427,43 +427,43 @@
@@ -433,43 +433,43 @@
libnautyA1_la_DEPENDENCIES = $(libnautyA1_la_MAP)
libnautyA1_la_CPPFLAGS = $(nautyA1_flavour_CPPFLAGS)
@ -73,7 +73,7 @@
libnautyL1_la_LDFLAGS = -version-info $(LIBNAUTY_LT_VERSION) $(libnautyL1_la_LD_VERSION_SCRIPT)
libnautyL1_la_SOURCES =$(libnauty_la_SOURCES)
@@ -494,17 +494,17 @@
@@ -500,17 +500,17 @@
nautestL_SOURCES = nauty.h naututil.h nautest.c
dreadtest_LDADD = $(NAUTY_LDADD)

View File

@ -1,4 +1,4 @@
%global nautybasever 2.7r2
%global nautybasever 2.7r3
%global nautytarver %(tr -d . <<< %{nautybasever})
Name: nauty
@ -128,6 +128,9 @@ LD_LIBRARY_PATH=$PWD/.libs make check
%{_libdir}/pkgconfig/%{name}.pc
%changelog
* Mon Sep 6 2021 Jerry James <loganjerry@gmail.com> - 2.7.3-1
- Version 2.7.3
* Thu Sep 2 2021 Jerry James <loganjerry@gmail.com> - 2.7.2-1
- Version 2.7.2

View File

@ -1 +1 @@
SHA512 (nauty27r2.tar.gz) = 07b6e2648faf87e5978d18ce30925b4a3cd3a384df542f987cfb6600cb74eb4960286b5559d971a3f5814d9360b200901babfd6e27faed47079402c4efe0759e
SHA512 (nauty27r3.tar.gz) = 8d6d92de8d348d3874677a55773088f4ff5b9a45fd9ed3802c9b1590072f5861946ac1d21892f4b383a9e36f6c9ac08270d021429cf36da3e5038e6a38d9fb6c