New upstream version.

This commit is contained in:
Jerry James 2017-10-23 19:07:16 -06:00
parent 0f07d01caf
commit 8cee592b82
6 changed files with 18 additions and 14 deletions

1
.gitignore vendored
View File

@ -1,2 +1,3 @@
/nauty26r5.tar.gz /nauty26r5.tar.gz
/nauty26r7.tar.gz /nauty26r7.tar.gz
/nauty26r10.tar.gz

View File

@ -39,10 +39,10 @@ Last-Update: 2016-03-19
$2=1 $2=1
else else
$2=0 $2=0
@@ -57,10 +74,15 @@ @@ -77,10 +94,15 @@
*)
dnl Checks for system features gccver=0.0.0 ;;
AC_CANONICAL_HOST esac
+AC_PATH_PROG([HELP2MAN],[help2man]) +AC_PATH_PROG([HELP2MAN],[help2man])
dnl Checks for C compiler and sets CFLAGS if not set by user dnl Checks for C compiler and sets CFLAGS if not set by user
@ -55,9 +55,9 @@ Last-Update: 2016-03-19
CFLAGS=$user_cflags CFLAGS=$user_cflags
MORECFLAGS="" MORECFLAGS=""
dnl we need AC_SYS_LARGEFILE and AC_FUNC_FSEEKO dnl we need AC_SYS_LARGEFILE and AC_FUNC_FSEEKO
@@ -434,6 +456,26 @@ @@ -400,6 +422,26 @@
edit_msg="++++++ This file is automatically generated, don't edit it by hand! ++++++" echo CFLAGS=$CFLAGS
AC_SUBST(edit_msg) echo MORECFLAGS=$MORECFLAGS
-AC_OUTPUT(makefile:makefile.in nauty.h:nauty-h.in -AC_OUTPUT(makefile:makefile.in nauty.h:nauty-h.in
- naututil.h:naututil-h.in gtools.h:gtools-h.in) - naututil.h:naututil-h.in gtools.h:gtools-h.in)

View File

@ -15,7 +15,7 @@ Last-Update: 2013-11-22
--- a/gtools-h.in --- a/gtools-h.in
+++ b/gtools-h.in +++ b/gtools-h.in
@@ -273,6 +273,7 @@ @@ -283,6 +283,7 @@
extern TLS_ATTR char *readg_line; extern TLS_ATTR char *readg_line;
extern TLS_ATTR size_t ogf_linelen; extern TLS_ATTR size_t ogf_linelen;
extern TLS_ATTR boolean is_pipe; extern TLS_ATTR boolean is_pipe;

View File

@ -91,7 +91,7 @@ Last-Update: 2016-04-20
{ {
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -300,6 +300,9 @@ dnl --disable-popcnt disables the use of @@ -263,6 +263,9 @@ dnl --disable-popcnt disables the use of
AC_MSG_CHECKING(if popcnt instruction is available and requested) AC_MSG_CHECKING(if popcnt instruction is available and requested)
AC_ARG_ENABLE([popcnt], AC_ARG_ENABLE([popcnt],
AS_HELP_STRING([--disable-popcnt], [Disable popcnt extensions]), [popcntarg=given], [popcntarg=notgiven]) AS_HELP_STRING([--disable-popcnt], [Disable popcnt extensions]), [popcntarg=given], [popcntarg=notgiven])
@ -101,7 +101,7 @@ Last-Update: 2016-04-20
AS_IF([test "x$popcntarg" = "xnotgiven" -o "x$enable_popcnt" = "xyes"], [ AS_IF([test "x$popcntarg" = "xnotgiven" -o "x$enable_popcnt" = "xyes"], [
have_hwpopcnt=0 have_hwpopcnt=0
test -e /proc/cpuinfo && grep -i popcnt /proc/cpuinfo >/dev/null && have_hwpopcnt=1 test -e /proc/cpuinfo && grep -i popcnt /proc/cpuinfo >/dev/null && have_hwpopcnt=1
@@ -329,7 +333,6 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([#include @@ -293,7 +296,6 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([#include
main(){unsigned int x; x = _mm_popcnt_u64(x);}])], [have_mmpop64=1], [have_mmpop64=0]) main(){unsigned int x; x = _mm_popcnt_u64(x);}])], [have_mmpop64=1], [have_mmpop64=0])
AC_MSG_RESULT($have_mmpop64) AC_MSG_RESULT($have_mmpop64)
], [ ], [
@ -109,7 +109,7 @@ Last-Update: 2016-04-20
AC_MSG_CHECKING(if __builtin_popcount() is supported) AC_MSG_CHECKING(if __builtin_popcount() is supported)
AC_LINK_IFELSE([AC_LANG_SOURCE([main(){unsigned int x; x = __builtin_popcount(x);}])], [have_popcnt=1], [have_popcnt=0]) AC_LINK_IFELSE([AC_LANG_SOURCE([main(){unsigned int x; x = __builtin_popcount(x);}])], [have_popcnt=1], [have_popcnt=0])
AC_MSG_RESULT($have_popcnt) AC_MSG_RESULT($have_popcnt)
@@ -348,6 +351,7 @@ AC_SUBST(have_popcntl) @@ -312,6 +314,7 @@ AC_SUBST(have_popcntl)
AC_SUBST(have_popcntll) AC_SUBST(have_popcntll)
AC_SUBST(have_mmpop32) AC_SUBST(have_mmpop32)
AC_SUBST(have_mmpop64) AC_SUBST(have_mmpop64)

View File

@ -1,9 +1,9 @@
%global nautybasever 2.6r7 %global nautybasever 2.6r10
%global nautytarver %(tr -d . <<< %{nautybasever}) %global nautytarver %(tr -d . <<< %{nautybasever})
Name: nauty Name: nauty
Version: %(tr r . <<< %{nautybasever}) Version: %(tr r . <<< %{nautybasever})
Release: 4%{?dist} Release: 1%{?dist}
Summary: Graph canonical labeling and automorphism group computation Summary: Graph canonical labeling and automorphism group computation
License: ASL 2.0 License: ASL 2.0
@ -125,6 +125,9 @@ make check
%{_libdir}/pkgconfig/%{name}.pc %{_libdir}/pkgconfig/%{name}.pc
%changelog %changelog
* Mon Oct 23 2017 Jerry James <loganjerry@gmail.com> - 2.6.10-1
- New upstream version
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.7-4 * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.7-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild

View File

@ -1 +1 @@
b2b18e03ea7698db3fbe06c5d76ad8fe nauty26r7.tar.gz SHA512 (nauty26r10.tar.gz) = 013a3ab11f1c64af4b2a5e8c8994f8b71911c711cfe8dcd2b171dec14a8cad0a77e1b158dc37eaa1bfa79b3e2c645f30d02c27de5d37f74425c193af53a6e768