Version 2.7.2.
This commit is contained in:
parent
4776d54ba4
commit
3d854bd1f0
@ -30,7 +30,7 @@ Last-Update: 2017-11-24
|
||||
|
||||
# ======================================================================
|
||||
# First we define some functions
|
||||
@@ -124,30 +141,37 @@
|
||||
@@ -119,30 +136,37 @@
|
||||
is_cygwin=0 ;;
|
||||
esac
|
||||
|
||||
@ -85,9 +85,9 @@ Last-Update: 2017-11-24
|
||||
|
||||
case "$CC" in
|
||||
gcc*)
|
||||
@@ -448,5 +472,26 @@
|
||||
edit_msg="++++++ This file is automatically generated, don't edit it by hand! ++++++"
|
||||
AC_SUBST(edit_msg)
|
||||
@@ -461,5 +485,26 @@
|
||||
AC_PROG_MKDIR_P
|
||||
AC_PROG_INSTALL
|
||||
|
||||
-AC_OUTPUT(makefile:makefile.in nauty.h:nauty-h.in
|
||||
- naututil.h:naututil-h.in gtools.h:gtools-h.in)
|
||||
|
@ -1,7 +1,7 @@
|
||||
Description: enable runtime detection of popcnt-enabled CPU
|
||||
Origin: fedora
|
||||
Author: Jerry James <loganjerry@gmail.com>
|
||||
Last-Update: 2020-05-21
|
||||
Last-Update: 2021-09-02
|
||||
|
||||
--- a/addedgeg.c
|
||||
+++ b/addedgeg.c
|
||||
@ -91,7 +91,7 @@ Last-Update: 2020-05-21
|
||||
{
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -83,6 +83,9 @@
|
||||
@@ -79,6 +79,9 @@ AC_ARG_ENABLE([popcnt],
|
||||
AS_HELP_STRING([--disable-popcnt], [Disable popcnt extensions]),
|
||||
[enablearg=given], [enablearg=notgiven])
|
||||
AS_IF([test $enablearg = notgiven || test "x$enable_popcnt" = xyes],[allow_popcnt=1],[allow_popcnt=0])
|
||||
@ -101,7 +101,7 @@ Last-Update: 2020-05-21
|
||||
|
||||
dnl --disable-clz disallows clz instructions, otherwise they are tested for
|
||||
AC_ARG_ENABLE([clz],
|
||||
@@ -317,7 +320,7 @@
|
||||
@@ -319,7 +322,7 @@ have_popcntll=0
|
||||
have_mmpop32=0
|
||||
have_mmpop64=0
|
||||
|
||||
@ -110,7 +110,7 @@ Last-Update: 2020-05-21
|
||||
[AS_IF([test "$CC" = "icc"],
|
||||
[AC_MSG_CHECKING(if _mm_popcnt_u32() is supported)
|
||||
AC_LINK_IFELSE([AC_LANG_SOURCE([#include <nmmintrin.h>
|
||||
@@ -351,6 +354,7 @@
|
||||
@@ -353,6 +356,7 @@ AC_SUBST(have_popcntl)
|
||||
AC_SUBST(have_popcntll)
|
||||
AC_SUBST(have_mmpop32)
|
||||
AC_SUBST(have_mmpop64)
|
||||
@ -949,7 +949,7 @@ Last-Update: 2020-05-21
|
||||
/**************************************************************************/
|
||||
--- a/genquarticg.c
|
||||
+++ b/genquarticg.c
|
||||
@@ -227,9 +227,9 @@ isbiconnected(graph *g, int n)
|
||||
@@ -226,9 +226,9 @@ isbiconnected(graph *g, int n)
|
||||
* of the graph reaches nmax after which it is written to outputfile *
|
||||
****************************************************************************/
|
||||
|
||||
@ -962,7 +962,7 @@ Last-Update: 2020-05-21
|
||||
{
|
||||
int vm1, vm2, vm3, vm4, vt1, vt2, vt3, vt4, c, b, mcol1,
|
||||
tcol, got_one, i, j, numpair1, numdovi, maxdovi, i1, j1, i2, j2,
|
||||
@@ -913,7 +913,7 @@ extend(int n, graph *g, edgestruct *edge
|
||||
@@ -906,7 +906,7 @@ extend(int n, graph *g, edgestruct *edge
|
||||
|
||||
} //end for c..
|
||||
|
||||
@ -971,7 +971,7 @@ Last-Update: 2020-05-21
|
||||
|
||||
/*****************************************************************************
|
||||
* *
|
||||
@@ -1157,9 +1157,9 @@ init_refinex( int *clr, int *lb, int *p,
|
||||
@@ -1150,9 +1150,9 @@ init_refinex( int *clr, int *lb, int *p,
|
||||
* code := -1 for n-1 not max, 0 for maybe, 1 for definite *
|
||||
* *
|
||||
*****************************************************************************/
|
||||
@ -984,7 +984,7 @@ Last-Update: 2020-05-21
|
||||
{
|
||||
int i, c1, c2, labc1, split1, split2, cell1, cell2, cnt, bmin, bmax;
|
||||
int workperm[MAXN], bucket[MAXN+2];
|
||||
@@ -1287,7 +1287,7 @@ refinex(graph *g, int *lab, int *ptn, in
|
||||
@@ -1280,7 +1280,7 @@ refinex(graph *g, int *lab, int *ptn, in
|
||||
}
|
||||
}
|
||||
}
|
||||
@ -995,7 +995,7 @@ Last-Update: 2020-05-21
|
||||
/*****************************************************************************/
|
||||
--- a/gentourng.c
|
||||
+++ b/gentourng.c
|
||||
@@ -547,9 +547,9 @@ userautomproc(int count, int *p, int *or
|
||||
@@ -549,9 +549,9 @@ userautomproc(int count, int *p, int *or
|
||||
* *
|
||||
*****************************************************************************/
|
||||
|
||||
@ -1008,7 +1008,7 @@ Last-Update: 2020-05-21
|
||||
{
|
||||
int i,c1,c2,labc1;
|
||||
setword x,lact;
|
||||
@@ -681,7 +681,7 @@ refinex(graph *g, int *lab, int *ptn, in
|
||||
@@ -683,7 +683,7 @@ refinex(graph *g, int *lab, int *ptn, in
|
||||
}
|
||||
}
|
||||
}
|
||||
@ -1017,7 +1017,7 @@ Last-Update: 2020-05-21
|
||||
|
||||
/**************************************************************************/
|
||||
|
||||
@@ -803,8 +803,7 @@ accept1(graph *g, int n, xword x, graph
|
||||
@@ -805,8 +805,7 @@ accept1(graph *g, int n, xword x, graph
|
||||
|
||||
/**************************************************************************/
|
||||
|
||||
@ -1027,7 +1027,7 @@ Last-Update: 2020-05-21
|
||||
/* make hitting invariant
|
||||
* return FALSE if n-1 not maximal else return TRUE */
|
||||
{
|
||||
@@ -827,12 +826,26 @@ hitinvar(graph *g, int *invar, int n)
|
||||
@@ -829,12 +828,26 @@ hitinvar(graph *g, int *invar, int n)
|
||||
if (v < n-1 && inv > invar[n-1]) return FALSE;
|
||||
}
|
||||
return TRUE;
|
||||
@ -1057,8 +1057,8 @@ Last-Update: 2020-05-21
|
||||
/* decide if n in theta(g+x) -- version for n+1 == maxn */
|
||||
{
|
||||
int i;
|
||||
@@ -849,10 +862,8 @@ accept2(graph *g, int n, xword x, graph
|
||||
setword workspace[50];
|
||||
@@ -851,10 +864,8 @@ accept2(graph *g, int n, xword x, graph
|
||||
setword workspace[200];
|
||||
boolean cheapacc;
|
||||
|
||||
-#ifdef INSTRUMENT
|
||||
@ -1070,7 +1070,7 @@ Last-Update: 2020-05-21
|
||||
nx = n + 1;
|
||||
gxn = 0;
|
||||
|
||||
@@ -873,15 +884,11 @@ accept2(graph *g, int n, xword x, graph
|
||||
@@ -875,15 +886,11 @@ accept2(graph *g, int n, xword x, graph
|
||||
gx[n] = gxn;
|
||||
degx[n] = degn = XPOPCOUNT(x);
|
||||
|
||||
@ -1088,7 +1088,7 @@ Last-Update: 2020-05-21
|
||||
if (canonise) makecanon(gx,gcan,nx);
|
||||
return TRUE;
|
||||
}
|
||||
@@ -920,9 +927,7 @@ accept2(graph *g, int n, xword x, graph
|
||||
@@ -922,9 +929,7 @@ accept2(graph *g, int n, xword x, graph
|
||||
{
|
||||
if (j0 == n)
|
||||
{
|
||||
@ -1099,7 +1099,7 @@ Last-Update: 2020-05-21
|
||||
if (canonise) makecanon(gx,gcan,nx);
|
||||
return TRUE;
|
||||
}
|
||||
@@ -965,9 +970,7 @@ accept2(graph *g, int n, xword x, graph
|
||||
@@ -967,9 +972,7 @@ accept2(graph *g, int n, xword x, graph
|
||||
{
|
||||
if (j0 == n)
|
||||
{
|
||||
@ -1110,7 +1110,7 @@ Last-Update: 2020-05-21
|
||||
if (canonise) makecanon(gx,gcan,nx);
|
||||
return TRUE;
|
||||
}
|
||||
@@ -986,9 +989,7 @@ accept2(graph *g, int n, xword x, graph
|
||||
@@ -988,9 +991,7 @@ accept2(graph *g, int n, xword x, graph
|
||||
|
||||
if (cheapacc)
|
||||
{
|
||||
@ -1121,7 +1121,7 @@ Last-Update: 2020-05-21
|
||||
if (canonise) makecanon(gx,gcan,nx);
|
||||
return TRUE;
|
||||
}
|
||||
@@ -998,22 +999,18 @@ accept2(graph *g, int n, xword x, graph
|
||||
@@ -1000,22 +1001,18 @@ accept2(graph *g, int n, xword x, graph
|
||||
options.defaultptn = FALSE;
|
||||
|
||||
active[0] = 0;
|
||||
@ -1129,7 +1129,7 @@ Last-Update: 2020-05-21
|
||||
- ++a2nauty;
|
||||
-#endif
|
||||
+ INSTRUMENT_VAR(a2nauty);
|
||||
nauty(gx,lab,ptn,active,orbits,&options,&stats,workspace,50,1,nx,gcan);
|
||||
nauty(gx,lab,ptn,active,orbits,&options,&stats,workspace,200,1,nx,gcan);
|
||||
|
||||
if (orbits[lab[n]] == orbits[n])
|
||||
{
|
||||
@ -1334,7 +1334,7 @@ Last-Update: 2020-05-21
|
||||
-long
|
||||
-numtriangles1(graph *g, int n)
|
||||
+POPCNTFUNC(long,numtriangles1,(graph *g, int n),
|
||||
/* The number of triangles in g */
|
||||
/* The number of triangles in g; undirected only */
|
||||
{
|
||||
int i,j;
|
||||
@@ -176,12 +173,11 @@ numtriangles1(graph *g, int n)
|
||||
@ -1349,7 +1349,7 @@ Last-Update: 2020-05-21
|
||||
-long
|
||||
-numtriangles(graph *g, int m, int n)
|
||||
+POPCNTFUNC(long,numtriangles,(graph *g, int m, int n),
|
||||
/* The number of triangles in g */
|
||||
/* The number of triangles in g; undirected only */
|
||||
{
|
||||
int i,j,k,kw;
|
||||
@@ -206,7 +202,7 @@ numtriangles(graph *g, int m, int n)
|
||||
@ -2022,7 +2022,7 @@ Last-Update: 2020-05-21
|
||||
* *
|
||||
--- a/nauty-h.in
|
||||
+++ b/nauty-h.in
|
||||
@@ -68,6 +68,7 @@ it is necessary to check they are correc
|
||||
@@ -88,6 +88,7 @@ it is necessary to check they are correc
|
||||
#define HAVE_POPCNTLL @have_popcntll@
|
||||
#define HAVE_MMPOP32 @have_mmpop32@
|
||||
#define HAVE_MMPOP64 @have_mmpop64@
|
||||
@ -2030,7 +2030,7 @@ Last-Update: 2020-05-21
|
||||
|
||||
/*==================================================================*/
|
||||
|
||||
@@ -804,6 +805,46 @@ typedef unsigned long nauty_counter;
|
||||
@@ -827,6 +828,46 @@ typedef unsigned long nauty_counter;
|
||||
|
||||
#ifndef FIRSTBITNZ /* Can be defined outside */
|
||||
|
||||
@ -2077,7 +2077,7 @@ Last-Update: 2020-05-21
|
||||
#ifdef NAUTY_IN_MAGMA
|
||||
#define FIRSTBITNZ(x) bs_firstbit(x)
|
||||
|
||||
@@ -915,7 +956,7 @@ static int msc_bsr_16(setword x) \
|
||||
@@ -938,7 +979,7 @@ static int msc_bsr_16(setword x) \
|
||||
|
||||
/* Note that, unlike icc, gcc will not use the POPCNT instruction
|
||||
without permission, in which case it defines __POPCNT__ . */
|
||||
@ -2086,7 +2086,7 @@ Last-Update: 2020-05-21
|
||||
#if defined(SETWORD_LONGLONG) && HAVE_POPCNTLL
|
||||
#define POPCOUNT(x) __builtin_popcountll(x)
|
||||
#elif defined(SETWORD_LONG) && HAVE_POPCNTL
|
||||
@@ -1176,6 +1217,18 @@ extern void free(void*);
|
||||
@@ -1199,6 +1240,18 @@ extern void free(void*);
|
||||
#define CONDYNFREE(name,name_sz,minsz) \
|
||||
if (name_sz > (size_t)(minsz)) {DYNFREE(name,name_sz);}
|
||||
|
||||
|
11
nauty.spec
11
nauty.spec
@ -1,14 +1,14 @@
|
||||
%global nautybasever 2.7r1
|
||||
%global nautybasever 2.7r2
|
||||
%global nautytarver %(tr -d . <<< %{nautybasever})
|
||||
|
||||
Name: nauty
|
||||
Version: %(tr r . <<< %{nautybasever})
|
||||
Release: 5%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Summary: Graph canonical labeling and automorphism group computation
|
||||
|
||||
License: ASL 2.0
|
||||
URL: http://pallini.di.uniroma1.it/
|
||||
Source0: http://pallini.di.uniroma1.it/%{name}%{nautytarver}.tar.gz
|
||||
URL: https://pallini.di.uniroma1.it/
|
||||
Source0: https://pallini.di.uniroma1.it/%{name}%{nautytarver}.tar.gz
|
||||
|
||||
# Debian patch to fix the gt_numorbits declaration
|
||||
Patch0: %{name}-fix-gt_numorbits.patch
|
||||
@ -128,6 +128,9 @@ LD_LIBRARY_PATH=$PWD/.libs make check
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
|
||||
%changelog
|
||||
* Thu Sep 2 2021 Jerry James <loganjerry@gmail.com> - 2.7.2-1
|
||||
- Version 2.7.2
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (nauty27r1.tar.gz) = f3a228b2967553f0096f9f70eaa1c25b0a929c315b4a6c6948903d197aa6431b7068ca19b1f7902c41597e1abfa81fb709fc7c4a8d193a187491239df8507b33
|
||||
SHA512 (nauty27r2.tar.gz) = 07b6e2648faf87e5978d18ce30925b4a3cd3a384df542f987cfb6600cb74eb4960286b5559d971a3f5814d9360b200901babfd6e27faed47079402c4efe0759e
|
||||
|
Loading…
x
Reference in New Issue
Block a user