nano/nano-2.3.0-warnings.patch
Kamil Dudka d4b92eee66 new upstream release (#680736)
- new upstream release (#680736)
- use hunspell as default spell-checker (#681000)
- fix for http://thread.gmane.org/gmane.editors.nano.devel/2911
2011-03-03 12:10:48 +01:00

43 lines
1.2 KiB
Diff

po/Makefile.in.in | 1 +
src/nano.c | 2 +-
2 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/po/Makefile.in.in b/po/Makefile.in.in
index ada8bb4..f7b2a95 100644
--- a/po/Makefile.in.in
+++ b/po/Makefile.in.in
@@ -20,6 +20,7 @@ VPATH = @srcdir@
prefix = @prefix@
exec_prefix = @exec_prefix@
+datarootdir = @datarootdir@
datadir = @datadir@
localedir = $(datadir)/locale
gettextsrcdir = $(datadir)/gettext/po
diff --git a/src/nano.c b/src/nano.c
index 269ab29..5b605bf 100644
--- a/src/nano.c
+++ b/src/nano.c
@@ -1925,7 +1925,7 @@ precalc_cleanup:
* TRUE. */
void do_output(char *output, size_t output_len, bool allow_cntrls)
{
- size_t current_len, orig_lenpt, i = 0;
+ size_t current_len, orig_lenpt = 0, i = 0;
char *char_buf = charalloc(mb_cur_max());
int char_buf_len;
diff --git a/src/search.c b/src/search.c
index ca93098..3451600 100644
--- a/src/search.c
+++ b/src/search.c
@@ -138,7 +138,7 @@ int search_init(bool replacing, bool use_answer)
int i = 0;
char *buf;
sc *s;
- void (*func)(void);
+ void (*func)(void) = (void (*)(void))0;
bool meta_key = FALSE, func_key = FALSE;
static char *backupstring = NULL;
/* The search string we'll be using. */