nano/nano-2.2.3-warnings.patch
Kamil Dudka 4d86d70033 - new upstream release
- CVE-2010-1160, CVE-2010-1161 (#582739)
2010-04-15 18:08:21 +00:00

43 lines
1.2 KiB
Diff

po/Makefile.in.in | 1 +
src/nano.c | 2 +-
src/winio.c | 1 -
3 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/po/Makefile.in.in b/po/Makefile.in.in
index ada8bb4..f7b2a95 100644
--- a/po/Makefile.in.in
+++ b/po/Makefile.in.in
@@ -20,6 +20,7 @@ VPATH = @srcdir@
prefix = @prefix@
exec_prefix = @exec_prefix@
+datarootdir = @datarootdir@
datadir = @datadir@
localedir = $(datadir)/locale
gettextsrcdir = $(datadir)/gettext/po
diff --git a/src/nano.c b/src/nano.c
index 59e2a9d..1d1d40c 100644
--- a/src/nano.c
+++ b/src/nano.c
@@ -1901,7 +1901,7 @@ precalc_cleanup:
* TRUE. */
void do_output(char *output, size_t output_len, bool allow_cntrls)
{
- size_t current_len, orig_lenpt, i = 0;
+ size_t current_len, orig_lenpt = 0, i = 0;
char *char_buf = charalloc(mb_cur_max());
int char_buf_len;
diff --git a/src/winio.c b/src/winio.c
index 1aef2a9..9fde5a2 100644
--- a/src/winio.c
+++ b/src/winio.c
@@ -3125,7 +3125,6 @@ void edit_redraw(filestruct *old_current, size_t pww_save)
old_current->lineno, openfile->edittop->lineno);
#endif
filestruct *old_edittop = openfile->edittop;
- ssize_t nlines;
#ifndef NANO_TINY
/* If the mark is on, update all the lines between old_current