new upstream release - 2.8.0

This commit is contained in:
Kamil Dudka 2017-03-31 12:09:39 +02:00
parent 25535468bc
commit 88b7b6e9ff
5 changed files with 30 additions and 59 deletions

View File

@ -4,57 +4,27 @@ Date: Thu, 19 Aug 2010 15:23:06 +0200
Subject: [PATCH 2/2] use futimens() if available, instead of utime()
---
config.h.in | 3 +++
configure | 2 +-
configure.ac | 2 +-
src/files.c | 46 +++++++++++++++++++++++++++++++++++-----------
4 files changed, 40 insertions(+), 13 deletions(-)
configure.ac | 1 +
src/files.c | 46 +++++++++++++++++++++++++++++++++++-----------
2 files changed, 36 insertions(+), 11 deletions(-)
diff --git a/config.h.in b/config.h.in
index 52e13f1..cb17b29 100644
--- a/config.h.in
+++ b/config.h.in
@@ -72,6 +72,9 @@
/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
#undef HAVE_DOPRNT
+/* Define to 1 if you have the `futimens' function. */
+#undef HAVE_FUTIMENS
+
/* Define to 1 if you have the `getdelim' function. */
#undef HAVE_GETDELIM
diff --git a/configure b/configure
index 02733c7..1805e53 100755
--- a/configure
+++ b/configure
@@ -7776,7 +7776,7 @@ fi
-for ac_func in getdelim getline isblank strcasecmp strcasestr strncasecmp strnlen snprintf vsnprintf
+for ac_func in futimens getdelim getline isblank strcasecmp strcasestr strncasecmp strnlen snprintf vsnprintf
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/configure.ac b/configure.ac
index 66f8ee3..f4975d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -442,7 +442,7 @@ int main(void)
@@ -468,6 +468,7 @@ int main(void)
dnl Checks for functions.
-AC_CHECK_FUNCS(getdelim getline isblank strcasecmp strcasestr strncasecmp strnlen snprintf vsnprintf)
+AC_CHECK_FUNCS(futimens getdelim getline isblank strcasecmp strcasestr strncasecmp strnlen snprintf vsnprintf)
+AC_CHECK_FUNCS(futimens)
if test "x$enable_utf8" != xno; then
AC_CHECK_FUNCS(iswalnum iswblank iswpunct iswspace nl_langinfo mblen mbstowcs mbtowc wctomb wcwidth)
AC_CHECK_FUNCS(iswalnum iswpunct mblen mbstowcs mbtowc wctomb)
diff --git a/src/files.c b/src/files.c
index 99cc1b8..9a1bdcc 100644
--- a/src/files.c
+++ b/src/files.c
@@ -1696,6 +1696,29 @@ int copy_file(FILE *inn, FILE *out)
@@ -1570,6 +1570,29 @@ int copy_file(FILE *inn, FILE *out)
return retval;
}
@ -84,7 +54,7 @@ index 99cc1b8..9a1bdcc 100644
/* Write a file out to disk. If f_open isn't NULL, we assume that it is
* a stream associated with the file, and we don't try to open it
* ourselves. If tmp is TRUE, we set the umask to disallow anyone else
@@ -1917,17 +1940,9 @@ bool write_file(const char *name, FILE *f_open, bool tmp,
@@ -1789,17 +1812,9 @@ bool write_file(const char *name, FILE *f_open, bool tmp,
fprintf(stderr, "Backing up %s to %s\n", realname, backupname);
#endif
@ -105,7 +75,7 @@ index 99cc1b8..9a1bdcc 100644
if (prompt_failed_backupwrite(backupname))
goto skip_backup;
statusline(HUSH, _("Error writing backup file %s: %s"),
@@ -1939,6 +1954,15 @@ bool write_file(const char *name, FILE *f_open, bool tmp,
@@ -1811,6 +1826,15 @@ bool write_file(const char *name, FILE *f_open, bool tmp,
goto cleanup_and_exit;
}

View File

@ -1,11 +0,0 @@
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEEp/amSmfaCe+SeC3XnfSGKvEXXFsFAliuvfwACgkQnfSGKvEX
XFsMkwgAl4JYw3aVvqClkV50hM9S3hTgYXFisnlBcOPax963k7zUjEip5zFmOIcD
ctm9CMDXp35kYmwhS5yYkNcgtoRcOwGpWNltrUhJgXU+k1W1aErA4odmuBqdoufS
r0b2knVRpPaaSjF+aPNqJRPMZrXdelN0QsVJS5WNkz9WgV6WIRcw0M5U+vjSypov
zG/FujMFukiCtCcEuQ+5V+ZNyjHH9BshcCRZCpYVRoKIx6zPTYUSPCZGfiMigoIh
gROCll8A+/s6V3E950LFxMtCgQbwZvHTL8eZ6TaYiKgYHNmgzYqys5uPDByD2zY2
xo+X27r5HVX+Z8lr3V8fvOCMXjVq+w==
=NMSG
-----END PGP SIGNATURE-----

11
nano-2.8.0.tar.gz.asc Normal file
View File

@ -0,0 +1,11 @@
-----BEGIN PGP SIGNATURE-----
iQEzBAABCAAdFiEEp/amSmfaCe+SeC3XnfSGKvEXXFsFAljeHL8ACgkQnfSGKvEX
XFvzkwf/YbAe+RfETWd7nZlw+c9CqntPLqcc1mVnCOO9ng3a7wAyCfzuHtgg0m63
vYufpYxi/AyFwTjv8GyPnqcVGdwqXiY06kKsPSh+3vP8ChIujYoAfrTXZoX4qGhP
68xX0ZxioR6NOUZ+Nwxa2n4VJO6q+P0fJKe2NoiX+tLRgErpZl/NPVdL+ekKWaau
iJ3snxkMNrm0cC6KnZn6eYr+mSaLY85StoCFX5l9dhkm+RtZfYx8RuFF69oSItW5
Q7PcSxtDj0/e+0ZhkM6gdbTEY7SAqdmAgs6vIt2CQZ16l8FAfRFd+r7rWsnKJFyU
OW8RlvHHNkbxeSrlLEmM4bspZ3zj5A==
=ZCcd
-----END PGP SIGNATURE-----

View File

@ -1,15 +1,16 @@
Summary: A small text editor
Name: nano
Version: 2.7.5
Version: 2.8.0
Release: 1%{?dist}
License: GPLv3+
URL: https://www.nano-editor.org
Source: https://www.nano-editor.org/dist/v2.7/%{name}-%{version}.tar.gz
Source: https://www.nano-editor.org/dist/v2.8/%{name}-%{version}.tar.gz
Source2: nanorc
# http://lists.gnu.org/archive/html/nano-devel/2010-08/msg00005.html
Patch2: 0002-use-futimens-if-available-instead-of-utime.patch
BuildRequires: automake
BuildRequires: file-devel
BuildRequires: gettext-devel
BuildRequires: git
@ -26,15 +27,12 @@ GNU nano is a small and friendly text editor.
%prep
%autosetup -S git
# do not run autotools, we have already reflected the configure.ac
# changes in configure and config.h.in
touch -c aclocal.m4 config.h.in configure Makefile.in
autoreconf -v
%build
mkdir build
cd build
ln -s ../configure
%global _configure ../configure
%configure
make %{?_smp_mflags}
@ -85,6 +83,9 @@ exit 0
%{_datadir}/nano
%changelog
* Fri Mar 31 2017 Kamil Dudka <kdudka@redhat.com> - 2.8.0-1
- new upstream release
* Thu Feb 23 2017 Kamil Dudka <kdudka@redhat.com> - 2.7.5-1
- new upstream release

View File

@ -1 +1 @@
SHA512 (nano-2.7.5.tar.gz) = a5332a361c4d0d9d0a77ebb11cdcffa976bee4981d5665b2732a9e6d7a2997566d9345332f2e6e5cb74f0a81be4413f54ca8f719962ab10b32d7ec1c9271973c
SHA512 (nano-2.8.0.tar.gz) = 75631ddddf960aadfffb3d5df235e7b47118ee3050118927677a94036a87f9d7dfee9f0a75bd5dc6813c12e4edd51d7836c9173057d5caebf55ba9cfaafc6159