new upstream release - 2.3.2
This commit is contained in:
parent
b249835f6f
commit
015956cd9c
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ nano-2.2.5.tar.gz
|
||||
/nano-2.2.6.tar.gz
|
||||
/nano-2.3.0.tar.gz
|
||||
/nano-2.3.1.tar.gz
|
||||
/nano-2.3.2.tar.gz
|
||||
|
@ -11,9 +11,9 @@ diff --git a/src/files.c b/src/files.c
|
||||
index f6efbf1..99cc1b8 100644
|
||||
--- a/src/files.c
|
||||
+++ b/src/files.c
|
||||
@@ -103,6 +103,24 @@ void initialize_buffer_text(void)
|
||||
openfile->totsize = 0;
|
||||
}
|
||||
@@ -306,6 +306,24 @@ int do_lockfile(const char *filename)
|
||||
#endif /* NANO_TINY */
|
||||
|
||||
|
||||
+#ifndef NANO_TINY
|
||||
+/* If *pstat is NULL, perform a stat call with the given file name. On success,
|
||||
@ -36,7 +36,7 @@ index f6efbf1..99cc1b8 100644
|
||||
/* If it's not "", filename is a file to open. We make a new buffer, if
|
||||
* necessary, and then open and read the file, if applicable. */
|
||||
void open_buffer(const char *filename, bool undoable)
|
||||
@@ -148,11 +166,7 @@ void open_buffer(const char *filename, bool undoable)
|
||||
@@ -351,11 +369,7 @@ void open_buffer(const char *filename, bool undoable)
|
||||
if (rc > 0) {
|
||||
read_file(f, rc, filename, undoable, new_buffer);
|
||||
#ifndef NANO_TINY
|
||||
@ -49,7 +49,7 @@ index f6efbf1..99cc1b8 100644
|
||||
#endif
|
||||
}
|
||||
|
||||
@@ -1532,8 +1546,8 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -1741,8 +1755,8 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
* specified it interactively), stat and save the value
|
||||
* or else we will chase null pointers when we do
|
||||
* modtime checks, preserve file times, etc. during backup */
|
||||
@ -60,7 +60,7 @@ index f6efbf1..99cc1b8 100644
|
||||
|
||||
/* We backup only if the backup toggle is set, the file isn't
|
||||
* temporary, and the file already exists. Furthermore, if we
|
||||
@@ -1924,7 +1938,10 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -2134,7 +2148,10 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
if (openfile->current_stat == NULL)
|
||||
openfile->current_stat =
|
||||
(struct stat *)nmalloc(sizeof(struct stat));
|
||||
|
@ -28,7 +28,7 @@ diff --git a/configure b/configure
|
||||
index 02733c7..1805e53 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -7484,7 +7484,7 @@ fi
|
||||
@@ -7362,7 +7362,7 @@ fi
|
||||
|
||||
|
||||
|
||||
@ -41,7 +41,7 @@ diff --git a/configure.ac b/configure.ac
|
||||
index 66f8ee3..f4975d3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -415,7 +415,7 @@ fi])
|
||||
@@ -414,7 +414,7 @@ fi])
|
||||
|
||||
dnl Checks for functions.
|
||||
|
||||
@ -54,7 +54,7 @@ diff --git a/src/files.c b/src/files.c
|
||||
index 99cc1b8..9a1bdcc 100644
|
||||
--- a/src/files.c
|
||||
+++ b/src/files.c
|
||||
@@ -1455,6 +1455,29 @@ int copy_file(FILE *inn, FILE *out)
|
||||
@@ -1665,6 +1665,29 @@ int copy_file(FILE *inn, FILE *out)
|
||||
return retval;
|
||||
}
|
||||
|
||||
@ -84,7 +84,7 @@ index 99cc1b8..9a1bdcc 100644
|
||||
/* Write a file out to disk. If f_open isn't NULL, we assume that it is
|
||||
* a stream associated with the file, and we don't try to open it
|
||||
* ourselves. If tmp is TRUE, we set the umask to disallow anyone else
|
||||
@@ -1694,6 +1717,18 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -1904,6 +1927,18 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
fprintf(stderr, "Backing up %s to %s\n", realname, backupname);
|
||||
#endif
|
||||
|
||||
@ -103,7 +103,7 @@ index 99cc1b8..9a1bdcc 100644
|
||||
/* Copy the file. */
|
||||
copy_status = copy_file(f, backup_file);
|
||||
|
||||
@@ -1704,19 +1739,6 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
@@ -1914,19 +1949,6 @@ bool write_file(const char *name, FILE *f_open, bool tmp, append_type
|
||||
goto cleanup_and_exit;
|
||||
}
|
||||
|
||||
|
@ -1,7 +0,0 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.10 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAk3KFpIACgkQvLNW35EAn6clMACfVnKHIlK4QUTOlEKNRrDEkXUJ
|
||||
i2YAoN4Od7TENKHOXX383Ml//RxN1TvU
|
||||
=z+9f
|
||||
-----END PGP SIGNATURE-----
|
@ -1,6 +1,13 @@
|
||||
From 8d618f769b1e66a26e7b790e4e94b2c3dca68d31 Mon Sep 17 00:00:00 2001
|
||||
From: Kamil Dudka <kdudka@redhat.com>
|
||||
Date: Tue, 26 Mar 2013 16:20:27 +0100
|
||||
Subject: [PATCH] fix compile-time warnings in nano-2.3.2
|
||||
|
||||
---
|
||||
po/Makefile.in.in | 1 +
|
||||
src/nano.c | 2 +-
|
||||
2 files changed, 2 insertions(+), 1 deletions(-)
|
||||
src/search.c | 2 +-
|
||||
3 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/po/Makefile.in.in b/po/Makefile.in.in
|
||||
index ada8bb4..f7b2a95 100644
|
||||
@ -15,10 +22,10 @@ index ada8bb4..f7b2a95 100644
|
||||
localedir = $(datadir)/locale
|
||||
gettextsrcdir = $(datadir)/gettext/po
|
||||
diff --git a/src/nano.c b/src/nano.c
|
||||
index 269ab29..5b605bf 100644
|
||||
index 9d2332d..c315768 100644
|
||||
--- a/src/nano.c
|
||||
+++ b/src/nano.c
|
||||
@@ -1925,7 +1925,7 @@ precalc_cleanup:
|
||||
@@ -1934,7 +1934,7 @@ precalc_cleanup:
|
||||
* TRUE. */
|
||||
void do_output(char *output, size_t output_len, bool allow_cntrls)
|
||||
{
|
||||
@ -28,15 +35,18 @@ index 269ab29..5b605bf 100644
|
||||
int char_buf_len;
|
||||
|
||||
diff --git a/src/search.c b/src/search.c
|
||||
index ca93098..3451600 100644
|
||||
index 74bfb07..77b2097 100644
|
||||
--- a/src/search.c
|
||||
+++ b/src/search.c
|
||||
@@ -138,7 +138,7 @@ int search_init(bool replacing, bool use_answer)
|
||||
int i = 0;
|
||||
char *buf;
|
||||
sc *s;
|
||||
- void (*func)(void);
|
||||
+ void (*func)(void) = (void (*)(void))0;
|
||||
bool meta_key = FALSE, func_key = FALSE;
|
||||
static char *backupstring = NULL;
|
||||
/* The search string we'll be using. */
|
||||
@@ -219,7 +219,7 @@ int search_init(bool replacing, bool use_answer)
|
||||
statusbar(_("Cancelled"));
|
||||
return -1;
|
||||
} else {
|
||||
- void (*func)(void);
|
||||
+ void (*func)(void) = (void (*)(void)) 0;
|
||||
|
||||
for (s = sclist; s != NULL; s = s->next)
|
||||
if ((s->menu & currmenu) && i == s->seq) {
|
||||
--
|
||||
1.7.1
|
||||
|
7
nano-2.3.2.tar.gz.asc
Normal file
7
nano-2.3.2.tar.gz.asc
Normal file
@ -0,0 +1,7 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
Version: GnuPG v1.4.10 (GNU/Linux)
|
||||
|
||||
iEYEABECAAYFAlFRsnwACgkQvLNW35EAn6f9wwCdHmY/WKtwVoLR49vPgr/D8mwN
|
||||
ULcAn0nHgbd3m7B5XKaWrF5hJkypsss/
|
||||
=ZC4W
|
||||
-----END PGP SIGNATURE-----
|
@ -1,13 +1,13 @@
|
||||
Summary: A small text editor
|
||||
Name: nano
|
||||
Version: 2.3.1
|
||||
Release: 6%{?dist}
|
||||
Version: 2.3.2
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Editors
|
||||
URL: http://www.nano-editor.org
|
||||
Source: http://www.nano-editor.org/dist/v2.3/%{name}-%{version}.tar.gz
|
||||
Source2: nanorc
|
||||
Patch0: nano-2.3.0-warnings.patch
|
||||
Patch0: nano-2.3.2-warnings.patch
|
||||
|
||||
# http://lists.gnu.org/archive/html/nano-devel/2010-08/msg00004.html
|
||||
Patch1: 0001-check-stat-s-result-and-avoid-calling-stat-on-a-NULL.patch
|
||||
@ -88,6 +88,9 @@ exit 0
|
||||
%{_datadir}/nano
|
||||
|
||||
%changelog
|
||||
* Tue Mar 26 2013 Kamil Dudka <kdudka@redhat.com> - 2.3.2-1
|
||||
- new upstream release
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user