Update to new release (#691171)

This commit is contained in:
Pavel Zhukov 2011-03-27 16:47:42 +04:00
parent 8fe1c51e03
commit 96917942b1
5 changed files with 14 additions and 64 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/mupdf-0.7.tar.gz /mupdf-0.7.tar.gz
/mupdf-0.8.15-source.tar.gz

View File

@ -1,23 +0,0 @@
--- a/Makefile 2011-01-13 23:10:08.911556954 +0300
+++ b/Makefile 2011-01-13 23:12:43.329510332 +0300
@@ -36,6 +36,7 @@
include Makerules
include Makethird
+CFLAGS ?=
CFLAGS += $(THIRD_INCS) $(SYS_FREETYPE_INC)
#
--- a/Makerules 2010-08-25 18:12:08.000000000 +0400
+++ b/Makerules 2011-01-13 23:31:10.535045464 +0300
@@ -4,7 +4,8 @@
OS := $(OS:MINGW%=MINGW)
CC ?= cc
-CFLAGS := -Ifitz -Imupdf -Wall
+CFLAGS ?=
+CFLAGS += -Ifitz -Imupdf -Wall
LDFLAGS :=
ifeq "$(build)" "debug"

View File

@ -1,20 +0,0 @@
--- a/Makefile 2011-02-06 00:31:40.957428001 +0300
+++ b/Makefile 2011-02-06 00:32:37.597428002 +0300
@@ -7,6 +7,7 @@
build ?= debug
prefix ?= /usr/local
+LIBDIR ?= $(prefix)/lib
OBJDIR := build/$(build)
GENDIR := build/generated
@@ -378,7 +379,7 @@
rm -rf build
install: $(OBJDIR) $(GENDIR) $(MUPDF_LIB) $(APPS)
- install -d $(prefix)/bin $(prefix)/lib $(prefix)/include
+ install -d $(prefix)/bin $(LIBDIR) $(prefix)/include
install $(APPS) $(prefix)/bin
- install $(MUPDF_LIB) $(prefix)/lib
+ install $(MUPDF_LIB) $(MUPDF_SO_LIB) $(LIBDIR)
install $(MUPDF_HDR) $(prefix)/include

View File

@ -1,16 +1,14 @@
Name: mupdf Name: mupdf
Version: 0.7 Version: 0.8.15
Release: 8%{?dist} Release: 1%{?dist}
Summary: A lightweight PDF viewer and toolkit Summary: A lightweight PDF viewer and toolkit
Group: Applications/Publishing Group: Applications/Publishing
License: GPLv3 License: GPLv3
URL: http://mupdf.com/ URL: http://mupdf.com/
Source0: http://mupdf.com/download/%{name}-%{version}.tar.gz Source0: http://mupdf.com/download/%{name}-%{version}-source.tar.gz
Source1: %{name}.desktop Source1: %{name}.desktop
Patch1: %{name}-pdfinfo.patch Patch1: %{name}-pdfinfo.patch
Patch2: %{name}-libdir.patch
Patch3: %{name}-cflags.patch
BuildRequires: openjpeg-devel jbig2dec-devel desktop-file-utils BuildRequires: openjpeg-devel jbig2dec-devel desktop-file-utils
BuildRequires: libjpeg-devel freetype-devel libXext-devel BuildRequires: libjpeg-devel freetype-devel libXext-devel
@ -43,9 +41,6 @@ applications that use mupdf and static libraries
%setup -q %setup -q
## http://bugs.ghostscript.com/show_bug.cgi?id=691884 ## http://bugs.ghostscript.com/show_bug.cgi?id=691884
%patch1 -p1 %patch1 -p1
## http://bugs.ghostscript.com/show_bug.cgi?id=691885
%patch2 -p1
%patch3 -p1
%build %build
export CFLAGS="%{optflags}" export CFLAGS="%{optflags}"
@ -56,14 +51,11 @@ make %{?_smp_mflags} verbose=1
make DESTDIR=%{buildroot} install prefix=%{buildroot}/usr LIBDIR=%{buildroot}%{_libdir} make DESTDIR=%{buildroot} install prefix=%{buildroot}/usr LIBDIR=%{buildroot}%{_libdir}
desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1} desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
install -D -m644 debian/%{name}.xpm %{buildroot}/%{_datadir}/pixmaps/%{name}.xpm install -D -m644 debian/%{name}.xpm %{buildroot}/%{_datadir}/pixmaps/%{name}.xpm
install -D -m644 debian/pdfshow.1 %{buildroot}/%{_mandir}/man1/%{name}.1
install -D -m644 debian/pdfshow.1 %{buildroot}/%{_mandir}/man1/pdfshow.1
install -D -m644 debian/pdfdraw.1 %{buildroot}/%{_mandir}/man1/pdfdraw.1
install -D -m644 debian/pdfclean.1 %{buildroot}/%{_mandir}/man1/pdfclean.1
## fix strange permissons ## fix strange permissons
chmod 0644 %{buildroot}/%{_includedir}/%{name}.h chmod 0644 %{buildroot}/%{_includedir}/%{name}.h
chmod 0644 %{buildroot}/%{_includedir}/fitz.h chmod 0644 %{buildroot}/%{_includedir}/fitz.h
chmod 0644 %{buildroot}%{_libdir}/libmupdf.a chmod 0644 %{buildroot}%{_libdir}/libmupdf.a
find %{buildroot}/%{_mandir} -type f -exec chmod 0644 {} \;
%post %post
update-desktop-database &> /dev/null || : update-desktop-database &> /dev/null || :
@ -91,27 +83,27 @@ update-desktop-database &> /dev/null || :
%{_libdir}/libmupdf.a %{_libdir}/libmupdf.a
%changelog %changelog
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-8 * Sun Mar 27 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 0.8.15-1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild - New upstream release
* Tue Feb 9 2011 Pavel Zhukov <pavel@zhukoff.net> - 0.7-7 * Tue Feb 9 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 0.7-7
- Fix dependency for F13 - Fix dependency for F13
* Sun Feb 7 2011 Pavel Zhukov <pavel@zhukoff.net> - 0.7-6 * Sun Feb 7 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 0.7-6
- roll back to static libraries patch for shared libs has been rejected - roll back to static libraries patch for shared libs has been rejected
- Fix spec errors - Fix spec errors
* Fri Jan 14 2011 Pavel Zhukov <pavel@zhukoff.net> - 0.7-4 * Fri Jan 14 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 0.7-4
- replac poitless macros to command names - replac poitless macros to command names
* Fri Jan 14 2011 Pavel Zhukov <pavel@zhukoff.net> - 0.7-3 * Fri Jan 14 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 0.7-3
- Create patch for optflags - Create patch for optflags
- Change Summary - Change Summary
- Fix Require for devel package - Fix Require for devel package
* Thu Jan 13 2011 Pavel Zhukov <pavel@zhukoff.net> -0.7-2 * Thu Jan 13 2011 Pavel Zhukov <landgraf@fedoraproject.org> -0.7-2
- add Fedora CFLAGS - add Fedora CFLAGS
- create patch for use shared library - create patch for use shared library
* Wed Jan 12 2011 Pavel Zhukov <pavel@zhukoff.net> - 0.7-1 * Wed Jan 12 2011 Pavel Zhukov <landgraf@fedoraproject.org> - 0.7-1
- Initial package - Initial package

View File

@ -1 +1 @@
83adc4d14eb17835df791a9a0d1e8fa9 mupdf-0.7.tar.gz ba6159fab82999599d36534cda07957f mupdf-0.8.15-source.tar.gz