Updated to version 0.36.0.
This commit is contained in:
parent
200a8ce750
commit
d771e5e4d9
@ -1,64 +0,0 @@
|
||||
From 985655ebfd77ceddc44d76f8cc6dc446002f34ee Mon Sep 17 00:00:00 2001
|
||||
From: Christoph Heinrich <christoph.heinrich@student.tugraz.at>
|
||||
Date: Fri, 3 Mar 2023 00:45:45 +0100
|
||||
Subject: [PATCH 1/2] ytdl_hook: init fragment requires other fragments
|
||||
|
||||
With dash the first fragment was always considered an init fragment if
|
||||
there wasn't a duration. However that only makes sense when there are
|
||||
also other fragments, so check if there are other fragments in addition
|
||||
to the lack of a duration.
|
||||
---
|
||||
player/lua/ytdl_hook.lua | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/player/lua/ytdl_hook.lua b/player/lua/ytdl_hook.lua
|
||||
index 27e5f4544b2..9e50b3a80b8 100644
|
||||
--- a/player/lua/ytdl_hook.lua
|
||||
+++ b/player/lua/ytdl_hook.lua
|
||||
@@ -297,7 +297,7 @@ local function edl_track_joined(fragments, protocol, is_live, base)
|
||||
local args = ""
|
||||
|
||||
-- assume MP4 DASH initialization segment
|
||||
- if not fragments[1].duration then
|
||||
+ if not fragments[1].duration and #fragments > 1 then
|
||||
msg.debug("Using init segment")
|
||||
args = args .. ",init=" .. edl_escape(join_url(base, fragments[1]))
|
||||
offset = 2
|
||||
|
||||
From a5961ad096b1361a12f836c8b170fc748f46962a Mon Sep 17 00:00:00 2001
|
||||
From: Christoph Heinrich <christoph.heinrich@student.tugraz.at>
|
||||
Date: Fri, 3 Mar 2023 00:50:58 +0100
|
||||
Subject: [PATCH 2/2] ytdl_hook: only log error when no fallback url available
|
||||
|
||||
An error indicates that something doesn't work, but as long as a
|
||||
safe url is available, playback is still expected to work.
|
||||
|
||||
Thus reduce logging level of MP4 DASH without fragments message and
|
||||
add a new error message for when there is no safe url available either.
|
||||
|
||||
Also adds a missing space.
|
||||
---
|
||||
player/lua/ytdl_hook.lua | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/player/lua/ytdl_hook.lua b/player/lua/ytdl_hook.lua
|
||||
index 9e50b3a80b8..77f7446ed22 100644
|
||||
--- a/player/lua/ytdl_hook.lua
|
||||
+++ b/player/lua/ytdl_hook.lua
|
||||
@@ -309,7 +309,7 @@ local function edl_track_joined(fragments, protocol, is_live, base)
|
||||
-- if not available in all, give up.
|
||||
for i = offset, #fragments do
|
||||
if not fragments[i].duration then
|
||||
- msg.error("EDL doesn't support fragments" ..
|
||||
+ msg.verbose("EDL doesn't support fragments " ..
|
||||
"without duration with MP4 DASH")
|
||||
return nil
|
||||
end
|
||||
@@ -423,6 +423,7 @@ local function formats_to_edl(json, formats, use_all_formats)
|
||||
track.protocol, json.is_live,
|
||||
track.fragment_base_url)
|
||||
if not edl_track and not url_is_safe(track.url) then
|
||||
+ msg.error("No safe URL or supported fragmented stream available")
|
||||
return nil
|
||||
end
|
||||
|
24
mpv.spec
24
mpv.spec
@ -1,15 +1,12 @@
|
||||
Name: mpv
|
||||
Version: 0.35.1
|
||||
Release: 3%{?dist}
|
||||
Version: 0.36.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
License: GPL-2.0-or-later AND LGPL-2.1-or-later
|
||||
Summary: Movie player playing most video formats and DVDs
|
||||
URL: https://%{name}.io/
|
||||
Source0: https://github.com/%{name}-player/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
# https://github.com/mpv-player/mpv/pull/11398
|
||||
Patch100: %{name}-0.35.1-yt-dlp-hook-fix.patch
|
||||
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libappstream-glib
|
||||
@ -31,11 +28,11 @@ BuildRequires: pkgconfig(jack)
|
||||
BuildRequires: pkgconfig(lcms2)
|
||||
BuildRequires: pkgconfig(libarchive) >= 3.4.0
|
||||
BuildRequires: pkgconfig(libass)
|
||||
BuildRequires: pkgconfig(libavcodec) >= 58.16.100
|
||||
BuildRequires: pkgconfig(libavdevice) >= 57.0.0
|
||||
BuildRequires: pkgconfig(libavfilter) >= 7.14.100
|
||||
BuildRequires: pkgconfig(libavformat) >= 58.9.100
|
||||
BuildRequires: pkgconfig(libavutil) >= 56.12.100
|
||||
BuildRequires: pkgconfig(libavcodec) >= 59.27.100
|
||||
BuildRequires: pkgconfig(libavdevice) >= 58.13.100
|
||||
BuildRequires: pkgconfig(libavfilter) >= 7.110.100
|
||||
BuildRequires: pkgconfig(libavformat) >= 59.24.100
|
||||
BuildRequires: pkgconfig(libavutil) >= 57.24.100
|
||||
BuildRequires: pkgconfig(libbluray)
|
||||
BuildRequires: pkgconfig(libcdio)
|
||||
BuildRequires: pkgconfig(libcdio_paranoia)
|
||||
@ -47,8 +44,8 @@ BuildRequires: pkgconfig(libpipewire-0.3) >= 0.3.19
|
||||
# mpv 0.35 doesn't build with libplacebo 6
|
||||
BuildRequires: (pkgconfig(libplacebo) >= 5 with pkgconfig(libplacebo) < 6)
|
||||
BuildRequires: pkgconfig(libpulse)
|
||||
BuildRequires: pkgconfig(libswresample) >= 3.0.100
|
||||
BuildRequires: pkgconfig(libswscale) >= 5.0.101
|
||||
BuildRequires: pkgconfig(libswresample) >= 3.9.100
|
||||
BuildRequires: pkgconfig(libswscale) >= 5.9.100
|
||||
BuildRequires: pkgconfig(libva)
|
||||
BuildRequires: pkgconfig(lua-5.1)
|
||||
BuildRequires: pkgconfig(mujs)
|
||||
@ -180,6 +177,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
|
||||
%changelog
|
||||
* Wed May 01 2024 Vitaly Zaitsev <vitaly@easycoding.org> - 0.36.0-1
|
||||
- Updated to version 0.36.0.
|
||||
|
||||
* Fri Feb 16 2024 Carl George <carlwgeorge@fedoraproject.org> - 0.35.1-3
|
||||
- Rebuild against libplacebo5 rhbz#2264138
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mpv-0.35.1.tar.gz) = 42f3564a9ed4d972d14b2c697b0163f06a8bb68a0606a86c34935181247c783e3cb62286b445799998def0919fb13fce8b8f6453f82652d5bfaea5929119127a
|
||||
SHA512 (mpv-0.36.0.tar.gz) = 51f455a425ea5aac47acb3582d0f958a34248a2290a8d6887d22bcb9385fe8d1ab5d7f09d5408cfecfb73c1ec85d1b8ec8958e45a4941d3f711a2e580187472f
|
||||
|
Loading…
Reference in New Issue
Block a user