Update to 3.2
This commit is contained in:
parent
1c9aa428a9
commit
d1255a163e
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/mpich-3.0.4.tar.gz
|
||||
/mpich-3.1.tar.gz
|
||||
/mpich-3.1.4.tar.gz
|
||||
/mpich-3.2.tar.gz
|
||||
|
32
0001-pm-remshell-include-MPL-when-linking.patch
Normal file
32
0001-pm-remshell-include-MPL-when-linking.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From d3d7f0d571607c3547396045093c77364cfaec0b Mon Sep 17 00:00:00 2001
|
||||
From: Ken Raffenetti <raffenet@mcs.anl.gov>
|
||||
Date: Fri, 28 Aug 2015 14:28:37 -0700
|
||||
Subject: [PATCH] pm/remshell: include MPL when linking
|
||||
|
||||
---
|
||||
src/pm/remshell/Makefile.mk | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/pm/remshell/Makefile.mk b/src/pm/remshell/Makefile.mk
|
||||
index ea366a9e..0ec937d9 100644
|
||||
--- a/src/pm/remshell/Makefile.mk
|
||||
+++ b/src/pm/remshell/Makefile.mk
|
||||
@@ -16,13 +16,13 @@ if BUILD_PM_REMSHELL
|
||||
if PRIMARY_PM_REMSHELL
|
||||
bin_PROGRAMS += src/pm/remshell/mpiexec
|
||||
src_pm_remshell_mpiexec_SOURCES = src/pm/remshell/mpiexec.c
|
||||
-src_pm_remshell_mpiexec_LDADD = src/pm/util/libmpiexec.a
|
||||
+src_pm_remshell_mpiexec_LDADD = src/pm/util/libmpiexec.a $(mpllib)
|
||||
# we may not want to add AM_CPPFLAGS for this program
|
||||
src_pm_remshell_mpiexec_CPPFLAGS = $(common_pm_includes) $(AM_CPPFLAGS)
|
||||
else !PRIMARY_PM_REMSHELL
|
||||
bin_PROGRAMS += src/pm/remshell/mpiexec.remshell
|
||||
src_pm_remshell_mpiexec_remshell_SOURCES = src/pm/remshell/mpiexec.c
|
||||
-src_pm_remshell_mpiexec_remshell_LDADD = src/pm/util/libmpiexec.a
|
||||
+src_pm_remshell_mpiexec_remshell_LDADD = src/pm/util/libmpiexec.a $(mpllib)
|
||||
# we may not want to add AM_CPPFLAGS for this program
|
||||
src_pm_remshell_mpiexec_remshell_CPPFLAGS = $(common_pm_includes) $(AM_CPPFLAGS)
|
||||
endif !PRIMARY_PM_REMSHELL
|
||||
--
|
||||
1.9.1
|
||||
|
13
0002-pm-gforker-include-MPL-when-linking.patch
Normal file
13
0002-pm-gforker-include-MPL-when-linking.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git mpich-3.2/src/pm/gforker/Makefile.mk~ mpich-3.2/src/pm/gforker/Makefile.mk
|
||||
index 3a156057b9..afb7b41a01 100644
|
||||
--- mpich-3.2/src/pm/gforker/Makefile.mk~
|
||||
+++ mpich-3.2/src/pm/gforker/Makefile.mk
|
||||
@@ -22,7 +22,7 @@ src_pm_gforker_mpiexec_CPPFLAGS = $(common_pm_includes) $(AM_CPPFLAGS)
|
||||
else !PRIMARY_PM_GFORKER
|
||||
bin_PROGRAMS += src/pm/gforker/mpiexec.gforker
|
||||
src_pm_gforker_mpiexec_gforker_SOURCES = src/pm/gforker/mpiexec.c
|
||||
-src_pm_gforker_mpiexec_gforker_LDADD = src/pm/util/libmpiexec.a
|
||||
+src_pm_gforker_mpiexec_gforker_LDADD = src/pm/util/libmpiexec.a $(mpllib)
|
||||
# we may not want to add AM_CPPFLAGS for this program
|
||||
src_pm_gforker_mpiexec_gforker_CPPFLAGS = $(common_pm_includes) $(AM_CPPFLAGS)
|
||||
endif !PRIMARY_PM_GFORKER
|
@ -1,5 +1,5 @@
|
||||
--- src/packaging/envmods/mpich.module.in 2015-02-20 15:48:13.000000000 -0500
|
||||
+++ src/packaging/envmods/mpich.module.in.new 2015-08-27 15:27:43.667837212 -0400
|
||||
--- a/src/packaging/envmods/mpich.module.in 2015-02-20 15:48:13.000000000 -0500
|
||||
+++ b/src/packaging/envmods/mpich.module.in.new 2015-08-27 15:27:43.667837212 -0400
|
||||
@@ -3,12 +3,23 @@
|
||||
# MPICH module for use with 'environment-modules' package:
|
||||
#
|
||||
|
12
mpich.spec
12
mpich.spec
@ -1,7 +1,7 @@
|
||||
Summary: A high-performance implementation of MPI
|
||||
Name: mpich
|
||||
Version: 3.1.4
|
||||
Release: 9%{?dist}
|
||||
Version: 3.2
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
Group: Development/Libraries
|
||||
URL: http://www.mpich.org/
|
||||
@ -11,6 +11,8 @@ Source1: mpich.macros
|
||||
Source2: mpich.pth.py2
|
||||
Source3: mpich.pth.py3
|
||||
Patch0: mpich-modules.patch
|
||||
Patch1: https://trac.mpich.org/projects/mpich/raw-attachment/ticket/2299/0001-pm-remshell-include-MPL-when-linking.patch
|
||||
Patch2: 0002-pm-gforker-include-MPL-when-linking.patch
|
||||
|
||||
BuildRequires: gcc-gfortran
|
||||
BuildRequires: hwloc-devel >= 1.8
|
||||
@ -21,6 +23,7 @@ BuildRequires: valgrind-devel
|
||||
BuildRequires: python2-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: rpm-mpi-hooks
|
||||
BuildRequires: automake
|
||||
Provides: mpi
|
||||
Provides: mpich2 = 3.0.1
|
||||
Obsoletes: mpich2 < 3.0
|
||||
@ -115,7 +118,7 @@ Contains documentations, examples and man-pages for mpich
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -p0
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
@ -237,6 +240,9 @@ make check VERBOSE=1
|
||||
%{_datadir}/%{name}/doc/
|
||||
|
||||
%changelog
|
||||
* Tue Dec 1 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 3.2-1
|
||||
- Update to latest version
|
||||
|
||||
* Mon Nov 16 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 3.1.4-9
|
||||
- Update requires and fix MPI_FORTRAN_MOD_DIR var
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user