35 lines
967 B
Diff
35 lines
967 B
Diff
From: Laszlo Boszormenyi (GCS) <gcs@debian.org>
|
|
Date: Fri, 02 May 2014 22:20:45 +0200
|
|
Subject: fix soname
|
|
|
|
Add soname switch to linker, regardless of Operating System
|
|
|
|
Bug-Debian: http://bugs.debian.org/746705
|
|
---
|
|
config/rules.mk | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
Index: mozjs52-52.2.1~artful1/config/rules.mk
|
|
===================================================================
|
|
--- mozjs52-52.2.1~artful1.orig/config/rules.mk
|
|
+++ mozjs52-52.2.1~artful1/config/rules.mk
|
|
@@ -418,7 +418,7 @@ endif # AIX
|
|
#
|
|
# Linux: add -Bsymbolic flag for components
|
|
#
|
|
-ifeq ($(OS_ARCH),Linux)
|
|
+#ifeq ($(OS_ARCH),Linux)
|
|
ifdef IS_COMPONENT
|
|
EXTRA_DSO_LDOPTS += -Wl,-Bsymbolic
|
|
endif
|
|
@@ -426,7 +426,8 @@ ifdef LD_VERSION_SCRIPT
|
|
EXTRA_DSO_LDOPTS += -Wl,--version-script,$(LD_VERSION_SCRIPT)
|
|
EXTRA_DEPS += $(LD_VERSION_SCRIPT)
|
|
endif
|
|
-endif
|
|
+#endif
|
|
+EXTRA_DSO_LDOPTS += -Wl,-soname,lib$(JS_LIBRARY_NAME).so.0
|
|
|
|
ifdef SYMBOLS_FILE
|
|
ifeq ($(OS_TARGET),WINNT)
|