Merge remote-tracking branch 'up/main' into main-riscv64

Signed-off-by: David Abdurachmanov <davidlt@rivosinc.com>
This commit is contained in:
David Abdurachmanov 2024-08-01 09:54:21 +03:00
commit b141170f5b
Signed by: davidlt
GPG Key ID: 7A5F42FAF91FACC3
5 changed files with 85 additions and 16 deletions

2
.gitignore vendored
View File

@ -3,3 +3,5 @@
/firefox-115.3.0esr.source.tar.xz
/firefox-115.3.1esr.source.tar.xz
/firefox-115.6.0esr.source.tar.xz
/firefox-115.7.0esr.source.tar.xz
/firefox-115.12.0esr.source.tar.xz

View File

@ -1,8 +1,43 @@
non262/Intl/available-locales-supported.js
non262/Intl/available-locales-resolved.js
non262/Intl/supportedValuesOf-timeZones-canonical.js
non262/Intl/available-locales-supported.js
non262/Intl/Collator/big5han-gb2312han.js
non262/Intl/Collator/implicithan.js
non262/Intl/DateTimeFormat/fractional-second-digits-append-item.js
non262/Intl/DateTimeFormat/day-period-hour-cycle.js
non262/Intl/DateTimeFormat/timeZone_backzone.js
non262/Intl/DateTimeFormat/fractional-second-digits-append-item.js
non262/Intl/DateTimeFormat/related-year.js
non262/Intl/DateTimeFormat/timeZone_backzone.js
non262/Intl/DateTimeFormat/timeZone_version.js
non262/Intl/DisplayNames/calendar.js
non262/Intl/DisplayNames/currency.js
non262/Intl/DisplayNames/language-dialect.js
non262/Intl/ListFormat/conjunction-type.js
non262/Intl/Locale/likely-subtags-generated.js
non262/Intl/Locale/likely-subtags.js
non262/Intl/supportedValuesOf-timeZones-canonical.js
non262/Intl/supportedValuesOf-timeZones.js
test262/built-ins/RegExp/property-escapes/generated/Alphabetic.js
test262/built-ins/RegExp/property-escapes/generated/Assigned.js
test262/built-ins/RegExp/property-escapes/generated/General_Category_-_Letter.js
test262/built-ins/RegExp/property-escapes/generated/General_Category_-_Other_Letter.js
test262/built-ins/RegExp/property-escapes/generated/General_Category_-_Other_Symbol.js
test262/built-ins/RegExp/property-escapes/generated/General_Category_-_Other.js
test262/built-ins/RegExp/property-escapes/generated/General_Category_-_Symbol.js
test262/built-ins/RegExp/property-escapes/generated/General_Category_-_Unassigned.js
test262/built-ins/RegExp/property-escapes/generated/Grapheme_Base.js
test262/built-ins/RegExp/property-escapes/generated/ID_Continue.js
test262/built-ins/RegExp/property-escapes/generated/ID_Start.js
test262/built-ins/RegExp/property-escapes/generated/Ideographic.js
test262/built-ins/RegExp/property-escapes/generated/IDS_Binary_Operator.js
test262/built-ins/RegExp/property-escapes/generated/Script_-_Common.js
test262/built-ins/RegExp/property-escapes/generated/Script_-_Han.js
test262/built-ins/RegExp/property-escapes/generated/Script_Extensions_-_Common.js
test262/built-ins/RegExp/property-escapes/generated/Script_Extensions_-_Han.js
test262/built-ins/RegExp/property-escapes/generated/Script_Extensions_-_Malayalam.js
test262/built-ins/RegExp/property-escapes/generated/Script_Extensions_-_Sharada.js
test262/built-ins/RegExp/property-escapes/generated/Script_Extensions_-_Sinhala.js
test262/built-ins/RegExp/property-escapes/generated/Sentence_Terminal.js
test262/built-ins/RegExp/property-escapes/generated/Unified_Ideograph.js
test262/built-ins/RegExp/property-escapes/generated/XID_Continue.js
test262/built-ins/RegExp/property-escapes/generated/XID_Start.js
test262/intl402/Intl/supportedValuesOf/timeZones-accepted-by-DateTimeFormat.js
test262/intl402/Locale/likely-subtags.js

View File

@ -26,7 +26,7 @@
%endif
Name: mozjs%{major}
Version: 115.6.0
Version: 115.12.0
Release: %autorelease -e 0.riscv64
Summary: SpiderMonkey JavaScript library
@ -63,6 +63,9 @@ Patch20: spidermonkey_checks_disable.patch
# s390x/ppc64 fixes
Patch21: 0001-Skip-failing-tests-on-ppc64-and-s390x.patch
# Tests Fixes
Patch30: tests-Replace-pipes-with-shlex-for-Python-3.13.patch
BuildRequires: cargo
%if !0%{?rhel}
BuildRequires: ccache
@ -103,10 +106,7 @@ The %{name}-devel package contains libraries and header files for
developing applications that use %{name}.
%prep
%autosetup -n firefox-%{version}/js/src -N
pushd ../..
%autopatch -p1
%autosetup -n firefox-%{version} -p1
# Purge the bundled six library incompatible with Python 3.12
rm third_party/python/six/six.py
@ -128,8 +128,6 @@ rm -rf js/src/devtools/automation/variants/
rm -rf js/src/octane/
rm -rf js/src/ctypes/libffi/
popd
%build
%if 0%{?build_with_lto}
# https://github.com/ptomato/mozjs/commit/36bb7982b41e0ef9a65f7174252ab996cd6777bd
@ -139,11 +137,11 @@ export CARGO_PROFILE_RELEASE_LTO=true
# Use bundled autoconf
export M4=m4
export AWK=awk
export AC_MACRODIR=/builddir/build/BUILD/firefox-%{version}/build/autoconf/
export AC_MACRODIR=./build/autoconf/
pushd js/src/
#sh ../../build/autoconf/autoconf.sh --localdir=/builddir/build/BUILD/firefox-%%{version}/js/src configure.in > configure
#chmod +x configure
%configure \
--with-system-icu \
--with-system-zlib \
@ -160,6 +158,7 @@ export AC_MACRODIR=/builddir/build/BUILD/firefox-%{version}/build/autoconf/
%make_build
%install
pushd js/src/
%make_install
# Fix permissions
@ -213,6 +212,7 @@ ln -s libmozjs-%{major}.so.0.0.0 %{buildroot}%{_libdir}/libmozjs-%{major}.so.0
ln -s libmozjs-%{major}.so.0 %{buildroot}%{_libdir}/libmozjs-%{major}.so
%check
pushd js/src/
# Run SpiderMonkey tests
%if 0%{?require_tests}
%{python3} tests/jstests.py -d -s -t 2400 --exclude-file=known_failures.txt --no-progress --wpt=disabled ../../js/src/dist/bin/js%{major}
@ -235,8 +235,8 @@ ln -s libmozjs-%{major}.so.0 %{buildroot}%{_libdir}/libmozjs-%{major}.so
%endif
%files
%doc README.html
%license LICENSE
%doc js/src/README.html
%license js/src/LICENSE
%{_libdir}/libmozjs-%{major}.so.0*
%files devel

View File

@ -1 +1 @@
SHA512 (firefox-115.6.0esr.source.tar.xz) = 9fe23b5f715e35b788d9c8fefe6b7be8785789b4ae6f5649b05a54221934101c6e1b9580319145f9bcaebfbd00fcc33e97afb63f7d57ba102a6b02c874d324af
SHA512 (firefox-115.12.0esr.source.tar.xz) = d98475061d870e0f3aa920b7c0b9b0c1cbdb3f4102f760f1d1c5ea3e45e216c673c8d3662501e7e78af4950a003a519e94b57e9b1eda8d615c159cdf62130e89

View File

@ -0,0 +1,32 @@
From dae1848488117166227b00cd7dcadf704b770339 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Franti=C5=A1ek=20Zatloukal?= <fzatlouk@redhat.com>
Date: Wed, 12 Jun 2024 15:56:03 +0200
Subject: [PATCH] tests: Replace pipes with shlex for Python 3.13
---
js/src/tests/lib/results.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/js/src/tests/lib/results.py b/js/src/tests/lib/results.py
index f902060..ba0c7c6 100644
--- a/js/src/tests/lib/results.py
+++ b/js/src/tests/lib/results.py
@@ -1,5 +1,5 @@
import json
-import pipes
+import shlex
import re
from .progressbar import NullProgressBar, ProgressBar
@@ -9,7 +9,7 @@ from .structuredlog import TestLogger
def escape_cmdline(args):
- return " ".join([pipes.quote(a) for a in args])
+ return " ".join([shlex.quote(a) for a in args])
class TestOutput:
--
2.45.1