mozjs102-102.2.0
This commit is contained in:
parent
0327febaca
commit
780f29809b
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/firefox-102.1.0esr.source.tar.xz
|
||||
/firefox-102.2.0esr.source.tar.xz
|
||||
|
18
D152549.diff
18
D152549.diff
@ -1,18 +0,0 @@
|
||||
diff --git a/js/src/build/Makefile.in b/js/src/build/Makefile.in
|
||||
--- a/js/src/build/Makefile.in
|
||||
+++ b/js/src/build/Makefile.in
|
||||
@@ -29,10 +29,13 @@
|
||||
$(SYSINSTALL) $(JS_LIBRARY_NAME).pc $(DESTDIR)$(libdir)/pkgconfig
|
||||
|
||||
install:: ../js-config.h
|
||||
$(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(JS_LIBRARY_NAME)
|
||||
|
||||
+install:: ../../../mozglue/baseprofiler/public/ProfilingCategoryList.h
|
||||
+ $(SYSINSTALL) $^ $(DESTDIR)$(includedir)/$(JS_LIBRARY_NAME)/js
|
||||
+
|
||||
######################################################
|
||||
# BEGIN SpiderMonkey header installation
|
||||
#
|
||||
# Mozilla/Gecko/Firefox mostly doesn't concern itself with defining a sensible
|
||||
# install target, because it's shipping primarily packaged builds. And even if
|
||||
|
17
D152556.diff
17
D152556.diff
@ -1,17 +0,0 @@
|
||||
diff --git a/js/public/Debug.h b/js/public/Debug.h
|
||||
--- a/js/public/Debug.h
|
||||
+++ b/js/public/Debug.h
|
||||
@@ -137,11 +137,11 @@
|
||||
js::Debugger* debugger;
|
||||
|
||||
// Check that |thing| is in the same compartment as our debuggerObject. Used
|
||||
// for assertions when constructing BuiltThings. We can overload this as we
|
||||
// add more instantiations of BuiltThing.
|
||||
-#if DEBUG
|
||||
+#ifdef DEBUG
|
||||
void assertBuilt(JSObject* obj);
|
||||
#else
|
||||
void assertBuilt(JSObject* obj) {}
|
||||
#endif
|
||||
|
||||
|
@ -18,7 +18,7 @@
|
||||
%endif
|
||||
|
||||
Name: mozjs%{major}
|
||||
Version: 102.1.0
|
||||
Version: 102.2.0
|
||||
Release: 1%{?dist}
|
||||
Summary: SpiderMonkey JavaScript library
|
||||
|
||||
@ -44,9 +44,6 @@ Patch13: tests-Use-native-TemporaryDirectory.patch
|
||||
Patch14: init_patch.patch
|
||||
Patch15: remove-sloppy-m4-detection-from-bundled-autoconf.patch
|
||||
Patch16: 0001-Python-Build-Use-r-instead-of-rU-file-read-modes.patch
|
||||
# These two should get uplifted into the next esr
|
||||
Patch17: D152556.diff
|
||||
Patch18: D152549.diff
|
||||
|
||||
# TODO: Check with mozilla for cause of these fails and re-enable spidermonkey compile time checks if needed
|
||||
Patch20: spidermonkey_checks_disable.patch
|
||||
@ -229,5 +226,8 @@ ln -s libmozjs-%{major}.so.0 %{buildroot}%{_libdir}/libmozjs-%{major}.so
|
||||
%{_includedir}/mozjs-%{major}/
|
||||
|
||||
%changelog
|
||||
* Mon Aug 22 2022 Frantisek Zatloukal <fzatlouk@redhat.com> - 102.2.0-1
|
||||
- mozjs102-102.2.0
|
||||
|
||||
* Wed Jul 27 2022 Frantisek Zatloukal <fzatlouk@redhat.com> - 102.1.0-1
|
||||
- Initial mozjs102 package based on mozjs91
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (firefox-102.1.0esr.source.tar.xz) = 2505b87ce4115445568eb6b7d8af41678bd787fd07f3f79e9f0a22d90cdf752ae5d4371856cf9c56e2d9da7d5b7c3939dc2aab5753fcc017398e7d65260f6f03
|
||||
SHA512 (firefox-102.2.0esr.source.tar.xz) = 06d753867ccfe1b2c79148cc60bc816b47a2abfa98219808868e9028bef1763d982ef7012698d06b8959cce79163d7926baf5f9d5ca9daa18c51fbf0efc59993
|
||||
|
Loading…
Reference in New Issue
Block a user