106 lines
3.8 KiB
Diff
106 lines
3.8 KiB
Diff
|
|
Index: mono-1.1.16/scripts/Makefile.am
|
|
===================================================================
|
|
--- mono-1.1.16.orig/scripts/Makefile.am
|
|
+++ mono-1.1.16/scripts/Makefile.am
|
|
@@ -80,7 +80,7 @@ plat_bindir = $(shell cygpath -m $(libdi
|
|
mono_instdir = $(shell cygpath -m $(libdir))/mono
|
|
else
|
|
plat_bindir = $(bindir)
|
|
-mono_instdir = $(prefix)/lib/mono
|
|
+mono_instdir = $(libdir)/mono
|
|
endif
|
|
|
|
REWRITE_COMMON = sed \
|
|
Index: mono-1.1.16/scripts/mono-nunit.pc.in
|
|
===================================================================
|
|
--- mono-1.1.16.orig/scripts/mono-nunit.pc.in
|
|
+++ mono-1.1.16/scripts/mono-nunit.pc.in
|
|
@@ -1,6 +1,6 @@
|
|
prefix=${pcfiledir}/../..
|
|
exec_prefix=${prefix}
|
|
-libdir=${exec_prefix}/lib
|
|
+libdir=${exec_prefix}/@reloc_libdir@
|
|
|
|
|
|
Name: Mono NUnit
|
|
|
|
|
|
|
|
Index: mono-1.1.16/mcs/tools/cilc/res-Makefile
|
|
===================================================================
|
|
--- mono-1.1.16.orig/mcs/tools/cilc/res-Makefile
|
|
+++ mono-1.1.16/mcs/tools/cilc/res-Makefile
|
|
@@ -2,7 +2,7 @@ include defs.mk
|
|
|
|
LIBNAME = $(shell echo $(basename $(SONAME)) | sed -e 's/^lib//')
|
|
HTARGET = $(prefix)/include/$(LIBNAME)/
|
|
-LIBTARGET = $(prefix)/lib/
|
|
+LIBTARGET = $(libdir)
|
|
|
|
CFLAGS += -static -fpic $(shell pkg-config --cflags glib-2.0 gobject-2.0 mono) $(EXTRAINCLUDES) -I.
|
|
|
|
--- mono-1.1.16.1/mono/metadata/assembly.c.libdir 2006-08-17 17:52:42.000000000 +0200
|
|
+++ mono-1.1.16.1/mono/metadata/assembly.c 2006-08-17 17:56:21.000000000 +0200
|
|
@@ -521,7 +521,7 @@
|
|
}
|
|
|
|
config = g_build_filename (base, "etc", NULL);
|
|
- lib = g_build_filename (base, "lib", NULL);
|
|
+ lib = g_build_filename (base, MONO_RELOC_LIBDIR, NULL);
|
|
mono = g_build_filename (lib, "mono/1.0", NULL);
|
|
if (stat (mono, &buf) == -1)
|
|
fallback ();
|
|
@@ -1844,7 +1844,7 @@
|
|
if (extra_gac_paths) {
|
|
paths = extra_gac_paths;
|
|
while (!res && *paths) {
|
|
- gacpath = g_build_path (G_DIR_SEPARATOR_S, *paths, "lib", "mono", "gac", aname->name, NULL);
|
|
+ gacpath = g_build_path (G_DIR_SEPARATOR_S, *paths, MONO_RELOC_LIBDIR, "mono", "gac", aname->name, NULL);
|
|
res = probe_for_partial_name (gacpath, fullname, aname, status);
|
|
g_free (gacpath);
|
|
paths++;
|
|
@@ -1908,7 +1908,7 @@
|
|
paths = extra_gac_paths;
|
|
while (!image && *paths) {
|
|
fullpath = g_build_path (G_DIR_SEPARATOR_S, *paths,
|
|
- "lib", "mono", "gac", subpath, NULL);
|
|
+ MONO_RELOC_LIBDIR, "mono", "gac", subpath, NULL);
|
|
image = mono_image_open (fullpath, NULL);
|
|
g_free (fullpath);
|
|
paths++;
|
|
@@ -2058,7 +2058,7 @@
|
|
if (extra_gac_paths) {
|
|
paths = extra_gac_paths;
|
|
while (!result && *paths) {
|
|
- fullpath = g_build_path (G_DIR_SEPARATOR_S, *paths, "lib", "mono", "gac", subpath, NULL);
|
|
+ fullpath = g_build_path (G_DIR_SEPARATOR_S, *paths, MONO_RELOC_LIBDIR, "mono", "gac", subpath, NULL);
|
|
result = mono_assembly_open_full (fullpath, status, refonly);
|
|
g_free (fullpath);
|
|
paths++;
|
|
--- mono-1.1.16.1/mcs/tools/gacutil/driver.cs.libdir 2006-08-17 15:40:14.000000000 +0200
|
|
+++ mono-1.1.16.1/mcs/tools/gacutil/driver.cs 2006-08-17 15:40:19.000000000 +0200
|
|
@@ -667,7 +667,7 @@
|
|
private static string EnsureLib (string dir)
|
|
{
|
|
DirectoryInfo d = new DirectoryInfo (dir);
|
|
- if (d.Name == "lib")
|
|
+ if (d.Name == "lib" || d.Name == "lib64")
|
|
return dir;
|
|
return Path.Combine (dir, "lib");
|
|
}
|
|
--- mono-1.1.16.1/mcs/class/Microsoft.Build.Utilities/Mono.XBuild.Utilities/MonoLocationHelper.cs.libdir 2006-08-17 15:46:11.000000000 +0200
|
|
+++ mono-1.1.16.1/mcs/class/Microsoft.Build.Utilities/Mono.XBuild.Utilities/MonoLocationHelper.cs 2006-08-17 15:46:53.000000000 +0200
|
|
@@ -53,10 +53,10 @@
|
|
xbuildDir = Path.Combine (t2.FullName, "xbuild");
|
|
// /usr/local/lib
|
|
t3 = t2.Parent;
|
|
+ libDir = t3.FullName;
|
|
// /usr/local
|
|
t4 = t3.Parent;
|
|
binDir = Path.Combine (t4.FullName, "bin");
|
|
- libDir = Path.Combine (t4.FullName, "lib");
|
|
}
|
|
|
|
public static string GetBinDir ()
|