7b913323af
Probably a pile of other stuff I've forgotten as well!
21 lines
913 B
Diff
21 lines
913 B
Diff
--- mono-2.0/mono/metadata/Makefile.am 2008-08-03 13:29:57.000000000 +0100
|
|
+++ mono-2.0/mono/metadata/Makefile-new.am 2008-08-03 15:50:47.000000000 +0100
|
|
@@ -9,7 +9,7 @@
|
|
# optimisation is required to actually inline them
|
|
AM_CFLAGS = -O
|
|
else
|
|
-assembliesdir = $(exec_prefix)/lib
|
|
+assembliesdir = $(libdir)
|
|
confdir = $(sysconfdir)
|
|
endif
|
|
|
|
@@ -21,7 +21,7 @@
|
|
#
|
|
noinst_LTLIBRARIES = libmonoruntime.la libmonoruntime-static.la
|
|
|
|
-INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/mono $(LIBGC_CFLAGS) $(GLIB_CFLAGS) -DMONO_BINDIR=\"$(bindir)/\" -DMONO_ASSEMBLIES=\"$(assembliesdir)\" -DMONO_CFG_DIR=\"$(confdir)\"
|
|
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/mono $(LIBGC_CFLAGS) $(GLIB_CFLAGS) $(GMODULE_CFLAGS) -DMONO_BINDIR=\"$(bindir)/\" -DMONO_ASSEMBLIES=\"$(assembliesdir)\" -DMONO_RELOC_LIBDIR=\"$(reloc_libdir)\" -DMONO_CFG_DIR=\"$(confdir)\"
|
|
|
|
#
|
|
# Make sure any prefix changes are updated in the binaries too.
|