fix missing mscorlib

This commit is contained in:
Timotheus Pokorra 2016-02-25 17:06:57 +01:00
parent 426119dc46
commit f5decb830f
2 changed files with 21 additions and 17 deletions

View File

@ -1,25 +1,26 @@
--- a/mcs/class/reference-assemblies/Makefile 2016-02-23 08:28:25.755899731 +0100
+++ b/mcs/class/reference-assemblies/Makefile 2016-02-23 08:28:54.603898383 +0100
@@ -7,22 +7,6 @@
PROFILE_DIR=$(DESTDIR)$(mono_libdir)/mono
install-local:
- $(MKINSTALLDIRS) $(PROFILE_DIR)/2.0-api
- $(MKINSTALLDIRS) $(PROFILE_DIR)/3.5-api
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.0-api
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.5-api
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.5-api/Facades
--- a/mcs/class/reference-assemblies/Makefile 2016-02-25 16:00:37.275529897 +0100
+++ b/mcs/class/reference-assemblies/Makefile 2016-02-25 16:00:48.007529395 +0100
@@ -12,17 +12,17 @@
$(MKINSTALLDIRS) $(PROFILE_DIR)/4.0-api
$(MKINSTALLDIRS) $(PROFILE_DIR)/4.5-api
$(MKINSTALLDIRS) $(PROFILE_DIR)/4.5-api/Facades
- $(INSTALL_LIB) ../../../external/binary-reference-assemblies/v2.0/*.dll $(PROFILE_DIR)/2.0-api
- $(INSTALL_LIB) ../../../external/binary-reference-assemblies/v3.5/*.dll $(PROFILE_DIR)/3.5-api
- $(INSTALL_LIB) ../../../external/binary-reference-assemblies/v4.0/*.dll $(PROFILE_DIR)/4.0-api
- $(INSTALL_LIB) ../../../external/binary-reference-assemblies/v4.5/*.dll $(PROFILE_DIR)/4.5-api
- $(INSTALL_LIB) ../../../external/binary-reference-assemblies/v4.5/Facades/*.dll $(PROFILE_DIR)/4.5-api/Facades
-
- # Unfortunately, a few programs (most notably NUnit) have hardcoded checks for <prefix>/lib/mono/4.0/mscorlib.dll,
- # so we need to place something there or those tools break. We decided to symlink to the reference assembly for now.
- # See https://bugzilla.xamarin.com/show_bug.cgi?id=38331
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.0
+ #$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v2.0/*.dll $(PROFILE_DIR)/2.0-api
+ #$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v3.5/*.dll $(PROFILE_DIR)/3.5-api
+ #$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v4.0/*.dll $(PROFILE_DIR)/4.0-api
+ #$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v4.5/*.dll $(PROFILE_DIR)/4.5-api
+ #$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v4.5/Facades/*.dll $(PROFILE_DIR)/4.5-api/Facades
# Unfortunately, a few programs (most notably NUnit) have hardcoded checks for <prefix>/lib/mono/4.0/mscorlib.dll,
# so we need to place something there or those tools break. We decided to symlink to the reference assembly for now.
# See https://bugzilla.xamarin.com/show_bug.cgi?id=38331
$(MKINSTALLDIRS) $(PROFILE_DIR)/4.0
- ln -sf ../4.0-api/mscorlib.dll $(PROFILE_DIR)/4.0/mscorlib.dll
+ #ln -sf ../4.0-api/mscorlib.dll $(PROFILE_DIR)/4.0/mscorlib.dll
DISTFILES = $(wildcard ../../../external/binary-reference-assemblies/v4.5/Facades/*.dll) $(wildcard ../../../external/binary-reference-assemblies/v4.5/*.dll) $(wildcard ../../../external/binary-reference-assemblies/v4.0/*.dll) $(wildcard ../../../external/binary-reference-assemblies/v3.5/*.dll) $(wildcard ../../../external/binary-reference-assemblies/v2.0/*.dll) Makefile

View File

@ -17,7 +17,7 @@
Name: mono
Version: 4.3.2
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Cross-platform, Open Source, .NET development framework
Group: Development/Languages
@ -752,6 +752,9 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%{_libdir}/pkgconfig/monodoc.pc
%changelog
* Thu Feb 25 2016 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 4.3.2-2
- fix missing mscorlib
* Wed Feb 24 2016 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 4.3.2-1
- update to 4.3.2.467 Cycle 7 Alpha