update to 4.6.0.150 Cycle 8 Beta Preview 1

This commit is contained in:
Timotheus Pokorra 2016-08-24 13:00:15 +02:00
parent 05a8b95988
commit e66e0e68e1
4 changed files with 31 additions and 72 deletions

View File

@ -1,13 +1,11 @@
diff -up mono-4.2.1/mcs/build/library.make.than mono-4.2.1/mcs/build/library.make
diff -up mono-4.2.1/mcs/class/corlib/System/TimeZoneInfo.cs.than mono-4.2.1/mcs/class/corlib/System/TimeZoneInfo.cs
--- mono-4.2.1/mcs/class/corlib/System/TimeZoneInfo.cs.than 2015-11-12 04:00:29.000000000 -0500
+++ mono-4.2.1/mcs/class/corlib/System/TimeZoneInfo.cs 2016-01-18 10:28:29.532781004 -0500
@@ -1150,7 +1150,7 @@ namespace System
try {
return ParseTZBuffer (id, buffer, length);
--- a/mcs/class/corlib/System/TimeZoneInfo.cs 2016-08-23 16:24:24.658169558 +0200
+++ b/mcs/class/corlib/System/TimeZoneInfo.cs 2016-08-23 16:25:22.925434487 +0200
@@ -1224,7 +1224,7 @@
} catch (InvalidTimeZoneException) {
throw;
} catch (Exception e) {
- throw new InvalidTimeZoneException (e.Message);
+ return Utc; //throw new InvalidTimeZoneException (e.Message);
- throw new InvalidTimeZoneException ("Time zone information file contains invalid data", e);
+ return Utc; // throw new InvalidTimeZoneException ("Time zone information file contains invalid data", e);
}
}

View File

@ -1,26 +0,0 @@
diff -up mono-4.2.1/mono/metadata/icall.c.than mono-4.2.1/mono/metadata/icall.c
--- mono-4.2.1/mono/metadata/icall.c.than 2015-11-12 10:00:29.000000000 +0100
+++ mono-4.2.1/mono/metadata/icall.c 2016-01-25 16:36:24.479028169 +0100
@@ -816,14 +816,14 @@ ves_icall_System_Runtime_CompilerService
}
#if G_BYTE_ORDER != G_LITTLE_ENDIAN
-#define SWAP(n) {\
- guint ## n *data = (guint ## n *) mono_array_addr (array, char, 0); \
- guint ## n *src = (guint ## n *) field_data; \
- guint ## n *end = (guint ## n *)((char*)src + size); \
-\
- for (; src < end; data++, src++) { \
- *data = read ## n (src); \
- } \
+#define SWAP(n) { \
+ guint ## n *data = (guint ## n *) mono_array_addr (array, char, 0); \
+ guint ## n *src = (guint ## n *) field_data; \
+ int i, nEnt = (size / sizeof(guint ## n)); \
+ \
+ for (i = 0; i < nEnt; i++) { \
+ data[i] = read ## n (&src[i]); \
+ } \
}
/* printf ("Initialize array with elements of %s type\n", klass->element_class->name); */

View File

@ -15,14 +15,14 @@
%endif
Name: mono
Version: 4.4.2
Release: 3%{?dist}
Version: 4.6.0
Release: 1%{?dist}
Summary: Cross-platform, Open Source, .NET development framework
Group: Development/Languages
License: MIT
URL: http://www.mono-project.com
Source0: http://download.mono-project.com/sources/mono/mono-%{version}.11.tar.bz2
Source0: http://download.mono-project.com/sources/mono/mono-%{version}.150.tar.bz2
# This key was generated by Tom "spot" Callaway <tcallawa@redhat.com> on Dec 1, 2009
# by running the following command:
# sn -k mono.snk
@ -31,9 +31,8 @@ Source1: mono.snk
Patch0: mono-4.0.0-ignore-reference-assemblies.patch
Patch1: mono-4.0.0-libgdiplusconfig.patch
Patch2: mono-4.2.1-ppc.patch
Patch3: mono-4.2.1-s390.patch
Patch4: mono-4.3.2-find-provides.patch
Patch5: mono-4.2-fix-winforms-trayicon.patch
Patch3: mono-4.3.2-find-provides.patch
Patch4: mono-4.2-fix-winforms-trayicon.patch
BuildRequires: bison
BuildRequires: gcc-c++
@ -51,10 +50,8 @@ BuildRequires: zlib-devel
%if 0%{bootstrap}
# for bootstrap, use bundled monolite instead of local mono
# for bootstrap, we build Mono.Cecil from the mono tarball
%else
BuildRequires: mono-core >= 4.0
BuildRequires: mono-cecil
%endif
# JIT only available on these:
@ -276,7 +273,6 @@ Development file for monodoc
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
# Add undeclared Arg
sed -i "61a #define ARG_MAX _POSIX_ARG_MAX" mono/io-layer/wapi_glob.h
@ -293,31 +289,6 @@ find . -name "*.exe" -not -path "./mcs/class/lib/monolite/*" -print -delete
rm -rf mcs/class/lib/monolite/*
%endif
%if 0%{bootstrap}
# for bootstrap, build Mono.Cecil from the mono tarball
%else
# Remove Cecil, use mono-cecil package instead
rm -rf data/cecil.pc*
sed -i "s#data/cecil.pc##g" configure.ac
sed -i "s#data/cecil.pc ##g" configure
sed -i "s#cecil.pc.in ##g;s#cecil.pc ##g" data/Makefile.in
rm -rf external/cecil
rm -rf mcs/class/Mono.Cecil
rm -rf mcs/class/Mono.Cecil.Mdb
sed -i "s/Mono\.Cecil\.Mdb//g;s/Mono\.Cecil//g" mcs/class/Makefile
#avoid error: Metadata file `Mono.Cecil' could not be found; it seems we need an absolute path
sed -i "s#LIB_REFS = System Mono.Cecil System.Core#LIB_REFS = System System.Core#g;s#LIB_MCS_FLAGS =#LIB_MCS_FLAGS = -r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/class/Mono.Debugger.Soft/Makefile
sed -i "s#LIB_REFS = System System.Core Mono.Cecil Mono.Cecil.Mdb#LIB_REFS = System System.Core#g;s#LIB_MCS_FLAGS =#LIB_MCS_FLAGS = -r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll -r:%{_monodir}/Mono.Cecil/Mono.Cecil.Mdb.dll#g" mcs/class/Mono.CodeContracts/Makefile
sed -i "s#\$(topdir)/class/lib/\$(PROFILE)/Mono.Cecil.dll#%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/linker/Makefile
sed -i "s#\$(topdir)/class/lib/\$(PROFILE)/Mono.Cecil.dll#%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/tuner/Makefile
sed -i "s#\$(topdir)/class/lib/\$(PROFILE)/Mono.Cecil.dll#%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/mdoc/Makefile
sed -i "s#-r:Mono.Cecil.dll#-r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/corcompare/Makefile
sed -i "s#-r:Mono.Cecil.dll#-r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/security/Makefile
sed -i "s#/r:Mono.Cecil.dll#-r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/pdb2mdb/Makefile
sed -i "s#/r:Mono.Cecil.dll#-r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/mdoc/Makefile
sed -i "s#/r:Mono.Cecil.dll#-r:%{_monodir}/Mono.Cecil/Mono.Cecil.dll#g" mcs/tools/mono-symbolicate/Makefile
%endif
%build
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
@ -376,6 +347,9 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%{__mv} -f %{buildroot}%{_bindir}/mono-gdb.py \
%{buildroot}%{_datadir}/gdb/auto-load%{_bindir}/
# do not make cecil publicly available. other packages should use the mono-cecil package instead
rm -f %{buildroot}%{_libdir}/pkgconfig/cecil.pc
%find_lang mcs
%post -p /sbin/ldconfig
@ -387,7 +361,7 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%postun devel -p /sbin/ldconfig
%files core -f mcs.lang
%doc COPYING.LIB ChangeLog NEWS README.md
%doc COPYING.LIB NEWS README.md
%{_bindir}/mono
%{_bindir}/mono-test-install
%{_datadir}/gdb/auto-load/*
@ -432,12 +406,14 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%gac_dll Commons.Xml.Relaxng
%gac_dll ICSharpCode.SharpZipLib
%gac_dll Mono.Debugger.Soft
%{_monogacdir}/Mono.Cecil
%gac_dll cscompmgd
%gac_dll Microsoft.VisualC
%gac_dll Mono.Cairo
%gac_dll Mono.CompilerServices.SymbolWriter
%gac_dll Mono.CSharp
%gac_dll System.Drawing
%gac_dll System.Deployment
%gac_dll Mono.Management
%gac_dll Mono.Posix
%gac_dll Mono.Security
@ -505,11 +481,16 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%gac_dll System.Net.Http
%gac_dll System.Net.Http.WebRequest
%gac_dll System.Threading.Tasks.Dataflow
%gac_dll System.Workflow.Activities
%gac_dll System.Workflow.ComponentModel
%gac_dll System.Workflow.Runtime
%files devel
%{_sysconfdir}/pki/mono/
%{_bindir}/mono-api-info
%{_monodir}/4.5/mono-api-info.exe
%{_monodir}/4.5/mono-api-info.exe*
%{_bindir}/mono-api-html
%{_monodir}/4.5/mono-api-html.exe*
%{_monodir}/4.5/linkeranalyzer.exe*
%mono_bin mono-symbolicate
%gac_dll SMDiagnostics
@ -696,6 +677,8 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%gac_dll System.Web.WebPages
%gac_dll System.Web.WebPages.Deployment
%gac_dll System.Web.WebPages.Razor
%gac_dll System.Web.Mobile
%gac_dll System.Web.RegularExpressions
%{_mandir}/man1/disco.1.gz
%{_mandir}/man1/httpcfg.1.gz
%{_mandir}/man1/mconfig.1.gz
@ -786,6 +769,10 @@ mkdir -p %{buildroot}%{_datadir}/gdb/auto-load%{_bindir}
%{_libdir}/pkgconfig/monodoc.pc
%changelog
* Tue Aug 23 2016 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 4.6.0-1
- update to 4.6.0.150 Cycle 8 Beta Preview 1
- use Mono.Cecil from the tarball to build Mono, but do not make it public for other packages
* Tue Aug 16 2016 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 4.4.2-3
- for bootstrap, there is no mono-cecil package, so we have to build Mono.Cecil from the mono tarball

View File

@ -1 +1 @@
bf3248973a518cfd1c82ee8a3e4f64b5 mono-4.4.2.11.tar.bz2
4d0e603b8415bae1f92b006b9b78035b mono-4.6.0.150.tar.bz2