fixed the build failure on s390x/ppc64/ppc64le against new glibc
which drops the tag struct ucontext
This commit is contained in:
parent
d9485c7953
commit
8ee3244241
12
mono-4.8.0.520-glibc-ucontext.patch
Normal file
12
mono-4.8.0.520-glibc-ucontext.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up mono-4.8.0/mono/utils/mono-sigcontext.h.than mono-4.8.0/mono/utils/mono-sigcontext.h
|
||||
--- mono-4.8.0/mono/utils/mono-sigcontext.h.than 2017-09-20 09:47:02.344226028 -0400
|
||||
+++ mono-4.8.0/mono/utils/mono-sigcontext.h 2017-09-20 09:53:16.120785421 -0400
|
||||
@@ -276,7 +276,7 @@ typedef struct ucontext {
|
||||
#endif
|
||||
|
||||
#if defined(__linux__)
|
||||
- typedef struct ucontext os_ucontext;
|
||||
+ typedef ucontext_t os_ucontext;
|
||||
|
||||
#ifdef __mono_ppc64__
|
||||
#define UCONTEXT_REG_Rn(ctx, n) (((os_ucontext*)(ctx))->uc_mcontext.gp_regs [(n)])
|
10
mono.spec
10
mono.spec
@ -16,7 +16,7 @@
|
||||
|
||||
Name: mono
|
||||
Version: 4.8.0
|
||||
Release: 11%{?dist}
|
||||
Release: 12%{?dist}
|
||||
Summary: Cross-platform, Open Source, .NET development framework
|
||||
|
||||
Group: Development/Languages
|
||||
@ -34,6 +34,9 @@ Patch2: mono-4.3.2-find-provides.patch
|
||||
Patch3: mono-4.2-fix-winforms-trayicon.patch
|
||||
Patch4: mono-4.6.0-patch_arm_fast_tls.patch
|
||||
Patch5: mono-4.6.1-aarch64.patch
|
||||
# fix bz#1484151, bz#1484149 due to new glibc which
|
||||
# drops the struct ucontext
|
||||
Patch6: mono-4.8.0.520-glibc-ucontext.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: cmake
|
||||
@ -276,6 +279,7 @@ Development file for monodoc
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
# Add undeclared Arg
|
||||
sed -i "61a #define ARG_MAX _POSIX_ARG_MAX" mono/io-layer/wapi_glob.h
|
||||
@ -790,6 +794,10 @@ rm -f %{buildroot}%{_libdir}/pkgconfig/cecil.pc
|
||||
%{_libdir}/pkgconfig/monodoc.pc
|
||||
|
||||
%changelog
|
||||
* Wed Sep 20 2017 Than Ngo <than@redhat.com> - 4.8.0-12
|
||||
- fixed the build failure on s390x/ppc64/ppc64le against new glibc
|
||||
which drops the tag struct ucontext
|
||||
|
||||
* Sun Aug 27 2017 Ville Skyttä <ville.skytta@iki.fi> - 4.8.0-11
|
||||
- Own dirs in %%{_monodir}/mono-configuration-crypto
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user