Full release Remove 2.6.7.c4 patch Move Build.Utilities.v4 back to core as

that's where it should be!
This commit is contained in:
Paul F. Johnson 2010-07-23 21:44:20 +00:00
parent c296310e02
commit 50c798f018
4 changed files with 12 additions and 59 deletions

View File

@ -6,3 +6,4 @@ mono-2_6_4-1_fc14:HEAD:mono-2.6.4-1.fc14.src.rpm:1272392899
mono-2_6_4-2_fc14:HEAD:mono-2.6.4-2.fc14.src.rpm:1275299763
mono-2_6_4-3_fc14:HEAD:mono-2.6.4-3.fc14.src.rpm:1275856661
mono-2_6_7-1_fc14:HEAD:mono-2.6.7-1.fc14.src.rpm:1279143830
mono-2_6_7-3_fc14:HEAD:mono-2.6.7-3.fc14.src.rpm:1279921391

View File

@ -1,53 +0,0 @@
Index: mcs/class/System.Core/System/TimeZoneInfo.cs
===================================================================
--- mono-2.6.7/mcs/class/System.Core/System/TimeZoneInfo.cs (revision 160268)
+++ mono-2.6.7/mcs/class/System.Core/System/TimeZoneInfo.cs (working copy)
@@ -380,9 +380,22 @@
else
ParseRegTzi(adjustmentRules, 1, 9999, reg_tzi);
- return CreateCustomTimeZone (id, baseUtcOffset, display_name, standard_name, daylight_name, ValidateRules (adjustmentRules).ToArray ());
+ return CreateCustomTimeZone (id, baseUtcOffset, display_name, standard_name, daylight_name,
+ (AdjustmentRule []) ValidateRules (adjustmentRules).ToArray ());
}
+ static List<AdjustmentRule> ValidateRules (List<AdjustmentRule> adjustmentRules)
+ {
+ AdjustmentRule prev = null;
+ foreach (AdjustmentRule current in adjustmentRules.ToArray ()) {
+ if (prev != null && prev.DateEnd > current.DateStart) {
+ adjustmentRules.Remove (current);
+ }
+ prev = current;
+ }
+ return adjustmentRules;
+ }
+
private static void ParseRegTzi (List<AdjustmentRule> adjustmentRules, int start_year, int end_year, byte [] buffer)
{
//int standard_bias = BitConverter.ToInt32 (buffer, 4); /* not sure how to handle this */
@@ -895,22 +908,11 @@
}
return CreateCustomTimeZone (id, baseUtcOffset, id, standardDisplayName);
} else {
- return CreateCustomTimeZone (id, baseUtcOffset, id, standardDisplayName, daylightDisplayName, ValidateRules (adjustmentRules).ToArray ());
+ return CreateCustomTimeZone (id, baseUtcOffset, id, standardDisplayName, daylightDisplayName,
+ (AdjustmentRule []) ValidateRules (adjustmentRules).ToArray ());
}
}
- static List<AdjustmentRule> ValidateRules (List<AdjustmentRule> adjustmentRules)
- {
- AdjustmentRule prev = null;
- foreach (AdjustmentRule current in adjustmentRules.ToArray ()) {
- if (prev != null && prev.DateEnd > current.DateStart) {
- adjustmentRules.Remove (current);
- }
- prev = current;
- }
- return adjustmentRules;
- }
-
static Dictionary<int, string> ParseAbbreviations (byte [] buffer, int index, int count)
{
var abbrevs = new Dictionary<int, string> ();

View File

@ -8,7 +8,7 @@
Name: mono
Version: 2.6.7
Release: 2%{?dist}
Release: 3%{?dist}
Summary: A .NET runtime environment
Group: Development/Languages
@ -56,7 +56,6 @@ Patch4: mono-2.0-monoservice.patch
Patch5: mono-2.6-metadata-makefile.patch
Patch6: mono-242-libgdiplusconfig.patch
Patch7: mono-264-libdir.patch
Patch8: mono-267-c4.patch
%if %{with_mono4}
Obsoletes: mono-mono-4-preview < 2.6.4
@ -329,7 +328,6 @@ Preview for the new C# 4.0 code
%patch6 -p1 -b .libgdiplus
sed -i -e 's!@libdir@!%{_libdir}!' %{PATCH7}
%patch7 -p1 -b .libdir-22
%patch8 -p1 -b .c4
sed -i -e 's!%{_libdir}!@libdir@!' %{PATCH7}
sed -i -e 's!$(prefix)/lib/!%{_libdir}/!' docs/Makefile.{am,in}
sed -i -e 's!${prefix}/lib/!%{_libdir}/!' data/monodoc.pc.in
@ -497,6 +495,10 @@ install -p -m0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/pki/mono/
%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
%{_libdir}/mono-source-libs/
%{monodir}/compat-2.0/System.Web.Mvc.dll
%if %{with_mono4}
%{_libdir}/mono/gac/Microsoft.Build.Tasks.v4.0/4.0*
%{_libdir}/mono/gac/Microsoft.Build.Utilities.v4.0/4.0*
%endif
%files devel
%defattr(-,root,root,-)
@ -799,11 +801,14 @@ install -p -m0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/pki/mono/
%{_libdir}/mono/gac/System.Data.Services/4.0*
%gac_dll System.Dynamic
%{monodir}/4.0/xbuild*
%{_libdir}/mono/gac/Microsoft.Build.Tasks.v4.0/4.0*
%{_libdir}/mono/gac/Microsoft.Build.Utilities.v4.0/4.0*
%endif
%changelog
* Wed Jul 21 2010 Paul F. Johnson <paul@all-the-johnsons.co.uk> 2.6.7-3
- Bump to full release
- Remove patch 8 (preview-4 patch)
- Put Build.Utilities.v4 back into the core part as it's needed in core
* Thu Jul 15 2010 Dan Horák <dan[at]danny.cz> - 2.6.7-2
- conditionalize the C# 4.0 support, don't build it on s390(x)

View File

@ -1 +1 @@
5851a2e6a6e6ae68fbc2a1c9ff1ead93 mono-2.6.7.tar.bz2
cc8b7bf061bd11fbd0fcc1c95eb79d34 mono-2.6.7.tar.bz2