Bump to mono-2.0 RC 1 Dropped XIM fix
This commit is contained in:
parent
f96202cca9
commit
318dae4186
@ -1,3 +1,4 @@
|
||||
mono-2_0-1_fc10:HEAD:mono-2.0-1.fc10.src.rpm:1218719116
|
||||
mono-2_0-4_fc10:HEAD:mono-2.0-4.fc10.src.rpm:1219746940
|
||||
mono-2_0-5_fc10:HEAD:mono-2.0-5.fc10.src.rpm:1220047677
|
||||
mono-2_0-6_fc10:HEAD:mono-2.0-6.fc10.src.rpm:1221073246
|
||||
|
@ -1,63 +0,0 @@
|
||||
--- mono-2.0/mcs/class/Managed.Windows.Forms/System.Windows.Forms/X11Keyboard.cs 2008-08-12 17:12:15.000000000 +0100
|
||||
+++ mono-2.0/mcs/class/Managed.Windows.Forms/System.Windows.Forms/X11Keyboard-new.cs 2008-08-22 16:47:01.000000000 +0100
|
||||
@@ -105,13 +105,26 @@
|
||||
KeyboardLayout layout = DetectLayout (layouts);
|
||||
lcid = layout.Lcid;
|
||||
CreateConversionArray (layouts, layout);
|
||||
+ SetupXIM ();
|
||||
+ initialized = true;
|
||||
+ }
|
||||
+
|
||||
+ private void SetupXIM ()
|
||||
+ {
|
||||
+ xim = IntPtr.Zero;
|
||||
|
||||
if (!XSupportsLocale ()) {
|
||||
Console.Error.WriteLine ("X does not support your locale");
|
||||
+ return;
|
||||
}
|
||||
|
||||
if (!XSetLocaleModifiers (String.Empty)) {
|
||||
Console.Error.WriteLine ("Could not set X locale modifiers");
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ if (Environment.GetEnvironmentVariable (ENV_NAME_XIM_STYLE) == "disabled") {
|
||||
+ return;
|
||||
}
|
||||
|
||||
xim = XOpenIM (display, IntPtr.Zero, IntPtr.Zero, IntPtr.Zero);
|
||||
@@ -119,6 +132,7 @@
|
||||
Console.Error.WriteLine ("Could not get XIM");
|
||||
else
|
||||
utf8_buffer = new byte [100];
|
||||
+
|
||||
initialized = true;
|
||||
}
|
||||
|
||||
@@ -905,7 +919,7 @@
|
||||
xic = CreateOverTheSpotXic (window, xim);
|
||||
if (xic != IntPtr.Zero)
|
||||
break;
|
||||
- Console.WriteLine ("failed to create XIC in over-the-spot mode.");
|
||||
+ //Console.WriteLine ("failed to create XIC in over-the-spot mode.");
|
||||
continue;
|
||||
case styleOnTheSpot:
|
||||
// Since .NET/Winforms seems to support only over-the-spot mode,,
|
||||
@@ -914,7 +928,7 @@
|
||||
xic = CreateOnTheSpotXic (window, xim);
|
||||
if (xic != IntPtr.Zero)
|
||||
break;
|
||||
- Console.WriteLine ("failed to create XIC in on-the-spot mode.");
|
||||
+ //Console.WriteLine ("failed to create XIC in on-the-spot mode.");
|
||||
continue;
|
||||
case styleRoot:
|
||||
xic = XCreateIC (xim,
|
||||
@@ -1148,6 +1162,7 @@
|
||||
keysym = (XKeySym) keysym_res.ToInt32 ();
|
||||
return s.Length;
|
||||
} else {
|
||||
+ lookup_buffer.Length = 0;
|
||||
res = XLookupString (ref xevent, lookup_buffer, len, out keysym_res, IntPtr.Zero);
|
||||
keysym = (XKeySym) keysym_res.ToInt32 ();
|
||||
return res;
|
13
mono.spec
13
mono.spec
@ -1,6 +1,6 @@
|
||||
Name: mono
|
||||
Version: 2.0
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: A .NET runtime environment
|
||||
|
||||
Group: Development/Languages
|
||||
@ -44,7 +44,6 @@ Patch7: mono-2.0-pcfiles.patch
|
||||
Patch6:mono-2.0-uselibdir.patch
|
||||
Patch9:mono-2.0-monoservice.patch
|
||||
Patch10: mono-2.0-metadata-makefile.patch
|
||||
Patch11: mono-2.0-swfxim.patch
|
||||
|
||||
%description
|
||||
The Mono runtime implements a JIT engine for the ECMA CLI
|
||||
@ -260,7 +259,6 @@ sed -i -e 's!%{_libdir}!@@LIBDIR@@!' %{PATCH8}
|
||||
%patch7 -p1 -b .pc-patches
|
||||
%patch9 -p1 -b .monoservice
|
||||
%patch10 -p1 -b .metadata
|
||||
%patch11 -p1 -b .swfxim
|
||||
autoreconf -f -i -s
|
||||
|
||||
# Add undeclared Arg
|
||||
@ -279,7 +277,7 @@ export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||
|
||||
gcc -o monodir %{SOURCE1} -DMONODIR=\"%{_libdir}/mono\"
|
||||
|
||||
%configure --with-ikvm=yes --with-jit=yes --with-xen_opt=yes --with-moonlight=no --disable-static
|
||||
%configure --with-ikvm=yes --with-jit=yes --with-xen_opt=yes --with-moonlight=no --disable-static --with-preview=yes
|
||||
make
|
||||
|
||||
|
||||
@ -333,6 +331,7 @@ install monodir $RPM_BUILD_ROOT%{_bindir}
|
||||
%{_bindir}/monodir
|
||||
%{_bindir}/mono-api-*
|
||||
%{_bindir}/mono-test-install
|
||||
%{_bindir}/gacutil2
|
||||
%mono_bin certmgr
|
||||
%mono_bin chktrust
|
||||
%mono_bin gacutil
|
||||
@ -614,6 +613,12 @@ install monodir $RPM_BUILD_ROOT%{_bindir}
|
||||
%gac_dll IBM.Data.DB2
|
||||
|
||||
%changelog
|
||||
* Tue Sep 09 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 2.0-6
|
||||
- Bump to RC1
|
||||
- Removed XIM patch
|
||||
- Added additional configure options
|
||||
- Fixed spec file
|
||||
|
||||
* Fri Aug 29 2008 Paul F. Johnson <paul@all-the-johnsons.co.uk> 2.0-5
|
||||
- moved libMonoPosixHelper back to the main package
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user