upgrade to Mono 6.6.0.161, with a bootstrap build
This commit is contained in:
parent
9e62c9a7e9
commit
305ea8ee10
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
||||
mono-*.tar.bz2
|
||||
mono-*.src.rpm
|
||||
/mono-6.6.0.161.tar.xz
|
||||
|
@ -11,9 +11,9 @@ diff --git a/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs b
|
||||
index b0777b5..d50d6c4 100644
|
||||
--- a/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
|
||||
+++ b/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
|
||||
@@ -6239,9 +6239,6 @@ namespace System.Windows.Forms {
|
||||
atoms [0] = 1; // Version 1
|
||||
atoms [1] = 1; // we want to be mapped
|
||||
@@ -6219,9 +6219,6 @@ namespace System.Windows.Forms {
|
||||
atoms [0] = (IntPtr)1; // Version 1
|
||||
atoms [1] = (IntPtr)1; // we want to be mapped
|
||||
|
||||
- // This line cost me 3 days...
|
||||
- XChangeProperty(DisplayHandle, hwnd.whole_window, _XEMBED_INFO, _XEMBED_INFO, 32, PropertyMode.Replace, atoms, 2);
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/mcs/tools/cil-stringreplacer/Makefile 2019-02-21 04:46:01.764018606 +0000
|
||||
+++ b/mcs/tools/cil-stringreplacer/Makefile 2019-02-21 04:46:33.532559588 +0000
|
||||
@@ -8,7 +8,7 @@
|
||||
API = $(filter basic build, $(PROFILE))
|
||||
ifdef API
|
||||
# It can be run using system .net during boostrap
|
||||
-TARGET_NET_REFERENCE = v4.6
|
||||
+TARGET_NET_REFERENCE = v4.7.1
|
||||
# Trick to make it work during boostrap where it has to run with system
|
||||
# assemblies not the ones in lib/basic folder
|
||||
PROGRAM_USE_INTERMEDIATE_FILE = 1
|
@ -6,6 +6,6 @@
|
||||
|
||||
+#define ARCH_MIN_MS_BLOCK_SIZE (64*1024)
|
||||
+#define ARCH_MIN_MS_BLOCK_SIZE_SHIFT 16
|
||||
#ifdef __linux__
|
||||
#define REDZONE_SIZE 0
|
||||
#elif defined(__APPLE__)
|
||||
#if defined(__APPLE__)
|
||||
#define REDZONE_SIZE 128
|
||||
#else
|
@ -1,6 +1,6 @@
|
||||
--- a/mcs/class/reference-assemblies/Makefile 2019-01-02 10:25:41.011999700 +0100
|
||||
+++ b/mcs/class/reference-assemblies/Makefile 2019-01-02 10:27:20.591632515 +0100
|
||||
@@ -10,25 +10,11 @@
|
||||
@@ -10,29 +10,11 @@
|
||||
$(MAKE) -C ../../../external/binary-reference-assemblies CSC="MONO_PATH=$(abspath $(topdir)/class/lib/$(BUILD_TOOLS_PROFILE)) $(INTERNAL_CSC)"
|
||||
|
||||
install-local:
|
||||
@ -14,6 +14,9 @@
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.6.1-api
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.6.2-api
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.7-api
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.7.1-api
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.7.2-api
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.8-api
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.5-api/Facades
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.5.1-api/Facades
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.5.2-api/Facades
|
||||
@ -23,6 +26,7 @@
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.7-api/Facades
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.7.1-api/Facades
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.7.2-api/Facades
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.8-api/Facades
|
||||
+ $(MKINSTALLDIRS) $(PROFILE_DIR)/4.5
|
||||
+ ln -sf 4.5 $(PROFILE_DIR)/4.7-api
|
||||
+ ln -sf 4.5 $(PROFILE_DIR)/4.6-api
|
||||
@ -31,31 +35,17 @@
|
||||
|
||||
$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v2.0/*.dll $(PROFILE_DIR)/2.0-api
|
||||
$(INSTALL_LIB) ../../../external/binary-reference-assemblies/v3.5/*.dll $(PROFILE_DIR)/3.5-api
|
||||
@@ -67,13 +53,6 @@
|
||||
$(INSTALL_LIB) ../../../external/binary-reference-assemblies/mono/*.dll $(PROFILE_DIR)/4.7.2-api
|
||||
rm -f $(PROFILE_DIR)/4.7.2-api/ICSharpCode.SharpZipLib.dll
|
||||
|
||||
- # Unfortunately, a few programs (most notably NUnit and FSharp) have hardcoded checks for <prefix>/lib/mono/4.0/mscorlib.dll or Mono.Posix.dll,
|
||||
- # so we need to place something there or those tools break. We decided to symlink to the reference assembly for now.
|
||||
- # See https://bugzilla.xamarin.com/show_bug.cgi?id=38331 and https://bugzilla.xamarin.com/show_bug.cgi?id=41052
|
||||
- $(MKINSTALLDIRS) $(PROFILE_DIR)/4.0
|
||||
- ln -sf ../4.0-api/mscorlib.dll $(PROFILE_DIR)/4.0/mscorlib.dll
|
||||
- ln -sf ../4.0-api/Mono.Posix.dll $(PROFILE_DIR)/4.0/Mono.Posix.dll
|
||||
-
|
||||
DISTFILES = \
|
||||
$(wildcard ../../../external/binary-reference-assemblies/v4.7.2/Facades/*.dll) \
|
||||
$(wildcard ../../../external/binary-reference-assemblies/v4.7.1/Facades/*.dll) \
|
||||
--- a/mcs/Makefile 2018-03-03 06:32:13.642690150 +0100
|
||||
+++ b/mcs/Makefile 2018-03-03 06:32:54.699643624 +0100
|
||||
@@ -40,7 +40,7 @@
|
||||
@@ -43,7 +43,7 @@
|
||||
|
||||
# fun specialty targets
|
||||
|
||||
-PROFILES = net_4_x binary_reference_assemblies xbuild_12 xbuild_14
|
||||
+PROFILES = net_4_x xbuild_12 xbuild_14
|
||||
|
||||
.PHONY: all-profiles $(STD_TARGETS:=-profiles)
|
||||
all-profiles $(STD_TARGETS:=-profiles): %-profiles: profiles-do--%
|
||||
.PHONY: all-profiles compiler-test-profiles run-compiler-test-profiles $(STD_TARGETS:=-profiles)
|
||||
all-profiles compiler-test-profiles run-compiler-test-profiles $(STD_TARGETS:=-profiles): %-profiles: profiles-do--%
|
||||
@@ -65,7 +65,6 @@
|
||||
_boot_ = all clean install
|
||||
$(_boot_:%=profile-do--xbuild_14--%): profile-do--xbuild_14--%: profile-do--net_4_x--%
|
||||
@ -66,9 +56,9 @@
|
||||
$(_boot_:%=profile-do--monodroid_tools--%): profile-do--monodroid_tools--%: profile-do--build--%
|
||||
--- a/mcs/build/Makefile 2018-03-03 07:18:20.662959369 +0100
|
||||
+++ b/mcs/build/Makefile 2018-03-03 07:18:33.303253408 +0100
|
||||
@@ -19,7 +19,6 @@
|
||||
@@ -18,7 +18,6 @@
|
||||
PLATFORMS = macos linux win32 unix
|
||||
PROFILES = \
|
||||
basic \
|
||||
build \
|
||||
- binary_reference_assemblies \
|
||||
net_4_x \
|
||||
@ -76,7 +66,7 @@
|
||||
xbuild_14
|
||||
--- a/runtime/Makefile.in 2018-03-03 14:06:44.691631197 +0100
|
||||
+++ b/runtime/Makefile.in 2018-03-03 14:07:07.241155116 +0100
|
||||
@@ -80,7 +80,7 @@
|
||||
@@ -90,7 +90,7 @@
|
||||
host_triplet = @host@
|
||||
target_triplet = @target@
|
||||
@INSTALL_4_x_TRUE@am__append_1 = etc/mono/4.0/machine.config etc/mono/4.0/web.config etc/mono/4.5/web.config etc/mono/4.0/Browsers/Compat.browser etc/mono/4.5/Browsers/Compat.browser
|
@ -18,36 +18,36 @@ diff -up mono-5.18.1.0/mono/mini/genmdesc.py.py3 mono-5.18.1.0/mono/mini/genmdes
|
||||
diff -up mono-5.18.1.0/mono/mini/Makefile.am.in.py3 mono-5.18.1.0/mono/mini/Makefile.am.in
|
||||
--- mono-5.18.1.0/mono/mini/Makefile.am.in.py3 2019-03-28 07:01:10.975851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/Makefile.am.in 2019-03-28 07:01:35.395851125 -0400
|
||||
@@ -738,7 +738,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.i
|
||||
@@ -780,7 +780,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.i
|
||||
|
||||
GENMDESC_OPTS=
|
||||
|
||||
-GENMDESC_PRG=python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
+GENMDESC_PRG=python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
|
||||
cpu-wasm.h: mini-ops.h cpu-wasm.md
|
||||
cpu-wasm.h: mini-ops.h cpu-wasm.md $(srcdir)/genmdesc.py
|
||||
$(GENMDESC_PRG) cpu-wasm.h wasm_desc $(srcdir)/cpu-wasm.md
|
||||
diff -up mono-5.18.1.0/mono/mini/Makefile.am.py3 mono-5.18.1.0/mono/mini/Makefile.am
|
||||
--- mono-5.18.1.0/mono/mini/Makefile.am.py3 2019-03-28 07:06:02.235851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/Makefile.am 2019-03-28 07:06:06.385851125 -0400
|
||||
@@ -738,7 +738,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.i
|
||||
@@ -780,7 +780,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.i
|
||||
|
||||
GENMDESC_OPTS=
|
||||
|
||||
-GENMDESC_PRG=python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
+GENMDESC_PRG=python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
|
||||
cpu-wasm.h: mini-ops.h cpu-wasm.md
|
||||
cpu-wasm.h: mini-ops.h cpu-wasm.md $(srcdir)/genmdesc.py
|
||||
$(GENMDESC_PRG) cpu-wasm.h wasm_desc $(srcdir)/cpu-wasm.md
|
||||
diff -up mono-5.18.1.0/mono/mini/Makefile.in.py3 mono-5.18.1.0/mono/mini/Makefile.in
|
||||
--- mono-5.18.1.0/mono/mini/Makefile.in.py3 2019-03-28 07:06:12.805851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/Makefile.in 2019-03-28 07:06:21.575851125 -0400
|
||||
@@ -1175,7 +1175,7 @@ libmonoincludedir = $(includedir)/mono-$
|
||||
@@ -1287,7 +1287,7 @@ libmonoincludedir = $(includedir)/mono-$
|
||||
libmonoinclude_HEADERS = jit.h
|
||||
CSFLAGS = -unsafe -nowarn:0219,0169,0414,0649,0618
|
||||
GENMDESC_OPTS =
|
||||
-GENMDESC_PRG = python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
+GENMDESC_PRG = python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
LLVM_AOT_RUNTIME_OPTS = $(if $(LLVM),--llvm,)
|
||||
GSHAREDVT_RUNTIME_OPTS = $(if $(GSHAREDVT),-O=gsharedvt,)
|
||||
fullaot_regtests = $(regtests)
|
||||
@AMD64_FALSE@LLVM_AOT_COMPILER_OPTS =
|
||||
@AMD64_TRUE@LLVM_AOT_COMPILER_OPTS = $(if $(LLVM),"=llvmllc=-mcpu=generic -mattr=+sse3",)
|
@ -1,8 +1,8 @@
|
||||
--- a/mcs/packages/Makefile 2019-02-21 04:53:46.843939657 +0000
|
||||
+++ b/mcs/packages/Makefile 2019-02-21 04:53:40.111824983 +0000
|
||||
@@ -40,15 +40,19 @@
|
||||
@@ -42,11 +42,13 @@
|
||||
|
||||
install-local: install-prototypes
|
||||
install-local:
|
||||
$(MKINSTALLDIRS) $(TARGET_DIR)
|
||||
+ifndef MCS_MODE
|
||||
$(INSTALL_LIB) $(ROSLYN_FILES_FOR_MONO) $(TARGET_DIR)
|
||||
@ -12,11 +12,5 @@
|
||||
(cd $(MSBUILD_ROSLYN_DIR); for asm in $(ROSLYN_FILES_FOR_MONO); do ln -fs ../../../../$(FRAMEWORK_VERSION)/$$(basename $$asm) . ; done)
|
||||
+endif
|
||||
|
||||
install-prototypes:
|
||||
$(MKINSTALLDIRS) $(TARGET_DIR)/dim
|
||||
+ifndef MCS_MODE
|
||||
$(INSTALL_LIB) $(ROSLYN_DIM_FILES) $(TARGET_DIR)/dim
|
||||
+endif
|
||||
|
||||
run-test-local: test-csi
|
||||
|
50
mono.spec
50
mono.spec
@ -2,7 +2,7 @@
|
||||
# workaround https://github.com/mono/mono/issues/9009#issuecomment-477073609
|
||||
%undefine _hardened_build
|
||||
%endif
|
||||
%global bootstrap 0
|
||||
%global bootstrap 1
|
||||
%if 0%{?el6}
|
||||
# see https://fedorahosted.org/fpc/ticket/395, it was added to el7
|
||||
%global mono_arches %{ix86} x86_64 sparc sparcv9 ia64 %{arm} alpha s390x ppc ppc64 ppc64le
|
||||
@ -20,15 +20,15 @@
|
||||
%undefine _missing_build_ids_terminate_build
|
||||
%endif
|
||||
|
||||
%global xamarinrelease 34
|
||||
%global xamarinrelease 161
|
||||
Name: mono
|
||||
Version: 5.20.1
|
||||
Release: 2%{?dist}
|
||||
Version: 6.6.0
|
||||
Release: 0%{?dist}
|
||||
Summary: Cross-platform, Open Source, .NET development framework
|
||||
|
||||
License: MIT
|
||||
URL: http://www.mono-project.com
|
||||
Source0: http://download.mono-project.com/sources/mono/mono-%{version}.%{xamarinrelease}.tar.bz2
|
||||
Source0: http://download.mono-project.com/sources/mono/mono-%{version}.%{xamarinrelease}.tar.xz
|
||||
# This key was generated by Tom "spot" Callaway <tcallawa@redhat.com> on Dec 1, 2009
|
||||
# by running the following command:
|
||||
# sn -k mono.snk
|
||||
@ -39,17 +39,16 @@ Source1: mono.snk
|
||||
Source2: mono-find-provides
|
||||
Source3: mono-find-requires
|
||||
Source4: mono.attr
|
||||
Patch0: mono-5.10.0-ignore-reference-assemblies.patch
|
||||
Patch0: mono-6.6.0-ignore-reference-assemblies.patch
|
||||
Patch1: mono-4.2.1-ppc.patch
|
||||
Patch2: mono-5.10.0-find-provides.patch
|
||||
Patch3: mono-4.2-fix-winforms-trayicon.patch
|
||||
Patch4: mono-4.6.1-aarch64.patch
|
||||
Patch5: mono-5.18.0-roslyn-binaries.patch
|
||||
Patch4: mono-6.6.0-aarch64.patch
|
||||
Patch5: mono-6.6.0-roslyn-binaries.patch
|
||||
Patch6: mono-5.18.0-use-mcs.patch
|
||||
Patch7: mono-5.18.0-use-v471.patch
|
||||
Patch8: mono-5.18.0-reference-assemblies-fix.patch
|
||||
Patch9: mono-5.18.0-sharpziplib-parent-path-traversal.patch
|
||||
Patch10: mono-5.18.1-python3.patch
|
||||
Patch7: mono-5.18.0-reference-assemblies-fix.patch
|
||||
Patch8: mono-5.18.0-sharpziplib-parent-path-traversal.patch
|
||||
Patch9: mono-6.6.0-python3.patch
|
||||
|
||||
BuildRequires: bison
|
||||
BuildRequires: python%{python3_pkgversion}
|
||||
@ -71,8 +70,8 @@ BuildRequires: perl-Getopt-Long
|
||||
%if 0%{bootstrap}
|
||||
# for bootstrap, use bundled monolite and reference assemblies instead of local mono
|
||||
%else
|
||||
BuildRequires: mono-core >= 5.0
|
||||
BuildRequires: mono-devel >= 5.0
|
||||
BuildRequires: mono-core >= 6.6
|
||||
BuildRequires: mono-devel >= 6.6
|
||||
%endif
|
||||
|
||||
# JIT only available on these:
|
||||
@ -337,7 +336,15 @@ not install anything from outside the mono source (XSP, mono-basic, etc.).
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
|
||||
# don't build mono-helix-client which requires the helix-binaries to build
|
||||
sed -i 's|mono-helix-client||g' mcs/tools/Makefile
|
||||
|
||||
# use v4.7.1 instead of v4.6
|
||||
sed -i 's|TARGET_NET_REFERENCE = v4.6|TARGET_NET_REFERENCE = $(BOOTSTRAP_BIN_PROFILE)|g' mcs/tools/upload-to-sentry/Makefile
|
||||
|
||||
# use v4.7.1 instead of v4.7
|
||||
sed -i 's|BOOTSTRAP_BIN_PROFILE = v4.7|BOOTSTRAP_BIN_PROFILE = v4.7.1|g' mcs/build/profiles/build.make
|
||||
|
||||
# Remove hardcoded lib directory for libMonoPosixHelper.so from the config
|
||||
sed -i 's|$mono_libdir/||g' data/config.in
|
||||
@ -370,6 +377,7 @@ export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
|
||||
export LD_LIBRARY_PATH=`pwd`/mono/native/.libs
|
||||
make %{?_smp_mflags}
|
||||
|
||||
# rebuild the reference assemblies
|
||||
@ -378,6 +386,7 @@ find ./external/binary-reference-assemblies/v4.7.1/ -name \*.dll -print -delete
|
||||
BUILD_PATH=`pwd` && cd ./external/binary-reference-assemblies/ && MONO_PATH=$BUILD_PATH/mcs/class/lib/net_4_x-linux/ V=1 CSC="$BUILD_PATH/runtime/mono-wrapper $BUILD_PATH/mcs/class/lib/net_4_x-linux/mcs.exe" make -C v4.7.1
|
||||
|
||||
%install
|
||||
export LD_LIBRARY_PATH=`pwd`/mono/native/.libs
|
||||
make install DESTDIR=%{buildroot}
|
||||
|
||||
# copy the mono.snk key into /etc/pki/mono
|
||||
@ -449,6 +458,7 @@ rm -rf %{buildroot}/usr/lib/debug/usr/lib64/libmono-btls-shared.so-*.debug
|
||||
|
||||
# drop other debug files as well
|
||||
rm -rf %{buildroot}/usr/lib/debug/usr/lib64/libmono-native.so*.debug
|
||||
rm -rf %{buildroot}/usr/lib/debug/usr/bin/mono-hang-watchdog-*.debug
|
||||
|
||||
# create a symbolic link so that Fedora packages targetting Framework 4.5 will still build
|
||||
cd %{buildroot}/usr/lib/mono && ln -s 4.7.1-api 4.5-api && cd -
|
||||
@ -482,7 +492,6 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
|
||||
%{_bindir}/mono-sgen
|
||||
%{_bindir}/mono-sgen-gdb.py
|
||||
%{_bindir}/mono-package-runtime
|
||||
%{_bindir}/monograph
|
||||
%{_bindir}/sgen-grep-binprot
|
||||
%dir %{_libdir}/mono
|
||||
%dir %{_libdir}/mono/lldb
|
||||
@ -604,6 +613,7 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
|
||||
%gac_dll System.Workflow.ComponentModel
|
||||
%gac_dll System.Workflow.Runtime
|
||||
%gac_dll Mono.Profiler.Log
|
||||
%{_bindir}/mono-hang-watchdog
|
||||
|
||||
%files devel
|
||||
%{_sysconfdir}/pki/mono/
|
||||
@ -726,6 +736,9 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
|
||||
%{_includedir}/mono-2.0/mono/cil/opcode.def
|
||||
%{_prefix}/lib/rpm/mono-find-*
|
||||
%{_prefix}/lib/rpm/fileattrs/mono.attr
|
||||
%{_bindir}/aprofutil
|
||||
%mono_bin aprofutil
|
||||
%{_mandir}/man1/aprofutil.1.gz
|
||||
|
||||
%files locale-extras
|
||||
%gac_dll I18N.CJK
|
||||
@ -882,8 +895,8 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
|
||||
%ifnarch ppc
|
||||
%{_prefix}/lib/monodoc
|
||||
%endif
|
||||
%mono_bin mdoc
|
||||
%{_bindir}/mod
|
||||
%{_bindir}/mdoc
|
||||
%{_bindir}/mdoc-*
|
||||
%{_bindir}/mdass*
|
||||
%{_bindir}/mdval*
|
||||
@ -898,6 +911,9 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
|
||||
%files complete
|
||||
|
||||
%changelog
|
||||
* Sat Jan 18 2020 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 6.6.0-1
|
||||
- upgrade to Mono 6.6.0.161, with a bootstrap build
|
||||
|
||||
* Sun Oct 13 2019 Peter Oliver <rpm@mavit.org.uk> - 5.20.1-1
|
||||
- Post script must belong to a subpackage, since there is no main package.
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mono-5.20.1.34.tar.bz2) = 08de875c2d5431c85a4a6d0a0938539750ae30c5cd1af1e50bd37ff5c31c1cfa87e2e757f97fb47fb3a23a8646c3455fe9faf86e4ec2c04264c751a776a166d3
|
||||
SHA512 (mono-6.6.0.161.tar.xz) = 0b0c72daef9e1c10c0d566292997d4a923766390793ec1196a063b885e853b47a12503238632879cf7397f03b34909137e24c53db9300a4f209164e973284186
|
||||
|
Loading…
x
Reference in New Issue
Block a user