fix issue with conflicts between i686 and x86_64 package (#1853724)

This commit is contained in:
Timotheus Pokorra 2020-10-12 16:32:38 +02:00
parent 0f81111850
commit 246fff2467
2 changed files with 27 additions and 4 deletions

View File

@ -0,0 +1,15 @@
--- a/mono/eglib/eglib-config.h.in 2020-10-12 14:57:46.354634946 +0200
+++ b/mono/eglib/eglib-config.h.in 2020-10-12 15:00:10.106637683 +0200
@@ -26,7 +26,11 @@
typedef @GSIZE@ gsize;
typedef @GSSIZE@ gssize;
-#define G_GSIZE_FORMAT @GSIZE_FORMAT@
+#ifdef __i386__
+#define G_GSIZE_FORMAT "u"
+#else
+#define G_GSIZE_FORMAT "lu"
+#endif
#if defined (HOST_WATCHOS)
#undef G_BREAKPOINT

View File

@ -24,7 +24,7 @@
%global xamarinrelease 104
Name: mono
Version: 6.10.0
Release: 0%{?dist}
Release: 1%{?dist}
Summary: Cross-platform, Open Source, .NET development framework
License: MIT
@ -56,6 +56,8 @@ Patch10: 0001-DocumentationEnumerator.cs-Declare-iface-and-ifaceMe.patch
Patch11: 0001-Replace-new-Csharp-features-with-old-ones.patch
# Reenable mdoc build. To be upstreamed after Patch 10 and 11
Patch12: 0001-Reenable-mdoc.exe-build.patch
# fix issue with conflicts between i686 and x86_64 package (#1853724)
Patch13: mono-6.6.0-fix-multi-arch-issue.patch
BuildRequires: bison
BuildRequires: python%{python3_pkgversion}
@ -345,6 +347,7 @@ pushd external/api-doc-tools
%patch11 -p1
popd
%patch12 -p1
%patch13 -p1
# don't build mono-helix-client which requires the helix-binaries to build
sed -i 's|mono-helix-client||g' mcs/tools/Makefile
@ -489,6 +492,10 @@ install -p -m755 %{SOURCE2} %{SOURCE3} %{buildroot}%{_prefix}/lib/rpm/
install -p -m644 %{SOURCE4} %{buildroot}%{_prefix}/lib/rpm/fileattrs/
%endif
# remove these files, we are using the files installed in /usr/lib/rpm/
rm %{buildroot}%{_bindir}/mono-find-requires
rm %{buildroot}%{_bindir}/mono-find-provides
%find_lang mcs
%post core
@ -662,8 +669,6 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
%mono_bin mkbundle
%mono_bin makecert
%mono_bin mono-cil-strip
%{_bindir}/mono-find-provides
%{_bindir}/mono-find-requires
%{_bindir}/monodis
%{_bindir}/monolinker
%mono_bin mono-shlib-cop
@ -935,8 +940,11 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
%files complete
%changelog
* Mon Oct 12 2020 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 6.10.0-1
- fix issue with conflicts between i686 and x86_64 package (#1853724)
* Mon Sep 28 2020 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 6.10.0-0
* Upgrade to Mono 6.10.0.104
- Upgrade to Mono 6.10.0.104
* Fri Aug 21 2020 François Cami <fcami@redhat.com> - 6.8.0-6
- Ship libMonoSupportW.so