Upgrade to Mono 6.10.0.104, with bootstrap build
This commit is contained in:
parent
93230c36af
commit
15530f7a74
@ -1,53 +0,0 @@
|
||||
--- a/scripts/mono-heapviz
|
||||
+++ b/scripts/mono-heapviz
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
# Generate a heap visualization for SGen from the heap dump written by
|
||||
# mono if the MONO_GC_DEBUG is set to something like
|
||||
diff -up mono-5.18.1.0/mono/mini/genmdesc.py.py3 mono-5.18.1.0/mono/mini/genmdesc.py
|
||||
--- mono-5.18.1.0/mono/mini/genmdesc.py.py3 2019-03-28 06:56:35.765851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/genmdesc.py 2019-03-28 06:56:44.805851125 -0400
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
#
|
||||
# This tool is used to generate the cpu-<ARCH>.h files used by the JIT. The input is the
|
||||
diff -up mono-5.18.1.0/mono/mini/Makefile.am.in.py3 mono-5.18.1.0/mono/mini/Makefile.am.in
|
||||
--- mono-5.18.1.0/mono/mini/Makefile.am.in.py3 2019-03-28 07:01:10.975851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/Makefile.am.in 2019-03-28 07:01:35.395851125 -0400
|
||||
@@ -780,7 +780,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.i
|
||||
|
||||
GENMDESC_OPTS=
|
||||
|
||||
-GENMDESC_PRG=python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
+GENMDESC_PRG=python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
|
||||
cpu-wasm.h: mini-ops.h cpu-wasm.md $(srcdir)/genmdesc.py
|
||||
$(GENMDESC_PRG) cpu-wasm.h wasm_desc $(srcdir)/cpu-wasm.md
|
||||
diff -up mono-5.18.1.0/mono/mini/Makefile.am.py3 mono-5.18.1.0/mono/mini/Makefile.am
|
||||
--- mono-5.18.1.0/mono/mini/Makefile.am.py3 2019-03-28 07:06:02.235851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/Makefile.am 2019-03-28 07:06:06.385851125 -0400
|
||||
@@ -780,7 +780,7 @@ MemoryIntrinsics.dll: MemoryIntrinsics.i
|
||||
|
||||
GENMDESC_OPTS=
|
||||
|
||||
-GENMDESC_PRG=python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
+GENMDESC_PRG=python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
|
||||
cpu-wasm.h: mini-ops.h cpu-wasm.md $(srcdir)/genmdesc.py
|
||||
$(GENMDESC_PRG) cpu-wasm.h wasm_desc $(srcdir)/cpu-wasm.md
|
||||
diff -up mono-5.18.1.0/mono/mini/Makefile.in.py3 mono-5.18.1.0/mono/mini/Makefile.in
|
||||
--- mono-5.18.1.0/mono/mini/Makefile.in.py3 2019-03-28 07:06:12.805851125 -0400
|
||||
+++ mono-5.18.1.0/mono/mini/Makefile.in 2019-03-28 07:06:21.575851125 -0400
|
||||
@@ -1287,7 +1287,7 @@ libmonoincludedir = $(includedir)/mono-$
|
||||
libmonoinclude_HEADERS = jit.h
|
||||
CSFLAGS = -unsafe -nowarn:0219,0169,0414,0649,0618
|
||||
GENMDESC_OPTS =
|
||||
-GENMDESC_PRG = python $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
+GENMDESC_PRG = python3 $(srcdir)/genmdesc.py $(target_define) $(srcdir)
|
||||
LLVM_AOT_RUNTIME_OPTS = $(if $(LLVM),--llvm,)
|
||||
@AMD64_FALSE@LLVM_AOT_COMPILER_OPTS =
|
||||
@AMD64_TRUE@LLVM_AOT_COMPILER_OPTS = $(if $(LLVM),llvmllc=-mattr=+sse3,)
|
16
mono.spec
16
mono.spec
@ -1,3 +1,4 @@
|
||||
%global _with_bootstrap 1
|
||||
%bcond_with bootstrap
|
||||
|
||||
%ifarch s390x
|
||||
@ -21,10 +22,10 @@
|
||||
%undefine _missing_build_ids_terminate_build
|
||||
%endif
|
||||
|
||||
%global xamarinrelease 123
|
||||
%global xamarinrelease 104
|
||||
Name: mono
|
||||
Version: 6.8.0
|
||||
Release: 6%{?dist}
|
||||
Version: 6.10.0
|
||||
Release: 0%{?dist}
|
||||
Summary: Cross-platform, Open Source, .NET development framework
|
||||
|
||||
License: MIT
|
||||
@ -49,7 +50,6 @@ Patch5: mono-6.6.0-roslyn-binaries.patch
|
||||
Patch6: mono-5.18.0-use-mcs.patch
|
||||
Patch7: mono-5.18.0-reference-assemblies-fix.patch
|
||||
Patch8: mono-5.18.0-sharpziplib-parent-path-traversal.patch
|
||||
Patch9: mono-6.6.0-python3.patch
|
||||
# Fix NRE bug in api-doc-tools: https://github.com/mono/api-doc-tools/pull/464
|
||||
Patch10: 0001-DocumentationEnumerator.cs-Declare-iface-and-ifaceMe.patch
|
||||
# Replace new Csharp features with old to allow mdoc to build
|
||||
@ -76,8 +76,8 @@ BuildRequires: perl-Getopt-Long
|
||||
# which results in not deleting the binaries in %%prep.
|
||||
|
||||
%if %{without bootstrap}
|
||||
BuildRequires: mono-core >= 6.8
|
||||
BuildRequires: mono-devel >= 6.8
|
||||
BuildRequires: mono-core >= 6.10
|
||||
BuildRequires: mono-devel >= 6.10
|
||||
%endif
|
||||
|
||||
# JIT only available on these:
|
||||
@ -341,7 +341,6 @@ not install anything from outside the mono source (XSP, mono-basic, etc.).
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
pushd external/api-doc-tools
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
@ -937,6 +936,9 @@ cert-sync /etc/pki/tls/certs/ca-bundle.crt
|
||||
%files complete
|
||||
|
||||
%changelog
|
||||
* Mon Sep 28 2020 Timotheus Pokorra <timotheus.pokorra@solidcharity.com> - 6.10.0-0
|
||||
* Upgrade to Mono 6.10.0.104
|
||||
|
||||
* Fri Aug 21 2020 François Cami <fcami@redhat.com> - 6.8.0-6
|
||||
- Ship libMonoSupportW.so
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mono-6.8.0.123.tar.xz) = f702d1ee3a7e8b1a028de02fe6f3ab78e1c5171a547c37db7e934c33533984f2847636476407ad46daeb150640136d6bb28c12c9482c1806997df2dfd7a839f1
|
||||
SHA512 (mono-6.10.0.104.tar.xz) = 73b853e9fc9af2e1bf5e45f7accb8893dd7e48f9723f74b03d99ea11cf565e2c5bb2d6ae4c81c7e7be0cdfa489016da909ed7b12808c8f84d9d25e33e1cb9874
|
||||
|
Loading…
Reference in New Issue
Block a user