Bump version to 1.4.0

* Refresh patch
* Use SPDX notation for `License:` field
* Add license information for `third-party/rust-demangle` sources
This commit is contained in:
Christoph Erhardt 2022-08-07 10:53:33 +02:00
parent c5d5316369
commit 85b585f179
4 changed files with 82 additions and 28 deletions

View File

@ -1,8 +1,8 @@
From 5cb5f63ea2f2fc6d6ea24a3a9f1e73f6fc6c9fc9 Mon Sep 17 00:00:00 2001
Message-Id: <5cb5f63ea2f2fc6d6ea24a3a9f1e73f6fc6c9fc9.1655550664.git.github@sicherha.de>
From b0b069ece8d76914670bfdfd04ea628477c95988 Mon Sep 17 00:00:00 2001
Message-Id: <b0b069ece8d76914670bfdfd04ea628477c95988.1659770551.git.github@sicherha.de>
From: Christoph Erhardt <github@sicherha.de>
Date: Fri, 29 Apr 2022 21:44:33 +0200
Subject: [PATCH] Skip tests that fail on armv7l
Subject: [PATCH 1/2] Skip tests that fail on armv7l
---
test/elf/exception.sh | 2 ++
@ -16,11 +16,11 @@ Subject: [PATCH] Skip tests that fail on armv7l
8 files changed, 11 insertions(+)
diff --git a/test/elf/exception.sh b/test/elf/exception.sh
index 3288c783..2e9f02f9 100755
index 2a68a261..f406e2e2 100755
--- a/test/elf/exception.sh
+++ b/test/elf/exception.sh
@@ -13,6 +13,8 @@ cd "$(dirname "$0")"/../..
t=out/test/elf/$testname
@@ -12,6 +12,8 @@ echo -n "Testing $testname ... "
t=out/test/elf/$MACHINE/$testname
mkdir -p $t
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
@ -29,10 +29,10 @@ index 3288c783..2e9f02f9 100755
int main() {
try {
diff --git a/test/elf/gdb-index-compress-output.sh b/test/elf/gdb-index-compress-output.sh
index 926f70df..62eda85c 100755
index 83cd2cea..015fe874 100755
--- a/test/elf/gdb-index-compress-output.sh
+++ b/test/elf/gdb-index-compress-output.sh
@@ -15,6 +15,7 @@ mkdir -p $t
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
@ -41,10 +41,10 @@ index 926f70df..62eda85c 100755
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf2.sh b/test/elf/gdb-index-dwarf2.sh
index 0ee1449c..d2efba9c 100755
index 853f5ed8..dce14849 100755
--- a/test/elf/gdb-index-dwarf2.sh
+++ b/test/elf/gdb-index-dwarf2.sh
@@ -15,6 +15,7 @@ mkdir -p $t
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
@ -53,10 +53,10 @@ index 0ee1449c..d2efba9c 100755
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf3.sh b/test/elf/gdb-index-dwarf3.sh
index 600adcf1..4d29416c 100755
index d2ce0804..0ced3284 100755
--- a/test/elf/gdb-index-dwarf3.sh
+++ b/test/elf/gdb-index-dwarf3.sh
@@ -15,6 +15,7 @@ mkdir -p $t
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
@ -65,10 +65,10 @@ index 600adcf1..4d29416c 100755
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf4.sh b/test/elf/gdb-index-dwarf4.sh
index a248fbcd..0df17625 100755
index ca81cf13..6be62e17 100755
--- a/test/elf/gdb-index-dwarf4.sh
+++ b/test/elf/gdb-index-dwarf4.sh
@@ -15,6 +15,7 @@ mkdir -p $t
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
@ -77,10 +77,10 @@ index a248fbcd..0df17625 100755
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf5.sh b/test/elf/gdb-index-dwarf5.sh
index ee33e8d0..01d324b6 100755
index 8d5584e6..e4b30b94 100755
--- a/test/elf/gdb-index-dwarf5.sh
+++ b/test/elf/gdb-index-dwarf5.sh
@@ -15,6 +15,7 @@ mkdir -p $t
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
@ -89,11 +89,11 @@ index ee33e8d0..01d324b6 100755
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/hello-static.sh b/test/elf/hello-static.sh
index 62dce63c..6c1dde72 100755
index a2c9626b..eed8b935 100755
--- a/test/elf/hello-static.sh
+++ b/test/elf/hello-static.sh
@@ -13,6 +13,8 @@ cd "$(dirname "$0")"/../..
t=out/test/elf/$testname
@@ -12,6 +12,8 @@ echo -n "Testing $testname ... "
t=out/test/elf/$MACHINE/$testname
mkdir -p $t
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
@ -102,18 +102,18 @@ index 62dce63c..6c1dde72 100755
#include <stdio.h>
diff --git a/test/elf/ifunc-static.sh b/test/elf/ifunc-static.sh
index 295350a3..7f1d2686 100755
index 8a25fa1c..b0cf698e 100755
--- a/test/elf/ifunc-static.sh
+++ b/test/elf/ifunc-static.sh
@@ -16,6 +16,8 @@ mkdir -p $t
@@ -15,6 +15,8 @@ mkdir -p $t
# IFUNC is not supported on RISC-V yet
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
+
# Skip if libc is musl because musl does not support GNU FUNC
echo 'int main() {}' | $CC -o $t/exe -xc -
readelf --dynamic $t/exe | grep -q ld-musl && { echo OK; exit; }
ldd --help 2>&1 | grep -q musl && { echo skipped; exit; }
--
2.36.1
2.37.1

View File

@ -0,0 +1,47 @@
From 3dcb7063c56a9119cb7e2e2c4c56bdc4d3b2d28a Mon Sep 17 00:00:00 2001
Message-Id: <3dcb7063c56a9119cb7e2e2c4c56bdc4d3b2d28a.1659770551.git.github@sicherha.de>
In-Reply-To: <b0b069ece8d76914670bfdfd04ea628477c95988.1659770551.git.github@sicherha.de>
References: <b0b069ece8d76914670bfdfd04ea628477c95988.1659770551.git.github@sicherha.de>
From: Christoph Erhardt <github@sicherha.de>
Date: Sat, 6 Aug 2022 09:18:54 +0200
Subject: [PATCH 2/2] Use system-compatible include path for `xxhash.h`
Distributors that build mold against the system-provided xxHash package
expect its header file `xxhash.h` in the top-level include directory,
not in an `xxhash` subdirectory. Adjust the include path and the
`#include` directive accordingly.
---
Makefile | 3 ++-
mold.h | 2 +-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index b19c34c0..0f66c6df 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,8 @@ CFLAGS = -O2
CXXFLAGS = -O2
MOLD_CXXFLAGS := -std=c++20 -fno-exceptions -fno-unwind-tables \
- -fno-asynchronous-unwind-tables -Ithird-party \
+ -fno-asynchronous-unwind-tables \
+ -Ithird-party -Ithird-party/xxhash \
-DMOLD_VERSION=\"$(VERSION)\" -DLIBDIR="\"$(LIBDIR)\""
MOLD_LDFLAGS := -pthread -lz -lm -ldl
diff --git a/mold.h b/mold.h
index 9464d8ad..b6478960 100644
--- a/mold.h
+++ b/mold.h
@@ -27,7 +27,7 @@
#include <vector>
#define XXH_INLINE_ALL 1
-#include <xxhash/xxhash.h>
+#include <xxhash.h>
#ifdef NDEBUG
# define unreachable() __builtin_unreachable()
--
2.37.1

View File

@ -1,9 +1,9 @@
Name: mold
Version: 1.3.1
Release: 2%{?dist}
Version: 1.4.0
Release: 1%{?dist}
Summary: A Modern Linker
License: AGPLv3+
License: AGPL-3.0-or-later AND (Apache-2.0 OR MIT)
URL: https://github.com/rui314/mold
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
@ -16,6 +16,8 @@ Patch0: tbb-strip-werror.patch
# Skip failing tests on armv7l
Patch1: 0001-Skip-tests-that-fail-on-armv7l.patch
# Allow building against the system-provided `xxhash.h`
Patch2: 0002-Use-system-compatible-include-path-for-xxhash.h.patch
# mold can currently produce native binaries for these architectures only
ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 riscv64
@ -105,6 +107,11 @@ fi
%{_mandir}/man1/mold.1*
%changelog
* Sun Aug 07 2022 Christoph Erhardt <fedora@sicherha.de> - 1.4.0-1
- Bump version to 1.4.0 (#2116004)
- Refresh patch
- Use SPDX notation for `License:` field
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

View File

@ -1 +1 @@
SHA512 (mold-1.3.1.tar.gz) = f576d2fcfee5cb3bade5ba24dcdd3020a16131ce7d4c3a00c3f92b94785ed86f3f040a6f5814b9c975c4c3d90a2b8c36a8101d5fbf1bc0a4be316f4a4a6dcefa
SHA512 (mold-1.4.0.tar.gz) = 7b7c4a7bac6bbc6e22372d93d94a6cb804c7017eba16b90e9bbc42b9608108c724ef55337aabdd9ce2f5244b94c8fd64311e70e18b5f8cf5f68533c2639e550d