Bump version to 1.4.1

This commit is contained in:
Christoph Erhardt 2022-08-18 14:37:59 +02:00
parent 78efc6aa6e
commit 1d53c194ce
5 changed files with 53 additions and 172 deletions

View File

@ -1,119 +0,0 @@
From b0b069ece8d76914670bfdfd04ea628477c95988 Mon Sep 17 00:00:00 2001
Message-Id: <b0b069ece8d76914670bfdfd04ea628477c95988.1659770551.git.github@sicherha.de>
From: Christoph Erhardt <github@sicherha.de>
Date: Fri, 29 Apr 2022 21:44:33 +0200
Subject: [PATCH 1/2] Skip tests that fail on armv7l
---
test/elf/exception.sh | 2 ++
test/elf/gdb-index-compress-output.sh | 1 +
test/elf/gdb-index-dwarf2.sh | 1 +
test/elf/gdb-index-dwarf3.sh | 1 +
test/elf/gdb-index-dwarf4.sh | 1 +
test/elf/gdb-index-dwarf5.sh | 1 +
test/elf/hello-static.sh | 2 ++
test/elf/ifunc-static.sh | 2 ++
8 files changed, 11 insertions(+)
diff --git a/test/elf/exception.sh b/test/elf/exception.sh
index 2a68a261..f406e2e2 100755
--- a/test/elf/exception.sh
+++ b/test/elf/exception.sh
@@ -12,6 +12,8 @@ echo -n "Testing $testname ... "
t=out/test/elf/$MACHINE/$testname
mkdir -p $t
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
+
cat <<EOF | $CXX -c -o $t/a.o -xc++ -fPIC -
int main() {
try {
diff --git a/test/elf/gdb-index-compress-output.sh b/test/elf/gdb-index-compress-output.sh
index 83cd2cea..015fe874 100755
--- a/test/elf/gdb-index-compress-output.sh
+++ b/test/elf/gdb-index-compress-output.sh
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf2.sh b/test/elf/gdb-index-dwarf2.sh
index 853f5ed8..dce14849 100755
--- a/test/elf/gdb-index-dwarf2.sh
+++ b/test/elf/gdb-index-dwarf2.sh
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf3.sh b/test/elf/gdb-index-dwarf3.sh
index d2ce0804..0ced3284 100755
--- a/test/elf/gdb-index-dwarf3.sh
+++ b/test/elf/gdb-index-dwarf3.sh
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf4.sh b/test/elf/gdb-index-dwarf4.sh
index ca81cf13..6be62e17 100755
--- a/test/elf/gdb-index-dwarf4.sh
+++ b/test/elf/gdb-index-dwarf4.sh
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/gdb-index-dwarf5.sh b/test/elf/gdb-index-dwarf5.sh
index 8d5584e6..e4b30b94 100755
--- a/test/elf/gdb-index-dwarf5.sh
+++ b/test/elf/gdb-index-dwarf5.sh
@@ -14,6 +14,7 @@ mkdir -p $t
[ $MACHINE = $(uname -m) ] || { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
which gdb >& /dev/null || { echo skipped; exit; }
diff --git a/test/elf/hello-static.sh b/test/elf/hello-static.sh
index a2c9626b..eed8b935 100755
--- a/test/elf/hello-static.sh
+++ b/test/elf/hello-static.sh
@@ -12,6 +12,8 @@ echo -n "Testing $testname ... "
t=out/test/elf/$MACHINE/$testname
mkdir -p $t
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
+
cat <<EOF | $CC -o $t/a.o -c -xc -
#include <stdio.h>
diff --git a/test/elf/ifunc-static.sh b/test/elf/ifunc-static.sh
index 8a25fa1c..b0cf698e 100755
--- a/test/elf/ifunc-static.sh
+++ b/test/elf/ifunc-static.sh
@@ -15,6 +15,8 @@ mkdir -p $t
# IFUNC is not supported on RISC-V yet
[ $MACHINE = riscv64 ] && { echo skipped; exit; }
+[ $MACHINE = armv7l ] && { echo skipped; exit; }
+
# Skip if libc is musl because musl does not support GNU FUNC
ldd --help 2>&1 | grep -q musl && { echo skipped; exit; }
--
2.37.1

View File

@ -0,0 +1,43 @@
From 092673cd7b0fe96e4c6f176c9ea35943e44f984e Mon Sep 17 00:00:00 2001
Message-Id: <092673cd7b0fe96e4c6f176c9ea35943e44f984e.1660813566.git.github@sicherha.de>
From: Christoph Erhardt <github@sicherha.de>
Date: Sat, 6 Aug 2022 09:18:54 +0200
Subject: [PATCH] Use system-compatible include path for `xxhash.h`
Distributors that build mold against the system-provided xxHash package
expect its header file `xxhash.h` in the top-level include directory,
not in an `xxhash` subdirectory. Adjust the include path and the
`#include` directive accordingly.
---
Makefile | 1 +
mold.h | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 1301236c..35e7fe76 100644
--- a/Makefile
+++ b/Makefile
@@ -47,6 +47,7 @@ CXXFLAGS = -O2
MOLD_CXXFLAGS := -std=c++20 -fno-exceptions -fno-unwind-tables \
-fno-asynchronous-unwind-tables \
+ -Ithird-party -Ithird-party/xxhash \
-DMOLD_VERSION=\"$(VERSION)\" -DLIBDIR="\"$(LIBDIR)\""
MOLD_LDFLAGS := -pthread -lz -lm -ldl
diff --git a/mold.h b/mold.h
index a50127ed..b8df38d3 100644
--- a/mold.h
+++ b/mold.h
@@ -32,7 +32,7 @@
#endif
#define XXH_INLINE_ALL 1
-#include "third-party/xxhash/xxhash.h"
+#include <xxhash.h>
#ifdef _MSC_VER
# define unreachable() __assume(0)
--
2.37.2

View File

@ -1,47 +0,0 @@
From 3dcb7063c56a9119cb7e2e2c4c56bdc4d3b2d28a Mon Sep 17 00:00:00 2001
Message-Id: <3dcb7063c56a9119cb7e2e2c4c56bdc4d3b2d28a.1659770551.git.github@sicherha.de>
In-Reply-To: <b0b069ece8d76914670bfdfd04ea628477c95988.1659770551.git.github@sicherha.de>
References: <b0b069ece8d76914670bfdfd04ea628477c95988.1659770551.git.github@sicherha.de>
From: Christoph Erhardt <github@sicherha.de>
Date: Sat, 6 Aug 2022 09:18:54 +0200
Subject: [PATCH 2/2] Use system-compatible include path for `xxhash.h`
Distributors that build mold against the system-provided xxHash package
expect its header file `xxhash.h` in the top-level include directory,
not in an `xxhash` subdirectory. Adjust the include path and the
`#include` directive accordingly.
---
Makefile | 3 ++-
mold.h | 2 +-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index b19c34c0..0f66c6df 100644
--- a/Makefile
+++ b/Makefile
@@ -45,7 +45,8 @@ CFLAGS = -O2
CXXFLAGS = -O2
MOLD_CXXFLAGS := -std=c++20 -fno-exceptions -fno-unwind-tables \
- -fno-asynchronous-unwind-tables -Ithird-party \
+ -fno-asynchronous-unwind-tables \
+ -Ithird-party -Ithird-party/xxhash \
-DMOLD_VERSION=\"$(VERSION)\" -DLIBDIR="\"$(LIBDIR)\""
MOLD_LDFLAGS := -pthread -lz -lm -ldl
diff --git a/mold.h b/mold.h
index 9464d8ad..b6478960 100644
--- a/mold.h
+++ b/mold.h
@@ -27,7 +27,7 @@
#include <vector>
#define XXH_INLINE_ALL 1
-#include <xxhash/xxhash.h>
+#include <xxhash.h>
#ifdef NDEBUG
# define unreachable() __builtin_unreachable()
--
2.37.1

View File

@ -1,5 +1,5 @@
Name: mold
Version: 1.4.0
Version: 1.4.1
Release: 1%{?dist}
Summary: A Modern Linker
@ -14,10 +14,8 @@ Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
# in the Fedora tbb package)
Patch0: tbb-strip-werror.patch
# Skip failing tests on armv7l
Patch1: 0001-Skip-tests-that-fail-on-armv7l.patch
# Allow building against the system-provided `xxhash.h`
Patch2: 0002-Use-system-compatible-include-path-for-xxhash.h.patch
Patch2: 0001-Use-system-compatible-include-path-for-xxhash.h.patch
# mold can currently produce native binaries for these architectures only
ExclusiveArch: %{ix86} x86_64 %{arm} aarch64 riscv64
@ -95,16 +93,22 @@ fi
%make_build %{build_args} test
%files
%license LICENSE
%license %{_docdir}/mold/LICENSE
%ghost %{_bindir}/ld
%{_bindir}/mold
%{_bindir}/ld.mold
%{_bindir}/ld64.mold
%{_libdir}/mold/mold-wrapper.so
%{_libexecdir}/mold/ld
%{_mandir}/man1/ld.mold.1*
%{_mandir}/man1/mold.1*
%changelog
* Thu Aug 18 2022 Christoph Erhardt <fedora@sicherha.de> - 1.4.1-1
- Bump version to 1.4.1 (#2119324)
- Refresh patch
- Remove superfluous directory entries from `%files`
* Sun Aug 07 2022 Christoph Erhardt <fedora@sicherha.de> - 1.4.0-1
- Bump version to 1.4.0 (#2116004)
- Refresh patch

View File

@ -1 +1 @@
SHA512 (mold-1.4.0.tar.gz) = 7b7c4a7bac6bbc6e22372d93d94a6cb804c7017eba16b90e9bbc42b9608108c724ef55337aabdd9ce2f5244b94c8fd64311e70e18b5f8cf5f68533c2639e550d
SHA512 (mold-1.4.1.tar.gz) = 304caf4e9d9b24170a9442a84036790407bd02609a5d07c31e5f0f6285128099cbc962571804636a5da55afda59b447c12218f9e4d402fbfa55ebc354814bdda