Rework compilation flags patch

This commit is contained in:
bloch@verdurin.com 2015-03-01 22:36:02 +00:00
parent a2f06b22a7
commit c6f5947946
1 changed files with 8 additions and 8 deletions

View File

@ -1,11 +1,11 @@
--- mmseq_0.9.14/src/Makefile 2011-09-20 11:27:55.000000000 +0100
+++ mmseq_0.9.14.new/src/Makefile 2011-10-07 16:13:01.261226334 +0100
@@ -35,7 +35,7 @@
$(CXX) $(CXXFLAGS) -c sokal.cc
diff -ur mmseq-1.0.8a/src/Makefile mmseq-1.0.8a-new/src/Makefile
--- mmseq-1.0.8a/src/Makefile 2014-01-09 22:45:54.000000000 +0000
+++ mmseq-1.0.8a-new/src/Makefile 2015-03-01 22:35:22.349761703 +0000
@@ -75,6 +75,7 @@
$(CXX) ${OPT} -c sokal.cc
fasta.o : fasta.c fasta.h
- $(CC) -c fasta.c
+ $(CC) $(CXXFLAGS) -c fasta.c
+ $(CC) $(CXXFLAGS) -c fasta.c
bam2hits : fasta.o bam2hits.cpp
${CXX} ${MACROS} $(CXXFLAGS) -fopenmp -O3 fasta.o bam2hits.cpp -o bam2hits ${LIBS_B2H}
uh.o : uh.cpp uh.hh
$(CXX) ${OMP} ${OPT} -c uh.cpp