patch to fix linking with the new --no-add-needed default

This commit is contained in:
Kalev Lember 2010-02-25 22:21:42 +00:00
parent b42f7ae088
commit 0036cdb4eb
2 changed files with 37 additions and 0 deletions

View File

@ -0,0 +1,34 @@
diff -up mmapper-2.0.4-final2-source/CMakeLists.txt.no-add-needed mmapper-2.0.4-final2-source/CMakeLists.txt
--- mmapper-2.0.4-final2-source/CMakeLists.txt.no-add-needed 2009-05-26 18:41:10.000000000 +0300
+++ mmapper-2.0.4-final2-source/CMakeLists.txt 2010-02-26 00:17:02.000000000 +0200
@@ -7,6 +7,9 @@ set(QT_USE_QTXML TRUE)
set(QT_USE_QTOPENGL TRUE)
include(${QT_USE_FILE})
+find_package(OpenGL REQUIRED)
+find_package(ZLIB REQUIRED)
+
# Get SVN revision number
find_package(Subversion)
if (Subversion_FOUND)
diff -up mmapper-2.0.4-final2-source/src/CMakeLists.txt.no-add-needed mmapper-2.0.4-final2-source/src/CMakeLists.txt
--- mmapper-2.0.4-final2-source/src/CMakeLists.txt.no-add-needed 2009-05-26 18:41:10.000000000 +0300
+++ mmapper-2.0.4-final2-source/src/CMakeLists.txt 2010-02-26 00:18:38.000000000 +0200
@@ -148,6 +148,8 @@ include_directories(
${CMAKE_CURRENT_SOURCE_DIR}/preferences
${CMAKE_CURRENT_SOURCE_DIR}/proxy
${CMAKE_CURRENT_SOURCE_DIR}/3rdparty
+ ${OPENGL_INCLUDE_DIR}
+ ${ZLIB_INCLUDE_DIR}
)
QT4_WRAP_CPP(mmapper_MOC_SRCS ${mmapper_MOC_HDRS})
@@ -165,6 +167,8 @@ add_executable(mmapper WIN32
target_link_libraries(mmapper
${QT_QTMAIN_LIBRARY}
${QT_LIBRARIES}
+ ${OPENGL_gl_LIBRARY}
+ ${ZLIB_LIBRARIES}
)
# Begin CPack Settings

View File

@ -22,6 +22,7 @@ License: GPLv2
URL: http://sourceforge.net/projects/mmapper
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}-%{extraversion}-source.tar.gz
Patch1: mmapper-fix-renderer-crash.patch
Patch2: mmapper-2.0.4-no-add-needed.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -40,6 +41,7 @@ data in real time and show player's position in a map.
%prep
%setup -q -n %{name}-%{version}-%{extraversion}-source
%patch1 -p0 -b .renderer-crash
%patch2 -p1 -b .no-add-needed
%build
@ -90,6 +92,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
%changelog
* Thu Feb 25 2010 Kalev Lember <kalev@smartlink.ee> - 2.0.4-5.final2
- Added patch to fix renderer crash with Qt 4.6
- patch to fix linking with the new --no-add-needed default
* Thu Feb 25 2010 Kalev Lember <kalev@smartlink.ee> - 2.0.4-4.final2
- Rebuilt with Qt 4.6