29 lines
893 B
Diff
29 lines
893 B
Diff
From e09b298273994b20cc8747765a567d716e241fd2 Mon Sep 17 00:00:00 2001
|
|
From: Isuru Fernando <isuruf@gmail.com>
|
|
Date: Thu, 4 Feb 2021 01:59:08 +0000
|
|
Subject: [PATCH 2/2] [PATCH][mlir] Fix building unittests in in-tree build
|
|
|
|
Reviewed By: mehdi_amini
|
|
|
|
Differential Revision: https://reviews.llvm.org/D95978
|
|
---
|
|
mlir/CMakeLists.txt | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/mlir/CMakeLists.txt b/mlir/CMakeLists.txt
|
|
index baacbdd3..5d21312 100644
|
|
--- a/mlir/CMakeLists.txt
|
|
+++ b/mlir/CMakeLists.txt
|
|
@@ -133,7 +133,7 @@ add_subdirectory(lib)
|
|
add_subdirectory(lib/CAPI)
|
|
if (MLIR_INCLUDE_TESTS)
|
|
add_definitions(-DMLIR_INCLUDE_TESTS)
|
|
- if (TARGET gtest)
|
|
+ if (EXISTS ${LLVM_MAIN_SRC_DIR}/utils/unittest/googletest/include/gtest/gtest.h)
|
|
add_subdirectory(unittests)
|
|
else()
|
|
message(WARNING "gtest not found, unittests will not be available")
|
|
--
|
|
1.8.3.1
|
|
|